ScreenBlankerEngine

A forum for general AmigaOS 4.x support questions that are not platform-specific

ScreenBlankerEngine

Postby Deniil » Mon Jul 11, 2011 9:36 pm

I have a suggestion/bug report for the screen blanker that comes with OS4.

It is clear that it listens to the multimedia don't-blank-flag in application.library. It is also fairly obvious that MPlayer tells app.lib that it shouldn't allow blanking when it's playing. Ok, great.

When MPlayer crashes (and it crashes a lot, especially when you are forced to use SDL because the P96 vo driver fails with horizontal alignment sometimes) it never tells app.lib to allow blanking again so the screen blanker never activates.

Now the bug report/suggestion:
Of course the ScreenBlankerEngine should respect the don't-blank-signal for automatic timeout blanking but it also fails to listen to any of its hotkeys too. This is not desirable IMO and I consider it a bug.
What is also surely a bug is that you cannot even use the Quit-hotkey in this situation. It is as if it simply ignores all hotkeys when it is told not to blank. I see no point in this, especially not in this real world where movie players crash a lot. But most importantly it should allow manual blank so that you at least have some way of switching off the monitor in this situation.
Deniil
 
Posts: 108
Joined: Mon Jul 11, 2011 7:59 pm

Re: ScreenBlankerEngine

Postby abalaban » Tue Jul 12, 2011 9:39 am

I have had such situations too where ScreenBlankerEngine refuse to launch even using the hotkeys. However I never noticed it was linked with a crashed app, I'll try to take it with more attention next time.
AmigaOne X1000 running AOS 4 beta
AmigaOne XE/G4
Amiga 1200/PPC 603e + BVision PPC
User avatar
abalaban
Beta Tester
Beta Tester
 
Posts: 456
Joined: Mon Dec 20, 2010 3:09 pm
Location: France


Return to General AmigaOS

Who is online

Users browsing this forum: No registered users and 3 guests