Update 3: USBCtrl only works with USB Stack v53.11

A forum for general AmigaOS 4.x support questions that are not platform-specific

Update 3: USBCtrl only works with USB Stack v53.11

Postby jaokim » Mon Aug 29, 2011 10:37 pm

When updated to 4.1 update 3 on my A1XE (no HW-fixes), I get an error: "Error: USBCtrl only works with USB Stack v53.11" when booting. My USB stuff (mouse, etc) does however work, but not with scroll wheel.

Trying to manually run USBCtrl START, does not work.
When running USBInspector, it tells me I need a USB stack running (Prefs/USB does however work).

Kicklayout: 53.3
Kickstart/usbresource.library: usbresource.library 53.11 (2011-06-05)
Kickstart/usbsys.device: usbsys.device 53.11 (2011-06-05)
Kickstart/uhci.usbhcd: uhci.usbhcd 53.7 (2009-12-10)
Kickstart/hub.usbfd: hub.usbfd 53.8 (2011-05-21)
Kickstart/hunk.library.kmod: hunk.library 53.4 (2011-05-02)
Kickstart/ohci.usbhcd: ohci.usbhcd 53.18 (2011-06-17)
Kickstart/bootkeyboard.usbfd: bootkeyboard.usbfd 52.3 (2007-04-01)
Kickstart/bootmenu.kmod: bootmenu.kmod 53.3 (2008-12-23)
Kickstart/bootmouse.usbfd: bootmouse.usbfd 53.1 (2009-11-21)
Kickstart/ehci.usbhcd: ehci.usbhcd 53.15 (2011-06-17)

USBCtrl: 53.11
User avatar
jaokim
Beta Tester
Beta Tester
 
Posts: 89
Joined: Sat Jun 18, 2011 1:41 am

Re: Update 3: USBCtrl only works with USB Stack v53.11

Postby Rigo » Mon Aug 29, 2011 11:08 pm

Have you performed a cold reboot yet?

It sounds like you are running the old versions of the kickstart modules which are still in memory.

Simon
User avatar
Rigo
AmigaOS Core Developer
AmigaOS Core Developer
 
Posts: 330
Joined: Mon Jan 17, 2011 10:42 pm

Re: Update 3: USBCtrl only works with USB Stack v53.11

Postby jaokim » Mon Aug 29, 2011 11:18 pm

I did a hard reboot.
But now I remember that I have my Kickstart on that old IDE-harddrive, since I can't boot from my SATA-drive on my 3114-card.
Doh! Sorry for the disturbance. And thanks for quick answer!
User avatar
jaokim
Beta Tester
Beta Tester
 
Posts: 89
Joined: Sat Jun 18, 2011 1:41 am


Return to General AmigaOS

Who is online

Users browsing this forum: No registered users and 2 guests