Jerky mouse with dockies enabled on X1000/Radeon 9250

A forum for general AmigaOS 4.x support questions that are not platform-specific

Re: Jerky mouse with dockies enabled on X1000/Radeon 9250

Postby Srtest » Fri Jan 15, 2016 5:05 am

For some reason I can't explain, linking all libpng.so libraries to libpng16.so.16.20.0 produces better docky performance and maybe even beyond dockies (I also use a bunch of them) while breaking compatibily with some older AOS4 titles (games).

X1000 + Southern Islands + latest drivers - composite and Warp3D on AOS4.1FE.
User avatar
Srtest
 
Posts: 238
Joined: Wed Jun 11, 2014 6:06 pm

Re: Jerky mouse with dockies enabled on X1000/Radeon 9250

Postby K-L » Sat Jan 16, 2016 10:24 am

This has nothing to do with the reported problem by the way. You'd better open a new thread about your topic ;)
--
AmigaONE X1000 / Radeon 2400 Pro (R610LE) / AmigaOS 4.1 Final Edition
Samm440ep/733Mhs (o/c) / Radeon M9 / AmigaOS 4.1 Final Edition
K-L
 
Posts: 70
Joined: Thu Sep 08, 2011 9:35 pm
Location: Lyon, France

Re: Jerky mouse with dockies enabled on X1000/Radeon 9250

Postby Srtest » Sun Jan 17, 2016 12:40 am

K-L wrote:This has nothing to do with the reported problem by the way. You'd better open a new thread about your topic ;)


You reported a jerky mouse in combination with one or more dockies. You reported an issue of performance and multitasking as it relates to that.

What I've found out was an accident (a game reported incompatibility with the newest libpng.so library). After reverting to the version supplied with Final Edition I've noticed somewhat of an operation that is less smooth as can be seen in what I described. Not something that is a main improvement or a so called fix for your situation, just that it might help a little or it might just effect me, ot it might have a bigger effect in your situation (which I didn't exactly experience).
User avatar
Srtest
 
Posts: 238
Joined: Wed Jun 11, 2014 6:06 pm

Re: Jerky mouse with dockies enabled on X1000/Radeon 9250

Postby K-L » Sun Jan 17, 2016 11:32 am

Regardin my situation, Hans already replied that this is a bug in the Radeon HD driver (DMA) on AmigaONE X1000.
--
AmigaONE X1000 / Radeon 2400 Pro (R610LE) / AmigaOS 4.1 Final Edition
Samm440ep/733Mhs (o/c) / Radeon M9 / AmigaOS 4.1 Final Edition
K-L
 
Posts: 70
Joined: Thu Sep 08, 2011 9:35 pm
Location: Lyon, France

Re: Jerky mouse with dockies enabled on X1000/Radeon 9250

Postby Hans » Mon Mar 14, 2016 3:21 am

K-L wrote:Regardin my situation, Hans already replied that this is a bug in the Radeon HD driver (DMA) on AmigaONE X1000.

Actually, it's DMA in the graphics.libarary, not the driver.

A semi-random thought, could you (and anyone else experiencing the jerkiness) try disabling anti-aliased text rendering? I think that it's in the font preferences (or maybe GUI prefs). Let me know if that reduces the jerkiness.

Hans
http://hdrlab.org.nz/ - Amiga OS 4 projects, programming articles and more. Home of the RadeonHD driver for Amiga OS 4.x project.
User avatar
Hans
AmigaOS Core Developer
AmigaOS Core Developer
 
Posts: 700
Joined: Tue Dec 21, 2010 10:25 pm
Location: New Zealand

Re: Jerky mouse with dockies enabled on X1000/Radeon 9250

Postby Raziel » Mon Mar 14, 2016 8:43 am

Setting font prefs to an unchecked "Antialiasing if possible" shows no difference for me
If slaughterhouses had glass walls, everyone would be a vegetarian. ~ Sir Paul McCartney
-
Did everything just taste purple for a second? ~ Philip J. Fry
-
Ain't got no cash, ain't got no style, ladies vomit when I smile. ~ Dr. John Zoidberg
User avatar
Raziel
 
Posts: 723
Joined: Sat Jun 18, 2011 5:00 pm
Location: A haunted Castle somewhere in the Bavarian Mountains

Re: Jerky mouse with dockies enabled on X1000/Radeon 9250

Postby K-L » Thu Apr 07, 2016 9:52 pm

I'd say that it reduces the jerkyness in very subtle way (but I can also reduce the behaviour if I get rid of my dockies).
--
AmigaONE X1000 / Radeon 2400 Pro (R610LE) / AmigaOS 4.1 Final Edition
Samm440ep/733Mhs (o/c) / Radeon M9 / AmigaOS 4.1 Final Edition
K-L
 
Posts: 70
Joined: Thu Sep 08, 2011 9:35 pm
Location: Lyon, France

Re: Jerky mouse with dockies enabled on X1000/Radeon 9250

Postby zzd10h » Mon Jan 02, 2017 6:03 pm

@Hans
"K-L guessed right, it is DMA (and text rendering) related. I can't say when a fix will be released, sorry."

According to Broadblues, DMA fix has been delivered in update 1.
http://amigaworld.net/modules/newbb/viewtopic.php?mode=viewtopic&topic_id=41524&forum=14&start=100&viewmode=flat&order=0#791508

Effectively, my OS4 seems faster and no more "jerky mouse" symptom.
Thank you !
http://apps.amistore.net/zTools
X1000 - AmigaOS 4.1.6 / 4.1 FE
zzd10h
 
Posts: 543
Joined: Sun Sep 16, 2012 6:40 am
Location: France

Previous

Return to General AmigaOS

Who is online

Users browsing this forum: No registered users and 1 guest