console control codes in 4.1FE

A forum for general AmigaOS 4.x support questions that are not platform-specific

Re: console control codes in 4.1FE

Postby nbache » Fri Feb 09, 2018 9:29 pm

xenic wrote:
nbache wrote:On my system (on a clean public 4.1. Final Edition) I can press Ctrl-J fine, it does the same as when I press Enter or Return.
That bug was reported back in September 2017 in the "AmigaOS Shell issue (FE Update 1)" topic and Tony said he fixed it. As a beta tester, it might work correctly for you.
Ah, yes, now I remember (this is the thread you refer to, right?).

But if you notice, the thread ends with Tony still having an issue with his fix attempt, so I believe it has never been completed. At least the bug is still outstanding - which also explains that it still works like I described above, not only in my public installation, but also in my beta installation (note that in the above statement I specifically mentioned a clean public 4.1 Final Edition).

Best regards,

Niels
Last edited by nbache on Sat Feb 10, 2018 12:13 am, edited 1 time in total.
User avatar
nbache
Beta Tester
Beta Tester
 
Posts: 1274
Joined: Mon Dec 20, 2010 8:25 pm
Location: Copenhagen, Denmark

Re: console control codes in 4.1FE

Postby tonyw » Sat Feb 10, 2018 12:00 am

Ah, yes, that is a real pain, that one. If you play with the old 68K version, it doesn't work properly either. You can't "up-arrow" to the previous command if it was a multiple, and the "history" is also wrong.

I'll spend some more time on it soon, but it's not trivial. The whole command history is involved, and that also means embedded escape sequences.
cheers
tony
User avatar
tonyw
AmigaOS Core Developer
AmigaOS Core Developer
 
Posts: 1315
Joined: Wed Mar 09, 2011 2:36 pm
Location: Sydney, Australia

Previous

Return to General AmigaOS

Who is online

Users browsing this forum: No registered users and 9 guests