Shell/Console iconification bug

A forum for general AmigaOS 4.x support questions that are not platform-specific

Shell/Console iconification bug

Postby xenic » Sun Jan 01, 2017 7:07 pm

If the user moves, renames or deletes the shell icon in SYS:System, a shell/console will crash if you iconify it. If you ignore the DSI in grim reaper the system continues but the the shell is apprently left in an iconified state with no way to reopen it.

In several personal reaction programs I've written; when IIcon->GetDiskObject() fails to find the program icon then calling IIntuition->IDoMethod(winObj, WM_ICONIFY, NULL) will use the a default icon (def_window). Apparently, shell/console windows are being iconified in a way that doesn't automatically supply a default icon and the shell/console code may need to manually check for the presence of the desired icon and use the default icon (def_window) if it's not found.

It's unlikely that a user might move, rename or delete the shell icon in SYS:System but potential crashes should be avoided and fixed.
AmigaOne X1000 with 2GB memory - OS4.1 FE
xenic
 
Posts: 938
Joined: Sun Jun 19, 2011 1:06 am

Re: Shell/Console iconification bug

Postby tonyw » Mon Jan 02, 2017 8:16 am

You are quite right and I am ashamed that this bug exists. I went to some trouble to prevent it in the case of the Console Prefs utility, but for some reason did not copy the code into the console.

Ah well...
cheers
tony
User avatar
tonyw
AmigaOS Core Developer
AmigaOS Core Developer
 
Posts: 1186
Joined: Wed Mar 09, 2011 2:36 pm
Location: Sydney, Australia

Re: Shell/Console iconification bug

Postby Raziel » Mon Jan 02, 2017 1:13 pm

Soooo...this bug fixed and up for the next update yet? :-)
If slaughterhouses had glass walls, everyone would be a vegetarian. ~ Sir Paul McCartney
-
Did everything just taste purple for a second? ~ Philip J. Fry
-
Ain't got no cash, ain't got no style, ladies vomit when I smile. ~ Dr. John Zoidberg
User avatar
Raziel
 
Posts: 727
Joined: Sat Jun 18, 2011 5:00 pm
Location: A haunted Castle somewhere in the Bavarian Mountains


Return to General AmigaOS

Who is online

Users browsing this forum: No registered users and 1 guest