What is required to use MiniGL?

A forum for general AmigaOS 4.x support questions that are not platform-specific

What is required to use MiniGL?

Postby jschultz » Wed Apr 12, 2017 3:45 pm

Hi

I recently decided to 'recreate' my X1000 from scratch (new SSD, new Compact flash card etc). I set it up with a DOS/03 partition for amigaboot.of and a bootable SFS/02 partition for the AmigaOS 4.1 FE, and proceeded to install AmigaOS 4.1 FE. Everything works as expected, as far as I can see, except for one thing....

I can't seem to get MiniGL to work.

I have downloaded miniGL.lha and unpacked it and copied the minigl.library and the mglut.library to libs (version 2.20 for both). I then ran the example 'picksquare' that comes in the .lha file. But it fails with the message:

Could not create an OpenGL window/context

Similarly the GLGalore plugin module in Hollywood 7, that uses miniGL, fails to initialize MiniGL.

The funny part is, that when i put on my old SSD (my existing old installation) back and boot from it, it does work. Therefore this is not a hardware issue. And I must have done something right at some time in the past to get MiniGL to work. But I can't remember what I did or did not do then :-)

My question is therefore - what does it take to make MiniGL work apart from locating the two library files to libs? Any help is appreciated.....

regards
Jesper
jschultz
 
Posts: 6
Joined: Mon Jun 27, 2011 9:59 pm

Re: What is required to use MiniGL?

Postby broadblues » Wed Apr 12, 2017 5:52 pm

MiniGL requires Warp3d

If you have a Southern Islands card you will need to buy Warp3d SI from A_Eon (unless you already have it from you previous x1k setup)

r200 and r300 cards work with the driver that comes with the OS.

There is no driver for the other kinds at the moment.
User avatar
broadblues
AmigaOS Core Developer
AmigaOS Core Developer
 
Posts: 478
Joined: Sat Jun 18, 2011 3:40 am
Location: Portsmouth, UK

Re: What is required to use MiniGL?

Postby jschultz » Wed Apr 12, 2017 10:19 pm

Hi

Doh! - I never wrote that down in my installation notes for the previous setup. It was the Warp3D_SI driver all right. I bought it then, installed it and promptly forgot all about it.

Thanks a lot for reminding me :D

I also got to test my new Acer/Predator ultrawide screen with the X1000. It looks stunning, connected through the HDMI port, though of course the Radeon card does not support its 3440 x 1440 native resolution. Running at 1920 x 1080 it displays with black borders. But very crisp and sharp. This means I can have the PC connected on the Display port and the Amiga on the HDMI port and switch happily between them... as in running Hollowood on both machines and compare speed etc. for my code. This turned out to be a good day.

regards
Jesper
jschultz
 
Posts: 6
Joined: Mon Jun 27, 2011 9:59 pm

Re: What is required to use MiniGL?

Postby davebraco » Wed Apr 12, 2017 11:28 pm

though of course the Radeon card does not support its 3440 x 1440 native resolution


What graphic card do you have? It seems some manage get 4K resolution on their miggies :
https://www.youtube.com/watch?v=gZCla-omFyA
µA1 256mo SATA -> lend to a dev
A1200PPC 256Mo MediatorTX Radeon9250 SATA RTL8029 SOLO-1
Sam440ep 533mhz 512mo 64Go SSD
Sam460ex 1150mhz 2Go RadeonHD 6570LP ENVY24HT
AmigaOne X1000 4Go SSD R9 270X Catweasel MK4
AmigaOne X5000 -> work in progress
User avatar
davebraco
Beta Tester
Beta Tester
 
Posts: 139
Joined: Sat Jun 18, 2011 8:06 am
Location: Belgium

Re: What is required to use MiniGL?

Postby jschultz » Thu Apr 13, 2017 2:03 pm

Hi

I have a RadeonHD R7 250x 1Gb gfx card. Its top resolution is 2560 x 1600 as far a I know. However it will display fine on a 4K screen (LG TV) though not in 4K native resolution. Instead it selects a lesser resolution (one third of 4K for both dimensions - 1360 x 768) and 'stretches' it to fit the entire screen. So it still looks cool for games on a 55" screen. I can force a 1920 x 1080 on the 4K TV. But then it clips the picture a bit - enough to be annoying, since the ratio does not fit well with the 4K native ratio.

regards
Jesper
jschultz
 
Posts: 6
Joined: Mon Jun 27, 2011 9:59 pm


Return to General AmigaOS

Who is online

Users browsing this forum: No registered users and 7 guests