Scaling Icons

A forum for general AmigaOS 4.x support questions that are not platform-specific

Re: Scaling Icons

Postby broadblues » Sun Apr 30, 2017 5:09 pm

I make a new fresh OS4,1 install in a new partition.
After that, the scaling icons works fine. The PNG icons shows like a PNG images.
Copy PNGiconmodule and the correct png1.2 so library.


I don't think png iconmodeule uses libpng.so it's much older than the shared objects system...

PNG icons now shows well and scaling works. So the problem is in a later installation. I think it goes for the Enhanced Pack, I will install it in the new partition and comment you.


Nothin in Enhancer could screw up icon scaling.

Try comparing the versions of LIBS:workbench.library and LIBS:icon.library betwen the two installs.

Also try copy the ENVARC:Sys/workbench.prefs from the working partition to the broken one see if that fixes it.
User avatar
broadblues
AmigaOS Core Developer
AmigaOS Core Developer
 
Posts: 481
Joined: Sat Jun 18, 2011 3:40 am
Location: Portsmouth, UK

Re: Scaling Icons

Postby Ribdevil » Sun Apr 30, 2017 10:07 pm

Thanks Andy.

The problem is the workbench.prefs file.
Now all works again.

Virginio
User avatar
Ribdevil
 
Posts: 33
Joined: Tue Jun 28, 2011 8:11 pm

Re: Scaling Icons

Postby nbache » Sun Apr 30, 2017 10:13 pm

Ribdevil wrote:The problem is the workbench.prefs file.
Now all works again.
So you should probably, just to be safe, try saving your workbench.prefs from the prefs program and make sure it still works correctly.

Otherwise you may get problems if you want to change some other setting in there later on.

Best regards,

Niels
User avatar
nbache
Beta Tester
Beta Tester
 
Posts: 1211
Joined: Mon Dec 20, 2010 8:25 pm
Location: Copenhagen, Denmark

Re: Scaling Icons

Postby Ribdevil » Mon May 01, 2017 1:01 pm

Yes, I make it.
Save the prefs, and reset. Make some changes and save again.
Reboot and changes are Ok. Restore to the values I like and save.
Reboot and confirm all is good.

Thanks to all for your help.

Best regards.

Virginio
User avatar
Ribdevil
 
Posts: 33
Joined: Tue Jun 28, 2011 8:11 pm

Previous

Return to General AmigaOS

Who is online

Users browsing this forum: No registered users and 3 guests