Rawdisk wants printer connection

A forum for general AmigaOS 4.x support questions that are not platform-specific

Rawdisk wants printer connection

Postby kilaueabart » Fri Nov 03, 2017 5:10 am

It seems to me something must be wrong here. Every time I use rawdisk to copy an image to a flash drive, I first need to cancel approximately twelve alerts of "Printer device not found." After that, the app tells me that it has succeeded in making the copy (although the drive remains "Uninitialized" and I don't know how to find out whether the supposedly copied .img is really there or not).
User avatar
kilaueabart
 
Posts: 527
Joined: Mon Mar 05, 2012 3:36 am

Re: Rawdisk wants printer connection

Postby Raziel » Fri Nov 03, 2017 8:46 am

kilaueabart wrote:It seems to me something must be wrong here. Every time I use rawdisk to copy an image to a flash drive, I first need to cancel approximately twelve alerts of "Printer device not found." After that, the app tells me that it has succeeded in making the copy (although the drive remains "Uninitialized" and I don't know how to find out whether the supposedly copied .img is really there or not).

I'd let Snoopy run and see where those Printer device accesses come from.
But first check in RawDisk if there isn't some PRT: device listed (not sure how it should appear thee, but you never know)
If slaughterhouses had glass walls, everyone would be a vegetarian. ~ Sir Paul McCartney
-
Did everything just taste purple for a second? ~ Philip J. Fry
-
Ain't got no cash, ain't got no style, ladies vomit when I smile. ~ Dr. John Zoidberg
User avatar
Raziel
 
Posts: 815
Joined: Sat Jun 18, 2011 5:00 pm
Location: A haunted Castle somewhere in the Bavarian Mountains

Re: Rawdisk wants printer connection

Postby tonyw » Fri Nov 03, 2017 10:49 am

It's not a RawDisk problem, but a usbprinter.device problem - usbprinter.device says, when queried, that it is a disk-based device, so RawDisk then has to check it out, like all the other disks. I seem to remember writing a BZ about it. That's as I remember it, anyway, this problem was first raised many years ago.

Writing to a volume with RawDisk will not "Initialise" it. If you are copying to an unmounted volume, the result may be mountable, but it won't be mounted until a reboot or manual Mount command. Be careful, you can easily destroy a mounted volume this way.
cheers
tony
User avatar
tonyw
AmigaOS Core Developer
AmigaOS Core Developer
 
Posts: 1315
Joined: Wed Mar 09, 2011 2:36 pm
Location: Sydney, Australia

Re: Rawdisk wants printer connection

Postby xenic » Fri Nov 03, 2017 5:34 pm

tonyw wrote:It's not a RawDisk problem, but a usbprinter.device problem - usbprinter.device says, when queried, that it is a disk-based device, so RawDisk then has to check it out, like all the other disks. I seem to remember writing a BZ about it. That's as I remember it, anyway, this problem was first raised many years ago.


If kilaueabartl's requesters say "Printer device not found" the problem might not be usbprinter.device. When I get requesters caused by usbprinter.device, the requester title is "USB printer" and the message is "The driver failed to access the device". Some programs that open the printer.device to get the current settings can also cause the requesters with the current usbprinter.device. When I open FinalWriter for the first time (without my printer turned on, I get a single requester but if I quit Finalwriter and restart it, I will get multiple requesters that need to be cancelled.

The usbprinter.device requester problem first appeared with the usbprinter.device in OS4.1update1. The OS4.1update1 usbprinter.device is version 53.2 (11/12/2009). The previous usbprinter.device was version 52.8 (03/11/2008), which I've been using for years now to avoid all the requesters. Assuming that the OS4 sources are kept in a proper repository like SVN, it shouldn't be too difficult to check out the older version, diff it against the current version and see what changes resulted in all the requesters that can occur with the newer version.

I think the printer prefs would not let you change the "Port device" with the old usbprinter.device unless there was a printer connected (and possibly turned on). I believe the newer usbprinter.device fixed that problem but introduced the multiple requester problem.
AmigaOne X1000 with 2GB memory - OS4.1 FE
xenic
 
Posts: 1146
Joined: Sun Jun 19, 2011 1:06 am

Re: Rawdisk wants printer connection

Postby xenic » Fri Nov 03, 2017 5:45 pm

kilaueabart wrote:It seems to me something must be wrong here. Every time I use rawdisk to copy an image to a flash drive, I first need to cancel approximately twelve alerts of "Printer device not found." After that, the app tells me that it has succeeded in making the copy (although the drive remains "Uninitialized" and I don't know how to find out whether the supposedly copied .img is really there or not).


On my X5000, I had to set up a flash drive with Media Toolbox and set the filesystem. I rebooted, formatted the flash drive and rebooted again. Then I used Rawdisk to copy the image to the flash drive and rebooted. It was then accessible on Workbench. I don't know if the same will work on your system. The second time I wanted to copy an ISO image to a USB flash drive, I opened the ISO image with diskimage device and just copied the files to an already initialized and formatted flash drive.
AmigaOne X1000 with 2GB memory - OS4.1 FE
xenic
 
Posts: 1146
Joined: Sun Jun 19, 2011 1:06 am

Re: Rawdisk wants printer connection

Postby kilaueabart » Sat Nov 04, 2017 4:27 am

xenic wrote:
tonyw wrote:It's not a RawDisk problem, but a usbprinter.device problem - usbprinter.device says, when queried, that it is a disk-based device, so RawDisk then has to check it out, like all the other disks. I seem to remember writing a BZ about it. That's as I remember it, anyway, this problem was first raised many years ago.


If kilaueabartl's requesters say "Printer device not found" the problem might not be usbprinter.device. When I get requesters caused by usbprinter.device, the requester title is "USB printer" and the message is "The driver failed to access the device".

OK, senile dementia raising its ugly head again. It is in fact a usbprinter requester. I just can't remember details for a whole minute anymore.

I also found out on rechecking the matter, if I use the icon in Workbench:Utilities instead of the R^A "Execute a file" gadget, the requester only comes up once. So thank you all, I consider this part of the problem solved.
User avatar
kilaueabart
 
Posts: 527
Joined: Mon Mar 05, 2012 3:36 am

Re: Rawdisk wants printer connection

Postby kilaueabart » Sat Nov 04, 2017 5:21 am

xenic wrote:On my X5000, I had to set up a flash drive with Media Toolbox and set the filesystem. I rebooted, formatted the flash drive and rebooted again. Then I used Rawdisk to copy the image to the flash drive and rebooted. It was then accessible on Workbench. I don't know if the same will work on your system. The second time I wanted to copy an ISO image to a USB flash drive, I opened the ISO image with diskimage device and just copied the files to an already initialized and formatted flash drive.

Unfortunately, Media Toolbox won't let me set the file system to the Fat32 I need. But I have set it so with GParted and tried to dd an .img file to it, but then Uboot on my X5000 complains "** Unrecognized file type **" when I try to boot from it.
So then I try rawdisking another copy of that .img file to the usb thumb drive, and still Uboot sniffs, "** Unrecognized file type **" and refuses to boot.

Mostly I moan about this problem in X5000 - Linux only, but then I thought, mistakenly it turns out, maybe it was a rawdisk, General AmigaOS, problem.
User avatar
kilaueabart
 
Posts: 527
Joined: Mon Mar 05, 2012 3:36 am

Re: Rawdisk wants printer connection

Postby xenic » Sat Nov 04, 2017 4:13 pm

kilaueabart wrote:Unfortunately, Media Toolbox won't let me set the file system to the Fat32 I need. But I have set it so with GParted and tried to dd an .img file to it, but then Uboot on my X5000 complains "** Unrecognized file type **" when I try to boot from it.
So then I try rawdisking another copy of that .img file to the usb thumb drive, and still Uboot sniffs, "** Unrecognized file type **" and refuses to boot.

Mostly I moan about this problem in X5000 - Linux only, but then I thought, mistakenly it turns out, maybe it was a rawdisk, General AmigaOS, problem.

Why would you need to boot AmigaOS from a Fat32 file system?
AmigaOne X1000 with 2GB memory - OS4.1 FE
xenic
 
Posts: 1146
Joined: Sun Jun 19, 2011 1:06 am

Re: Rawdisk wants printer connection

Postby Spectre660 » Sat Nov 04, 2017 4:45 pm

He is trying to install Linux using AmigaOS 4.1FE to create the Linux installer.
The Linux installers need a fat32 formatted USB thumb drive. No problem if you have another OS or system already running.
Rawdisk should be able to copy either a complete installer .img or an empty fat32 .img to a USB thumb drive that he could copy the individual installer files to.(These .img files are smaller than the preinstalled .img that is too big)
But it is not working for him .


xenic wrote:
kilaueabart wrote:Unfortunately, Media Toolbox won't let me set the file system to the Fat32 I need. But I have set it so with GParted and tried to dd an .img file to it, but then Uboot on my X5000 complains "** Unrecognized file type **" when I try to boot from it.
So then I try rawdisking another copy of that .img file to the usb thumb drive, and still Uboot sniffs, "** Unrecognized file type **" and refuses to boot.

Mostly I moan about this problem in X5000 - Linux only, but then I thought, mistakenly it turns out, maybe it was a rawdisk, General AmigaOS, problem.

Why would you need to boot AmigaOS from a Fat32 file system?
Spectre660
 
Posts: 1478
Joined: Sat Jun 18, 2011 3:16 pm
Location: Montserrat

Re: Rawdisk wants printer connection

Postby xenic » Sat Nov 04, 2017 10:15 pm

Spectre660 wrote:He is trying to install Linux using AmigaOS 4.1FE to create the Linux installer.
The Linux installers need a fat32 formatted USB thumb drive. No problem if you have another OS or system already running.
Rawdisk should be able to copy either a complete installer .img or an empty fat32 .img to a USB thumb drive that he could copy the individual installer files to.(These .img files are smaller than the preinstalled .img that is too big)
But it is not working for him .

Since most flash drives come formatted with a FAT filesystem, I'm guessing he tried one of those and it didn't work either? If he initializes the flash drive with Media Toolbox it will also have an RDB. That seems like it could be a problem if the drive is used with Linux although I don't know anything about Linux.

The only filesystems that show up in Media Toolbox are the ones loaded by Kickstart. If he adds CrossDOSFilesystem to kicklayout (MODULE L/CrossDOSFileSystem) and performs a cold boot, several possible FAT filesystems will show up in the Media Toolbox "Select Filesystem/edit details" window. I don't know if doing that is recommended and he's on his own if he wants to try that. He wouldn't want to leave the CrossDOSFilesystem in kicklayout because it could cause boot failures if there is a FAT formatted USB flash drive plugged in when the system is booted. At some point in older OS4 releases I think CrossDOSFilesystem was in Kickstart and kicklayout by default but was moved to SYS:L & removed form kicklayout to avoid problems like the one I mentioned.
Last edited by xenic on Sun Nov 05, 2017 5:35 pm, edited 1 time in total.
AmigaOne X1000 with 2GB memory - OS4.1 FE
xenic
 
Posts: 1146
Joined: Sun Jun 19, 2011 1:06 am

Next

Return to General AmigaOS

Who is online

Users browsing this forum: No registered users and 2 guests