AmiUpdate?

A forum for general AmigaOS 4.x support questions that are not platform-specific

AmiUpdate?

Postby daveyw » Sat May 12, 2018 2:46 am

My apologies if this is OT - AmiUpdate is distributed with OS 4.1 so I'm guessing this OK to post here - but is anyone else having problems with AmiUpdate?

It doesn't seem to be working for me anymore. The log reads a number of failures.

Code: Select all
AmiUpdate 2.43 (29.12.2016) Part of the AmiUpdate suite

Log opened on 12-5-2018 at 12:43:26

12:43:26 Program started

12:43:26 Started system scan

12:43:26   Found host machine as: X5020

12:43:26   Synchronising with server: 'www.amiupdate.net'...

12:43:26     Requesting HTTP header file from server...

12:43:26     Trying to connect to: www.amiupdate.net on port: 80

12:44:41       Failed

12:44:41      Failed to establish connection to: www.amiupdate.net error: Connection to the server failed

12:44:41       Failed to receive HTTP header file...

12:44:41       HTTPFetch error: Transferring the file was not possible due to a previous error

12:44:41   Synchronising with server: 'update.amigaos.net'...

12:44:41     Requesting HTTP header file from server...

12:44:42     Trying to connect to: www2.hyperion-entertainment.com on port: 80

12:44:42       Connected

12:44:42       Received HTTP header file...

12:44:42       Basic Authorisation required for this update

12:44:42       User and Pass found in sitelist

12:44:42       Authorizing...

12:44:42     Trying to connect to: www2.hyperion-entertainment.com on port: 80

12:44:43       Connected

12:44:43       Received HTTP header file...

12:44:43         Failed to get filesize from header, Content-Length: tag missing

12:44:43     Starting file download (unknown size )

12:44:43     Trying to connect to: www2.hyperion-entertainment.com on port: 80

12:44:43       Connected

12:44:44     Synchronisation successful

12:44:45 Scan completed

12:44:45 Waiting for user input...

User avatar
daveyw
 
Posts: 166
Joined: Mon Sep 12, 2011 8:44 pm

Re: AmiUpdate?

Postby nbache » Sat May 12, 2018 12:31 pm

Even though it might seem so, there is actually (probably) only one failure:
Code: Select all
12:43:26     Trying to connect to: www.amiupdate.net on port: 80

12:44:41       Failed
The following messages are just consequences of not being able to connect to the amiupdate.net server in the first place (although the log messages could be clearer).

Later on, the word "Failed" occurs once more ("Failed to get filesize from header, Content-Length: tag missing"), but this is not really a problem, it just means the file is downloaded without knowing its size in advance. Again, this could have been worded to make it clearer that it is not preventing anything from being done.

So, the remaining question would be: Why couldn't you connect to "www.amiupdate.net" on port 80? It might be a temporary problem on the server, at your ISP, or in the DNS system, or anywhere in between. Try again later, and if still unsuccessful, try opening the same address in your browser and see if that behaves any differently. Finally, try contacting Rigo directly if still unsuccessful

Edit: I tried with the browser myself and got no reply on "www.amiupdate.net" (nor simply "amiupdate.net"). Also see this thread on Amigans: http://www.amigans.net/modules/xforum/v ... 8&forum=30

Edit 2: I just tried on my PC with FireFox, and it worked - made a redir to "amiupdate.codebench.co.uk". I thought: WTF? Then I tried again with Odyssey on the X1k, and it worked there too. So either it is really intermittent, or something was just fixed.

Try again with AmiUpdate. Or maybe it will work to edit the server prefs to go directly to "amiupdate.codebench.co.uk"?

Best regards,

Niels
User avatar
nbache
Beta Tester
Beta Tester
 
Posts: 1249
Joined: Mon Dec 20, 2010 8:25 pm
Location: Copenhagen, Denmark

Re: AmiUpdate?

Postby daveyw » Sat May 12, 2018 9:23 pm

Thanks, I've added amiupdate.codebench.co.uk as a server.

The Version check appears to be hardcoded, so there's quite a long wait for that to timeout before it starts checking for updates.
User avatar
daveyw
 
Posts: 166
Joined: Mon Sep 12, 2011 8:44 pm

Re: AmiUpdate?

Postby mritter0 » Sun May 13, 2018 1:01 am

Workbench Explorer - A better way to browse drawers
User avatar
mritter0
 
Posts: 207
Joined: Mon Aug 25, 2014 10:41 pm
Location: Bettendorf, IA, USA

Re: AmiUpdate?

Postby Eroom » Tue May 15, 2018 10:57 am

daveyw wrote:Thanks, I've added amiupdate.codebench.co.uk as a server.

The Version check appears to be hardcoded, so there's quite a long wait for that to timeout before it starts checking for updates.


If you run Updates in Prefs on the first tab untick 'Perform Self-Update check when started manually' this stopped that for me.
Eroom
 
Posts: 10
Joined: Sun Sep 18, 2011 9:14 pm
Location: UK.

Re: AmiUpdate?

Postby nbache » Tue May 15, 2018 11:01 pm

Eroom wrote:If you run Updates in Prefs on the first tab untick 'Perform Self-Update check when started manually' this stopped that for me.
Rigo posted in the thread on Amigans.net with more info about this, and that he will solve the problem with the next version of AmiUpdate.

Follow the link given by mritter0 above.

Best regards,

Niels
User avatar
nbache
Beta Tester
Beta Tester
 
Posts: 1249
Joined: Mon Dec 20, 2010 8:25 pm
Location: Copenhagen, Denmark


Return to General AmigaOS

Who is online

Users browsing this forum: No registered users and 3 guests