(Auto)Switch-off monitor bug (ScreenBlanker)

A forum for general AmigaOS 4.x support questions that are not platform-specific

(Auto)Switch-off monitor bug (ScreenBlanker)

Postby samo79 » Thu Oct 27, 2011 2:48 am

I have a strange problem with the (auto)switch-off of the monitor functionality that happen after a while if the computer and the monitor are turned on but not touched for a certain period of time (it's the Power managment feature if i remember correctly)

Leaving the monitor turned on for a certain period of time will active the auto-switch off option (this is availible on the ScreenBlaker module) and this works ok in general, the problem arrive if the monitor will be auto switched off (black screen) for a very long time, (don't know specifically how many time) in this case the user can't be able to reactive the screen moving the mouse as always, simply nothing happen and the screen remain black and you need to reboot

Only now i found the combo SHIFT F2 (to check it go to ScreenBlanker --> HotKey tab) to active this functionality manually so i try a test and the mouse seems to works fine to disactivate it (it close the black save screen and turn correctly to the Workbench)

So there is a problem somewhere that "blocked" the mouse functionality but only after a while during the wait in "black screen" mode ?

- Eventually, to test it you need to leave your computer (and monitor) on for a while (and hour or two i can say) then when you come back you will see the monitor off (black screen), now just try to move your mouse to turn on Workbench --> nothing happen here!

- Second test, active the same functionality manually with SHIFT + F2 combo --> Black screen --> Then move the mouse --> Now it works ok here!

Additional info:
- I have a Sam Flex 800 with Radeon 9250 and AmigaOS 4.1 Update 3 altrough i had this problem since the first AmigaOS 4.1 released with the machine
- The ScreenBlanker settings are never touched, so the original settings are used
Last edited by samo79 on Thu Oct 27, 2011 5:04 pm, edited 1 time in total.
User avatar
samo79
 
Posts: 519
Joined: Sat Jun 18, 2011 12:13 am
Location: Italy

Re: (Auto)Switch-off monitor bug (ScreenBlanker)

Postby prowler » Thu Oct 27, 2011 3:27 pm

I don't have the exact same problem and mine sounds a lot more benign than yours.

What I have is the screen saver will kick in, then the auto blanker will kick in. It will stay like that for a while and then all of a sudden, the auto blanker switches off and the screen is displayed again. The screen saver or blanker will never start again unless I start using the computer so resetting the whole count down to inactivity thing again.
prowler
 
Posts: 12
Joined: Tue Jun 21, 2011 3:23 pm
Location: Australia

Re: (Auto)Switch-off monitor bug (ScreenBlanker)

Postby nexus » Fri Oct 28, 2011 7:45 am

I cannot confirm both of the problems.

Recently, I used to run some staff on my Amiga over night. I always can wake up the monitor the next morning and screenblanker always works still fine in the morning. So either the problems are related to Sam (I don't have one) or to the monitor.

Regarding samo79's problem: I think to remember an option in the screenblanker prefs, that disables the mouse to
bring back the monitor from DPSM. I guess, you tried to press keys on the keyboard, too?

regards,
nexus
User avatar
nexus
Beta Tester
Beta Tester
 
Posts: 347
Joined: Mon Dec 20, 2010 3:11 pm
Location: Germany

Re: (Auto)Switch-off monitor bug (ScreenBlanker)

Postby samo79 » Sat Oct 29, 2011 6:53 am

Yep that option is disabled so the mouse should works, but at the end will not (if i wait a lot of time during a "black screen" situation)

I will try pressing a key on keyboard altrough AFAIK only a soft reset will solve ... i will try again eventually
User avatar
samo79
 
Posts: 519
Joined: Sat Jun 18, 2011 12:13 am
Location: Italy

Re: (Auto)Switch-off monitor bug (ScreenBlanker)

Postby Paul Zager » Sun Oct 30, 2011 12:20 am

@samo79,

Since update 3 I've had the same issue with my setup on my XE. I used to have mouse movement sensing dsiabled, since bumps to the desk were easy, and brought up the sreen again when I didn't want it to.

But with update 3 and this "locked" black screen issue, I enabled the mouse sensing again, thinking maybe it was a problem with my wireless keyboard not sending a signal and not letting the scrfeen come back on. Trouble is, neither mouse movement nor a key press does anything to bring the screen back on once it gets into this condition.

Paul
A1-XE G4, 2GB, 9250, 4.1.4
User avatar
Paul Zager
 
Posts: 13
Joined: Wed Jul 06, 2011 4:58 pm

Re: (Auto)Switch-off monitor bug (ScreenBlanker)

Postby samo79 » Sun Oct 30, 2011 3:46 am

Paul Zager wrote:@samo79,

Since update 3 I've had the same issue with my setup on my XE. I used to have mouse movement sensing dsiabled, since bumps to the desk were easy, and brought up the sreen again when I didn't want it to.

But with update 3 and this "locked" black screen issue, I enabled the mouse sensing again, thinking maybe it was a problem with my wireless keyboard not sending a signal and not letting the scrfeen come back on. Trouble is, neither mouse movement nor a key press does anything to bring the screen back on once it gets into this condition.

Paul


Well so i'm not alone ... the only difference is that i have this kind of problem since beginning (the original AmigaOS 4.1 on my Sam440 Flex) :roll:
Not a big issue at the end but still and should be fixed :-)
User avatar
samo79
 
Posts: 519
Joined: Sat Jun 18, 2011 12:13 am
Location: Italy

Re: (Auto)Switch-off monitor bug (ScreenBlanker)

Postby nexus » Mon Oct 31, 2011 9:50 pm

@samo79

what GFX card do you have? Is it one with two outputs and do you have 2 cables connected to it or 1 cable + VGA-adapter at the other output?

regards,
nexus
User avatar
nexus
Beta Tester
Beta Tester
 
Posts: 347
Joined: Mon Dec 20, 2010 3:11 pm
Location: Germany

Re: (Auto)Switch-off monitor bug (ScreenBlanker)

Postby samo79 » Tue Nov 01, 2011 3:40 am

I have an ATI Radeon 9250 128 MB (64 bit) and only 1 cable is connected to my LCD monitor :)
User avatar
samo79
 
Posts: 519
Joined: Sat Jun 18, 2011 12:13 am
Location: Italy

Re: (Auto)Switch-off monitor bug (ScreenBlanker)

Postby Deniil » Thu Nov 24, 2011 6:25 pm

This is exactly what I have been reporting in this thread at Amigans.net!!

And it is not the fault of the screen blanker. If you disable the screen blanker completely (and switch off the monitor by hand instead) you may come back to a system where only the mouse is working until you click somewhere, then everything freezes and you have to reboot using the reset button.

I have an AmigaOne XE G4 with Radeon 9250.
Deniil
 
Posts: 108
Joined: Mon Jul 11, 2011 7:59 pm

Re: (Auto)Switch-off monitor bug (ScreenBlanker)

Postby samo79 » Thu Nov 24, 2011 10:41 pm

@Denill

Mmm so you suspect that my problem it's a usual freeze moment instead ?
Maybe, i can't say for sure as the screen is black and i can't see the Worbench, if the mouse are working and so on ... but honestly what you say sound

In general i didn't experience such freeze, very often i leave my computer running during the entire night, listening music while sleeping and so on but maybe sometimes happen and this is the reason of the "unremovible" black screen ..
User avatar
samo79
 
Posts: 519
Joined: Sat Jun 18, 2011 12:13 am
Location: Italy

Next

Return to General AmigaOS

Who is online

Users browsing this forum: No registered users and 3 guests