Amiupdate and reboot

A forum for Classic Amiga specific support issues.

Amiupdate and reboot

Postby my_pc_is_amiga » Tue Dec 25, 2012 6:36 pm

Amiupdate is not doing a hard reboot when #?.kmod or when resident libraries have been updated. Only a soft reboot is done and so libraries are not updated in ram--which means I need to reboot again as a hard reset.
my_pc_is_amiga
 
Posts: 64
Joined: Sat Dec 08, 2012 8:58 pm

Re: Amiupdate and reboot

Postby nbache » Tue Dec 25, 2012 11:18 pm

A hard reboot is only necessary if kickstart modules have been updated, for libraries (in LIBS:) and similar a soft reset is enough.

Best regards,

Niels
User avatar
nbache
Beta Tester
Beta Tester
 
Posts: 1265
Joined: Mon Dec 20, 2010 8:25 pm
Location: Copenhagen, Denmark

Re: Amiupdate and reboot

Postby Rigo » Wed Dec 26, 2012 2:58 am

Strange. It works fine here after updating something requiring a hard reset.

Simon
User avatar
Rigo
AmigaOS Core Developer
AmigaOS Core Developer
 
Posts: 330
Joined: Mon Jan 17, 2011 10:42 pm

Re: Amiupdate and reboot

Postby my_pc_is_amiga » Wed Dec 26, 2012 8:28 am

I think it was the recent rtg.library update that was not doing a hard reboot ... and was seeing this on the classic.
my_pc_is_amiga
 
Posts: 64
Joined: Sat Dec 08, 2012 8:58 pm

Re: Amiupdate and reboot

Postby Rigo » Wed Dec 26, 2012 3:09 pm

Hmmm, strange. I've just checked the rtg update, and it is flagged for hard reboot after installation.

Please make sure you have the "RebootDeamon" in the Modules directory of the AmiUpdate drawer. If not, that might explain it.

Simon
User avatar
Rigo
AmigaOS Core Developer
AmigaOS Core Developer
 
Posts: 330
Joined: Mon Jan 17, 2011 10:42 pm

Re: Amiupdate and reboot

Postby my_pc_is_amiga » Fri Jan 04, 2013 4:25 am

I tried the "reboot" command from the shell and looks like to me my Amiga A4000T is not going through a hard reboot. With "reboot", I don't get back to the 3.x early startup menu as I can with the ctrl-alt-alt. The only time I can hard reboot is with ctrl-alt-alt (or of course turning the machine off/on). Does "reboot" work for others that have a A4000T machine?
my_pc_is_amiga
 
Posts: 64
Joined: Sat Dec 08, 2012 8:58 pm

Re: Amiupdate and reboot

Postby alekc » Wed Jan 09, 2013 2:53 pm

Try "reboot sync" command.
alekc
 
Posts: 50
Joined: Sat Jun 18, 2011 4:06 pm

Re: Amiupdate and reboot

Postby danbeaver » Thu Jan 10, 2013 2:19 am

On My A4000T, a Hard Reboot has not been possible since before Update 5 without an ON/OFF/ON or a 10+ second press of Ctrl+(L)A+(R)A reboot. No software commands take me back to a KS 3.1 boot, i.e., a hard reboot.

This has been discussed in the past (and ignored).
User avatar
danbeaver
 
Posts: 367
Joined: Thu Jan 19, 2012 10:58 pm
Location: On the edge of the Equator in hot & humid Guam

Re: Amiupdate and reboot

Postby ssolie » Thu Jan 10, 2013 6:03 pm

danbeaver wrote:This has been discussed in the past (and ignored).

Just because there is no fix yet doesn't mean something has been ignored.
AmigaOS Development Team Lead
Be authentic. Get AmigaOS.
User avatar
ssolie
AmigaOS Core Developer
AmigaOS Core Developer
 
Posts: 1000
Joined: Mon Dec 20, 2010 9:51 pm
Location: Canada

Re: Amiupdate and reboot

Postby my_pc_is_amiga » Fri Jan 11, 2013 8:14 am

alekc wrote:Try "reboot sync" command.


I tried that just now and no change. It is still a soft reboot.
my_pc_is_amiga
 
Posts: 64
Joined: Sat Dec 08, 2012 8:58 pm

Next

Return to Platform: Classic

Who is online

Users browsing this forum: No registered users and 2 guests

cron