floppy disk usage guide ?

A forum for Classic Amiga specific support issues.

floppy disk usage guide ?

Postby Lio » Fri Sep 12, 2014 9:27 pm

Hi All,
I did not see this mentionned anywhere in the AOS4.1 package so is there a floppy usage guide for classic ?
What I see is that the floppy drive is supported and the floppy disk I would insert shows up its icon on the WB and I can open it BUT
- this works only if I insert the floppy disk and reboot
- ejecting the disk and inserting another one does not get rid of the previous icon
- inserting a floppy disk once the WB is loaded does not shows up the floppy disk icon

I tried mounter in system folder but it simply ignores the trackdisk.device

so how to load/eject floppy disk then ?
Lio
 
Posts: 31
Joined: Tue Sep 13, 2011 9:07 pm

Re: floppy disk usage guide ?

Postby DarrenHD » Fri Sep 12, 2014 10:02 pm

Lio wrote:Hi All,
I did not see this mentionned anywhere in the AOS4.1 package so is there a floppy usage guide for classic ?
What I see is that the floppy drive is supported and the floppy disk I would insert shows up its icon on the WB and I can open it BUT
- this works only if I insert the floppy disk and reboot
- ejecting the disk and inserting another one does not get rid of the previous icon
- inserting a floppy disk once the WB is loaded does not shows up the floppy disk icon

I tried mounter in system folder but it simply ignores the trackdisk.device

so how to load/eject floppy disk then ?


Hi, what system do you have? There are some differences in the floppy drive handling based on what type of Amiga you have - A1200 from C= vs. A1200 from Escom/AT, or A3/4000. There are some questions asked suring the OS4.1 Installation about that.

Darren
AmigaOS 4.x Beta Tester - Classic Amiga enthusiast - http://www.hd-zone.com is my Amiga Blog, check it out!
User avatar
DarrenHD
Beta Tester
Beta Tester
 
Posts: 633
Joined: Mon Dec 20, 2010 4:38 pm
Location: London, Ontario, Canada

Re: floppy disk usage guide ?

Postby Lio » Fri Sep 12, 2014 10:04 pm

yes you re right, I have the original A1200 from Commodore so I did not apply the fix during installation (it was automatically chosen anyway AFAIR).
Lio
 
Posts: 31
Joined: Tue Sep 13, 2011 9:07 pm

Re: floppy disk usage guide ?

Postby DarrenHD » Fri Sep 12, 2014 10:07 pm

Lio wrote:yes you re right, I have the original A1200 from Commodore so I did not apply the fix during installation (it was automatically chosen anyway AFAIR).


Okay, then the floppy behaviour should be the same as it is on OS 3.9, eg. the floppy Icon should appear - or disappear - if you insert or eject the disk.

you can also try the diskchange df0: command from shell.

Darren
AmigaOS 4.x Beta Tester - Classic Amiga enthusiast - http://www.hd-zone.com is my Amiga Blog, check it out!
User avatar
DarrenHD
Beta Tester
Beta Tester
 
Posts: 633
Joined: Mon Dec 20, 2010 4:38 pm
Location: London, Ontario, Canada

Re: floppy disk usage guide ?

Postby Lio » Sat Sep 13, 2014 8:26 pm

as I said if I dont insert a disk at boot, no disk icon appears and a diskchange DF0: gave a insert DF0: !

it works ONLY if a disk is inserted at boot and only in this case, the diskchange command is working... I guess I have to live with that !
Lio
 
Posts: 31
Joined: Tue Sep 13, 2011 9:07 pm

Re: floppy disk usage guide ?

Postby Rotzloeffel » Mon Dec 01, 2014 1:59 pm

There is an entry at the end of the file Kicklayout-A1200. You find it in Devs:Kickstarts/

uncomment the Line A1200FloppyFix

that should solve your Problem
Rotzloeffel
 
Posts: 32
Joined: Sat Jun 18, 2011 5:56 pm
Location: Wolfach / Germany


Return to Platform: Classic

Who is online

Users browsing this forum: No registered users and 3 guests

cron