Some problems with locale

A forum for Classic Amiga specific support issues.

Some problems with locale

Postby ancalimon » Mon Nov 10, 2014 11:36 pm

I am trying to keep my Workbench English but set my keymap to Turkish Q. I also want to be able to use iso-8859-9 (Turkish) because without it I can not view Turkish fonts. How do I do this?

Also if I do not select Turkish as the preferred language of my AmigaOS (thus making everything appear in Turkish), I can not type Turkish characters at all. There are two versions of Turkish:

1: Turkish türkçe (i=I)
2: Turkish türkçe (i=İ)

1) If I select the (i=İ), when I run Input from Prefs drawer, I get the following errors:

Code: Select all
Parse error in keymap file usa_tha_TIS-6
Unknown charset in line 10

Parse error in keymap file slo_ISO-8859-
Unknown charset in line 10

Parse error in keymap file s_ISO-8859-1
Unknown charset in line 10

Parse error in keymap file tha_usa_TIS-6
Unknown charset in line 10

Parse error in keymap file usa_ISO-8859-
Unknown charset in line 10

Parse error in keymap file ro_ISO-8859-
Unknown charset in line 10

Parse error in keymap file lt_ISO-8859-1
Unknown charset in line 12

Parse error in keymap file lv_ISO-8859-
Unknown charset in line 10

Parse error in keymap file lv_qwerty_IS
Unknown charset in line 10

Parse error in keymap file nl
Unknown charset in line 10

Parse error in keymap file fo_ISO-8859-
Unknown charset in line 10

Parse error in keymap file gb_ISO-8859-
Unknown charset in line 10

Parse error in keymap file hr_ISO-8859-
Unknown charset in line 10

Parse error in keymap file ch_d_ISO-885
Unknown charset in line 10

Parse error in keymap file ch_f_ISO-885
Unknown charset in line 10

Parse error in keymap file dk_ISO-8859-
Unknown charset in line 10

Parse error in keymap file al
Unknown charset in line 10

Parse error in keymap file br_abnt2_ISO
Unknown charset in line 10

Parse error in keymap file cdn_f_ISO-88
Unknown charset in line 10


I think it behaves like this because it tries to read all the I (or i) letters as İ (or ı) which is an illegal international character.

If I try to select türkçe Q after this, I can type Turkish character inside the test area. If I select use, I can not type the Turkish characters but their English equivalents are typed ( for example, it types [ instead of ğ )

2) If I select the (i=I), when I run Input from Prefs drawer, I do not get any errors when I run Input from Prefs drawer and I can selct türkçe q keymap and type Turkish characters properly outside of the testing area inside Input prefs (for example inside a shell window


Another thing to take note is this: If I want to select English as my first preferred language from Locale languages tab, I'm only presented with Türkçe (turkish) instead of the two options (i=I), and the problematic (i=İ)
This keeps my Workbench screen English like I want. But if I choose türkçe Q from Input prefs as my keymap, the following things happen:

*The characters inside parenthesis is where that letter is on an English keyboard)
**Turkish have the following letters that are not present in American keyboard: ğ Ğ ü Ü ş Ş ö Ö ç Ç. There are also ı and İ. You get an "ı" when you press "I" and not an "i". So if you want to type "dir" in a shell, you have to use the İ key instead of I key. But when you want to type DIR in capital, you have to use the "I" key.

1) Pressing "I" key results in capital "I" even when caps lock is not active.
2) Pressing ğ ( [ ) results in no character printed. But If I press i after that, I get an i with two dots.
3) ü and Ü works
4) Pressing ş ( ; ) results in no character printed. But if I press i after that, I get an ı with ` on top of it.
5) Pressing i ( ` ) works but if I try to type capital İ , I get the " chacter.
6) ö and Ö ( , ) works
7) ç and Ç ( . ) works


There has to be a different option for setting charmap so that I can view my AmigaOS in English but still get to see Turkish characters properly. Also choosing English as the preferred language should not stop me from properly using Turkish keymap.
ancalimon
 
Posts: 27
Joined: Tue Oct 18, 2011 8:31 am

Re: Some problems with locale

Postby Spektro » Fri Nov 14, 2014 5:55 pm

Hi ancalimon,

In the Input preferences I've selected the 'Turkish Q ISO-8859-9' keyboard and in the Locale preferences I have 'english_ISO-8859-15' in the Preferred languages list (nothing else there).

As a result Workbench and all the other programs are in English and I get Turkish characters when typing. But it looks like not all Turkish characters are there. The Turkish keymap definition may be missing something. The Turkish keymap definitions are in the following files:

  • Turkish ISO-8859-9: SYS:Devs/KeyMaps/tr_ISO-8859-9
  • Turkish Q ISO-8859-9: SYS:Devs/KeyMaps/tr_q_ISO-8859-9
You can change the keymaps just by editing the files with a text editor. Please read this documentation before editing the files: 'SYS:Documentation/Keymaps.doc'.

1) If I select the (i=İ), when I run Input from Prefs drawer, I get the following errors:

I don't get the parse errors when I select 'Turkish türkçe (i=İ)' language in the Locale preferences.

I have the following Turkish language files in the SYS:Locale/Languages:

  • turkish_int_ISO-8859-9.language, version 52.1 (5.12.06)
  • turkish_ISO-8859-9.language, version 52.1 (5.12.06)
You can run the following command from the Shell to make sure that the language files have not been corrupted:
md5sum locale:languages/tur#?

It should give you the following checksums:
Code: Select all
dc8b9be4a5b5830494f42ef3e0ef4b3e  locale:languages/turkish_ISO-8859-9.language
b83a11ade6ea3a453094cbe16c8a4a67  locale:languages/turkish_int_ISO-8859-9.language

To get the checksums of the keymap files, execute this Shell command:
md5sum devs:keymaps/tr_#?

The result should be:
Code: Select all
d2fb1af3293bc839b1f7e2a0c921ccf7  devs:keymaps/tr_q_ISO-8859-9
132a84fa5511a6fa48bd28b394df9d03  devs:keymaps/tr_ISO-8859-9
- Janne Peräaho
User avatar
Spektro
Beta Tester
Beta Tester
 
Posts: 105
Joined: Sat Jun 18, 2011 7:55 am
Location: Finland


Return to Platform: Classic

Who is online

Users browsing this forum: No registered users and 3 guests

cron