Issues with Radeon card for the Mediator

A forum for Classic Amiga specific support issues.

Issues with Radeon card for the Mediator

Postby Benny » Thu Aug 11, 2016 7:19 pm

In the last months I bought 4 Radeon PCI card's for my Mediator 4000, but only the Sapphire Radeon 7000 with 64MB seems to work with OS4.1 FE.

The other 3 are:
ATI9200 / 128MB DDR PCI,
R92P 128MB PCI,
R9250PCI-D3 with 256MB.

With every card installed the machine keeps rebooting from the harddrive or from the OS4.1 FE disk/CD.

I think I tried every combination of jumpers on the Mediator PCI 4000 card.

Is the OS very picky about the card or is the videoram of 128MB an issue ?
Benny
 
Posts: 29
Joined: Fri Nov 11, 2011 9:03 pm

Re: Issues with Radeon card for the Mediator

Postby DarrenHD » Tue Aug 30, 2016 7:13 am

Benny wrote:In the last months I bought 4 Radeon PCI card's for my Mediator 4000, but only the Sapphire Radeon 7000 with 64MB seems to work with OS4.1 FE.

The other 3 are:
ATI9200 / 128MB DDR PCI,
R92P 128MB PCI,
R9250PCI-D3 with 256MB.

With every card installed the machine keeps rebooting from the harddrive or from the OS4.1 FE disk/CD.

I think I tried every combination of jumpers on the Mediator PCI 4000 card.

Is the OS very picky about the card or is the videoram of 128MB an issue ?


Do those other Radeons work on OS 3.x ?

I know the Sapphire card was tested and is confirmed to work as it is 5V Tolerant.
AmigaOS 4.x Beta Tester - Classic Amiga enthusiast - http://www.hd-zone.com is my Amiga Blog, check it out!
User avatar
DarrenHD
Beta Tester
Beta Tester
 
Posts: 633
Joined: Mon Dec 20, 2010 4:38 pm
Location: London, Ontario, Canada

Re: Issues with Radeon card for the Mediator

Postby Benny » Thu Nov 10, 2016 2:28 pm

DarrenHD wrote:
Benny wrote:In the last months I bought 4 Radeon PCI card's for my Mediator 4000, but only the Sapphire Radeon 7000 with 64MB seems to work with OS4.1 FE.

The other 3 are:
ATI9200 / 128MB DDR PCI,
R92P 128MB PCI,
R9250PCI-D3 with 256MB.

With every card installed the machine keeps rebooting from the harddrive or from the OS4.1 FE disk/CD.

I think I tried every combination of jumpers on the Mediator PCI 4000 card.

Is the OS very picky about the card or is the videoram of 128MB an issue ?


Do those other Radeons work on OS 3.x ?

I know the Sapphire card was tested and is confirmed to work as it is 5V Tolerant.


Non of the above cards work in the Mediator, I bought another Radeon PCI 9250 card and is does not work either under OS3.1: the PCIinfo (from Elbox) does not recognize the cards.
One of the cards is bought from a user with an Amiga 1200 Mediator.

Only the Radeon 7000, from my other topic, does work with OS4.1 FE, but not in the OS3.1 / 68060 / Mediator 4000 config.

The Cybervision 3D and the Voodoo 3000 do work under OS4.1 FE and the OS3.1 installation without any troubles, and stable.
So I guess I need another (tested in Mediator) Radeon 9250.
Benny
 
Posts: 29
Joined: Fri Nov 11, 2011 9:03 pm

Re: Issues with Radeon card for the Mediator

Postby Benny » Mon Dec 12, 2016 11:05 pm

DarrenHD wrote:
Benny wrote:In the last months I bought 4 Radeon PCI card's for my Mediator 4000, but only the Sapphire Radeon 7000 with 64MB seems to work with OS4.1 FE.

The other 3 are:
ATI9200 / 128MB DDR PCI,
R92P 128MB PCI,
R9250PCI-D3 with 256MB.

With every card installed the machine keeps rebooting from the harddrive or from the OS4.1 FE disk/CD.

I think I tried every combination of jumpers on the Mediator PCI 4000 card.

Is the OS very picky about the card or is the videoram of 128MB an issue ?


Do those other Radeons work on OS 3.x ?

I know the Sapphire card was tested and is confirmed to work as it is 5V Tolerant.


I bought 2 other Radeon's, I have a 3V and a 5V Mediator so every card should be ok, only not compatible to the os.

I now have 6 Radeon cards and 1 is working 100% in OS4.1 that is the Radeon 9250 from Sapphire. The 7000 from Sapphire has gfx glitches under OS4.1, but does run.
This Radeon 7000 does not work under OS3.1 and all my other 4 Radeon cards do not work in the Mediator either. A few are recognized in Pciinfo from Elbox, but they aren't running under Picasso96.
Benny
 
Posts: 29
Joined: Fri Nov 11, 2011 9:03 pm

Re: Issues with Radeon card for the Mediator

Postby DarrenHD » Tue Jan 17, 2017 8:27 pm

Benny wrote:
DarrenHD wrote:
Benny wrote:In the last months I bought 4 Radeon PCI card's for my Mediator 4000, but only the Sapphire Radeon 7000 with 64MB seems to work with OS4.1 FE.

The other 3 are:
ATI9200 / 128MB DDR PCI,
R92P 128MB PCI,
R9250PCI-D3 with 256MB.

With every card installed the machine keeps rebooting from the harddrive or from the OS4.1 FE disk/CD.

I think I tried every combination of jumpers on the Mediator PCI 4000 card.

Is the OS very picky about the card or is the videoram of 128MB an issue ?


Do those other Radeons work on OS 3.x ?

I know the Sapphire card was tested and is confirmed to work as it is 5V Tolerant.


I bought 2 other Radeon's, I have a 3V and a 5V Mediator so every card should be ok, only not compatible to the os.

I now have 6 Radeon cards and 1 is working 100% in OS4.1 that is the Radeon 9250 from Sapphire. The 7000 from Sapphire has gfx glitches under OS4.1, but does run.
This Radeon 7000 does not work under OS3.1 and all my other 4 Radeon cards do not work in the Mediator either. A few are recognized in Pciinfo from Elbox, but they aren't running under Picasso96.


To be safe, at least for me the only Radeon's I've had work are ones purchased directly from Elbox, or the Sapphire Radeon 9250, either 128MB or 256MB.

Other Radeons may have different ID's which aren't picked up by the Radeon driver (they are hardcoded values and if they aren't there obviously it won't work).
AmigaOS 4.x Beta Tester - Classic Amiga enthusiast - http://www.hd-zone.com is my Amiga Blog, check it out!
User avatar
DarrenHD
Beta Tester
Beta Tester
 
Posts: 633
Joined: Mon Dec 20, 2010 4:38 pm
Location: London, Ontario, Canada


Return to Platform: Classic

Who is online

Users browsing this forum: No registered users and 1 guest