Update1 FE issues with A4000D and GRex

A forum for Classic Amiga specific support issues.

Update1 FE issues with A4000D and GRex

Postby Alexco » Mon Jan 16, 2017 11:34 pm

Hi,

I have severe issues with the Update 1 of the Final Edition on my A4000D (same system as this one here: http://forum.hyperion-entertainment.biz/viewtopic.php?f=15&t=3469) with 8MB Permedia 2 GFX card.
After manually downloading the update (Amiupdate always failed to download this file correctly due to many many many stalls and restarts during download) and installing it, the system no longer boots. After the kernel loads, I get a red screen.
I tried different configurations:
1) started without GREX kernel option, system loads but GFX is somewhat disturbed
Modified kicklayout
2a) with PCI GFX & Voodoo3 and without Permedia2 entries: red screen
2b) without PCI GFX, Voodoo3 and P2 entries: pink screen, after reset red screen
2b) only with PCI GFX entry: pink screen
3a) removed Permedia 2 card from system: red screen
3b) exchanged Permedia2 card for Voodoo3 card: red screen
Changed kernel back to kernel from OS4.1FE Install CD: system boots up correctly, even showing Update 1, Permedia 2 in title bar.
Maybe this is related to the Mediator issue, as Rotzloeffel already pointed out?

How can I help? Do you need some debug output? If so, what setup is needed?

Regards,
Alexander
Alexco
 
Posts: 6
Joined: Sun Jun 05, 2016 10:35 am

Re: Update1 FE issues with A4000D and GRex

Postby DarrenHD » Tue Jan 17, 2017 4:23 pm

Alexco wrote:Hi,

I have severe issues with the Update 1 of the Final Edition on my A4000D (same system as this one here: http://forum.hyperion-entertainment.biz/viewtopic.php?f=15&t=3469) with 8MB Permedia 2 GFX card.
After manually downloading the update (Amiupdate always failed to download this file correctly due to many many many stalls and restarts during download) and installing it, the system no longer boots. After the kernel loads, I get a red screen.
I tried different configurations:
1) started without GREX kernel option, system loads but GFX is somewhat disturbed
Modified kicklayout
2a) with PCI GFX & Voodoo3 and without Permedia2 entries: red screen
2b) without PCI GFX, Voodoo3 and P2 entries: pink screen, after reset red screen
2b) only with PCI GFX entry: pink screen
3a) removed Permedia 2 card from system: red screen
3b) exchanged Permedia2 card for Voodoo3 card: red screen
Changed kernel back to kernel from OS4.1FE Install CD: system boots up correctly, even showing Update 1, Permedia 2 in title bar.
Maybe this is related to the Mediator issue, as Rotzloeffel already pointed out?

How can I help? Do you need some debug output? If so, what setup is needed?

Regards,
Alexander


It sounds very similar. I know they are working on the "black screen" issue and it may be related. Hopefully it will be resolved soon.
AmigaOS 4.x Beta Tester - Classic Amiga enthusiast - http://www.hd-zone.com is my Amiga Blog, check it out!
User avatar
DarrenHD
Beta Tester
Beta Tester
 
Posts: 633
Joined: Mon Dec 20, 2010 4:38 pm
Location: London, Ontario, Canada

Re: Update1 FE issues with A4000D and GRex

Postby DarrenHD » Tue Jan 17, 2017 5:48 pm

Alexco wrote:Hi,

I have severe issues with the Update 1 of the Final Edition on my A4000D (same system as this one here: http://forum.hyperion-entertainment.biz/viewtopic.php?f=15&t=3469) with 8MB Permedia 2 GFX card.
After manually downloading the update (Amiupdate always failed to download this file correctly due to many many many stalls and restarts during download) and installing it, the system no longer boots. After the kernel loads, I get a red screen.
I tried different configurations:
1) started without GREX kernel option, system loads but GFX is somewhat disturbed
Modified kicklayout
2a) with PCI GFX & Voodoo3 and without Permedia2 entries: red screen
2b) without PCI GFX, Voodoo3 and P2 entries: pink screen, after reset red screen
2b) only with PCI GFX entry: pink screen
3a) removed Permedia 2 card from system: red screen
3b) exchanged Permedia2 card for Voodoo3 card: red screen
Changed kernel back to kernel from OS4.1FE Install CD: system boots up correctly, even showing Update 1, Permedia 2 in title bar.
Maybe this is related to the Mediator issue, as Rotzloeffel already pointed out?

How can I help? Do you need some debug output? If so, what setup is needed?

Regards,
Alexander



The only other thing I can recommend is to try a clean install. Install AmigaOS 4.1 Final Edition, then apply the Update 1 .lha update (Don't use Amiupdate - download it from Hyperion then run it). See if that changes anything.
AmigaOS 4.x Beta Tester - Classic Amiga enthusiast - http://www.hd-zone.com is my Amiga Blog, check it out!
User avatar
DarrenHD
Beta Tester
Beta Tester
 
Posts: 633
Joined: Mon Dec 20, 2010 4:38 pm
Location: London, Ontario, Canada

Re: Update1 FE issues with A4000D and GRex

Postby Alexco » Wed Jan 18, 2017 8:22 pm

Sorry, does not change anything.
I switched "VERBOSE" on, watched a lot of things getting loaded, until the prompt for enter shows.
After pressing enter the machine resets and I get the red AGA full screen, no disk activity. Sometimes I can reset with CTRL-A-A, sometimes not.
Alexco
 
Posts: 6
Joined: Sun Jun 05, 2016 10:35 am

Re: Update1 FE issues with A4000D and GRex

Postby DarrenHD » Wed Jan 18, 2017 9:15 pm

Alexco wrote:Sorry, does not change anything.
I switched "VERBOSE" on, watched a lot of things getting loaded, until the prompt for enter shows.
After pressing enter the machine resets and I get the red AGA full screen, no disk activity. Sometimes I can reset with CTRL-A-A, sometimes not.


I don't know if you are able to get a boot log or not....that may help, at least I can look at it and post it to the bug report....here are the instructions:

Setup Debugging in AmigaOS 4.1 Classic

1) Modify your Sys:Kickstart/kicklayout-xxxx file (where xxxx is your model number). Change the kernel to kernel.debug. Save the file.

2) Modify your startup sequence so the C:Bootloader line reads:

C:Bootloader COMMANDLINE=”SERIAL DEBUGLEVEL=5 BAUDRATE=57600 NORAMPAGER″

Save the file.

3) Power off your Amiga.

4) Connect a serial cable to your Amiga’s serial port, and connect the other end to another computer with a serial port.

5) Start the second computer where the cable is attached and start a Terminal program. Set it to a Baud Rate of 57600 8-N-1. Set that Terminal Program to capture the buffer to a file.

6) Turn on your Amiga. After the Kickstart loads and the machine resets, you should start to see serial output on the second computer. Save this output.
AmigaOS 4.x Beta Tester - Classic Amiga enthusiast - http://www.hd-zone.com is my Amiga Blog, check it out!
User avatar
DarrenHD
Beta Tester
Beta Tester
 
Posts: 633
Joined: Mon Dec 20, 2010 4:38 pm
Location: London, Ontario, Canada

Re: Update1 FE issues with A4000D and GRex

Postby Alexco » Sat Jan 21, 2017 11:53 pm

Okay,

I saved two logs, one where OS4 halts with pink screen, and one with red screen. Same config, no changes just a reboot (first came pink then red).
On the other hand, with the logging enabled and debug kernel sometimes the machine boots up to the desktop before it locks itself with a DSI.

Thanks for help,
Alexander

log.zip
log files
(6.04 KiB) Downloaded 31 times
Alexco
 
Posts: 6
Joined: Sun Jun 05, 2016 10:35 am


Return to Platform: Classic

Who is online

Users browsing this forum: No registered users and 1 guest