AOS 4.1 FE defect - drawer/partition/assign selection in ASL

A forum for AmigaOne XE and MicroA1-C specific issues.

AOS 4.1 FE defect - drawer/partition/assign selection in ASL

Postby saimo » Sun Jan 18, 2015 12:52 am

I have noticed a few minor defects in AOS 4.1 FE that I haven't seen mentioned elsewhere, so I have decided to report them. Eventually I went for separate threads to avoid confusion.
If the problem described below is already discussed elsewhere, please feel free to just point me to the right place. Thanks.

My system:
* A1 XE G4
* 512 MB RAM
* Radeon 9000 with 64 MB RAM
* SoundBlaster Live!
* IDE HD on a1ide.device (normally turned off at the beginning of the startup-sequence)
* SATA SDD on Sil5312ide.device
* all partitions formatted with SFS/00

The problem here is that the ASL requesters do not update the Drawer gadget when a drawer/partition/assign is selected without entering it:

Image

This is not coherent with the behaviour of when the choice is for drawers only (in that case it works - f.ex., try RequestFile DRAWERSONLY) and with files selection (the File gadget gets updated as soon as a file is single-clicked).

I noticed this because at some point I only needed to select a directory and found out that I had to double-click (I hate double-clicking!). Before, it wasn't so.

BTW, I'm not sure how it was before, but I have just noticed that, additionally, the partition names do not have the : at the end: there's a little incoherency with the assigns there, and it looks quite odd (there's no possibility of exchanging them for drawers thanks to the context, but still...).
User avatar
saimo
 
Posts: 94
Joined: Sat Oct 29, 2011 11:37 pm

Return to Platform: AmigaOne XE and MicroA1-C

Who is online

Users browsing this forum: Google [Bot] and 1 guest