Page 1 of 1

Rear USB ports on A1XE

PostPosted: Fri Dec 30, 2016 12:07 am
by daveyw
Hi all,

I haven't used onboard USB on my A1XE for many, many years, since I added a USB2 card.

Now, my PS2 mouse is looking very sad, and I'm thinking of replacing it. As PS2 mice are rare - and multi-button PS2 mice even rarer - I've got a USB mouse.

The onboard USB would be the obvious place to plug it in, but I've discovered that no USB devices plugged into the rear are recongnised! Tried my new mouse and some USB sticks, but nothing.

It's getting power (the mouse and one of my sticks have LEDs, and they come on), but AmigaOS isn't recognising anything plugged in.

Rear ports are enable in UBoot.
Nothing's commented out in Kicklayout.

(I bought this machine second hand; the previous user has the front ports deactivated in uboot, and I have since rewired the case to my PCI card's internal USB header.)

Anyone have any ideas on what might be amiss? It's not huge, I'm not missing anything I haven't used in years, I can always use my USB2 connectors, but it's a baffling mystery

Re: Rear USB ports on A1XE

PostPosted: Fri Dec 30, 2016 3:30 pm
by Raziel
I may be completely wrong, but i think i remember something about screwed up rear USB ports on the XE if the hardware DMA fix has been installed. (Does your board has the hardware fix?)

Too long now since i sold the XE so i might aswell remember wrong, maybe someone else can chip in (i remember having the DMA fixed but not the complete hardware fix - which fixed the DMA/internet access problem, but didn't kill the rear USB ports)

Re: Rear USB ports on A1XE

PostPosted: Fri Dec 30, 2016 3:55 pm
by RussellB
On an unfixed board the USB ports can not detect usb devices being inserted and removed. It should be able to detect usb devices from boot up or you might have better luck using a powered usb hub.

Re: Rear USB ports on A1XE

PostPosted: Sat Dec 31, 2016 12:25 am
by tonyw
It's not associated with the DMA hack, it's a separate issue.

The problem is that there are no terminating resistors connected to the USB ports (any of them) because they were supposed to be inside the VIA southbridge. No one was able to find out how to enable them within the VIA SB and they may not be there anyway.

As Russel said, the problem manifests itself as a failure to recognise devices being plugged in or unplugged. If you power up with the mouse in the port, it should work.

The proper and permanent fix is to add 2 x 16k resistors to each port, from the data lines to ground. Easily done if you are handy with a soldering iron or know someone who is. An alternative is to use an external hub (does it have to be separately powered?) and leave it connected permanently.

Re: Rear USB ports on A1XE

PostPosted: Sat Dec 31, 2016 11:39 pm
by daveyw
I don't think that is the issue, as they worked at some point in the past and I haven't had the DMA fix applied since then.

Even if I power up with the mouse plugged in, it isn't recognised.

I see that FE Update 1 tweaks USB, so I'll have another attempt after I apply the update.

Re: Rear USB ports on A1XE

PostPosted: Mon Jan 02, 2017 7:44 am
by daveyw
Yup, update 1 sorted the issue, and I can now use the mouse on the rear USB port if I boot with it installed. However, there's a noticeable performance issue (feels a bit like Windows circa 2000) and it doesn't survive an OS reset, so I'll stick with using the USB2 port.