Graphics Card -Sam 440ep-Flex PCI slot

This forum is for all AmigaOne 500, Sam440 and Sam460 specific issues.

Graphics Card -Sam 440ep-Flex PCI slot

Postby Spectre660 » Wed Aug 01, 2012 4:04 am

On My Sam 440ep-Flex 800Mhz and a Radeon 9250 graphics card
OS 4.1 update 4 crashes on start of Workbench display if Graphics card is in either the second or third PCI slot.
Will only work if Graphics card is in first PCI slot.
OS 4.1 update 1 install CD boots ok with the graphics card in any of the three PCI slots
Spectre660
 
Posts: 1485
Joined: Sat Jun 18, 2011 3:16 pm
Location: Montserrat

Re: Graphics Card -Sam 440ep-Flex PCI slot

Postby xenic » Wed Aug 01, 2012 6:01 pm

Spectre660 wrote:On My Sam 440ep-Flex 800Mhz and a Radeon 9250 graphics card
OS 4.1 update 4 crashes on start of Workbench display if Graphics card is in either the second or third PCI slot.
Will only work if Graphics card is in first PCI slot.
OS 4.1 update 1 install CD boots ok with the graphics card in any of the three PCI slots

I haven't tried moving my graphics card but I did find that my sound card won't work in the bottom (third) PCI slot. SInce I only have the graphics card and a sound card, I assumed that it's not possible to leave an empty slot above a PCI card. I haven't seen any official statements to that effect though.
AmigaOne X1000 with 2GB memory - OS4.1 FE
xenic
 
Posts: 1148
Joined: Sun Jun 19, 2011 1:06 am

Re: Graphics Card -Sam 440ep-Flex PCI slot

Postby Spectre660 » Wed Aug 01, 2012 6:35 pm

I once had to run the 9250 in the second PCI slot and It did work. The problem with slot 1 turned out to be a power supply issue.
I had a Graphics card in Slot 1 and a Sounblaster in slot 3 with slot 2 empty up to last month working ok.
I thought that the slot two problems for the graphics card was Uboot but I have just tested all the versions back to 1.31b and same problem.
Just Isolated it to Os 4,1 Updates after update 1 yesterday.
Do you remember some Sam-flex machines crashing without the fan in update 3 ? This problem may be related to that update.

My reason for looking at this is that I am trying to get both a Radeon HD card via a PCIE to PCI adapter and a 9250 card runing at the same time on My Sam Flex.


xenic wrote:
Spectre660 wrote:On My Sam 440ep-Flex 800Mhz and a Radeon 9250 graphics card
OS 4.1 update 4 crashes on start of Workbench display if Graphics card is in either the second or third PCI slot.
Will only work if Graphics card is in first PCI slot.
OS 4.1 update 1 install CD boots ok with the graphics card in any of the three PCI slots

I haven't tried moving my graphics card but I did find that my sound card won't work in the bottom (third) PCI slot. SInce I only have the graphics card and a sound card, I assumed that it's not possible to leave an empty slot above a PCI card. I haven't seen any official statements to that effect though.
Spectre660
 
Posts: 1485
Joined: Sat Jun 18, 2011 3:16 pm
Location: Montserrat

Re: Graphics Card -Sam 440ep-Flex PCI slot

Postby xenic » Thu Aug 02, 2012 6:51 pm

Spectre660 wrote:I once had to run the 9250 in the second PCI slot and It did work. The problem with slot 1 turned out to be a power supply issue.
I had a Graphics card in Slot 1 and a Sounblaster in slot 3 with slot 2 empty up to last month working ok.
I thought that the slot two problems for the graphics card was Uboot but I have just tested all the versions back to 1.31b and same problem.

I just looked and all my updates and it is a very confusing situation. In addition to the UBoot updates I also have an update named "SAM-pci-flex-update.lha" from Dec 2010 that affects PCI speed. I've never gotten confirmation that the pci-flex update is included in later UBoot updates or if it should still be applied. Don't forget about the SAM440ep_setup utility either; it changes PCI hardware registers. I also just updated my UBoot to the latest version (1.3.1e) and HyperClock now says that my UBoot is outdated!
Just Isolated it to Os 4,1 Updates after update 1 yesterday.

I just looked at the Update 2 files and I don't see any files that would affect PCI or graphics. Take a look at the Update 2 archive and see for yourself.
Do you remember some Sam-flex machines crashing without the fan in update 3 ? This problem may be related to that update.

Yes, but even when I left my case open and set up enough fans to create a hurricane inside my SAM Flex my crashing problems persisted. I had to resort to using HyperClock to change my clock speeds and now run it from my WBStartup to change clock speeds when I turn on the computer or hit the reset button.
My reason for looking at this is that I am trying to get both a Radeon HD card via a PCIE to PCI adapter and a 9250 card runing at the same time on My Sam Flex.

There is mention of secondary graphics cards in the SAM440e_setup docs which you might want to check out. If all else fails you could see if altering system timings with HyperCLock helps. HyperClock alters CPU timing, FSB timing (whatever that is) and PCI timing.
AmigaOne X1000 with 2GB memory - OS4.1 FE
xenic
 
Posts: 1148
Joined: Sun Jun 19, 2011 1:06 am

Re: Graphics Card -Sam 440ep-Flex PCI slot

Postby Spectre660 » Thu Aug 02, 2012 7:58 pm

The Graphics changes actually came in update 3. I would need to create Bootable SDcards of update 2 and 3 to isolated the update that introduced the problem. (I am sure it is update 3 though).
I had disabled the SaM440_Setup for my recent tests. It still does some functions for Radeon cards and especially Radeon HD cards . have a look at the Memcopy raw details of these two GfxBench2d results.

The second one is mine with the Sam440_setup active.

http://hdrlab.org.nz/benchmark/gfxbench ... Result/854
http://hdrlab.org.nz/benchmark/gfxbench ... Result/826

also compare to the best result for a Radeon 9250 posted for the newer 2.8 program and update 4.

http://hdrlab.org.nz/benchmark/gfxbench ... Result/822


The pci-flex update cannot be rolled back once it is applied. I applied it when it was released. This does not seem to be a problem as OS 4.1 update 1 has no issue with the pci slots used for the graphics card.
I remember having tons of problem at the end August 2011 when I applied the Update 3 files.
Thought that my Graphics cards was bad because the Sam kept crashing and would only work on low screen resolutions until I reconnected the rear case fan.

xenic wrote:
Spectre660 wrote:I once had to run the 9250 in the second PCI slot and It did work. The problem with slot 1 turned out to be a power supply issue.
I had a Graphics card in Slot 1 and a Sounblaster in slot 3 with slot 2 empty up to last month working ok.
I thought that the slot two problems for the graphics card was Uboot but I have just tested all the versions back to 1.31b and same problem.

I just looked and all my updates and it is a very confusing situation. In addition to the UBoot updates I also have an update named "SAM-pci-flex-update.lha" from Dec 2010 that affects PCI speed. I've never gotten confirmation that the pci-flex update is included in later UBoot updates or if it should still be applied. Don't forget about the SAM440ep_setup utility either; it changes PCI hardware registers. I also just updated my UBoot to the latest version (1.3.1e) and HyperClock now says that my UBoot is outdated!
Just Isolated it to Os 4,1 Updates after update 1 yesterday.

I just looked at the Update 2 files and I don't see any files that would affect PCI or graphics. Take a look at the Update 2 archive and see for yourself.
Do you remember some Sam-flex machines crashing without the fan in update 3 ? This problem may be related to that update.

Yes, but even when I left my case open and set up enough fans to create a hurricane inside my SAM Flex my crashing problems persisted. I had to resort to using HyperClock to change my clock speeds and now run it from my WBStartup to change clock speeds when I turn on the computer or hit the reset button.
My reason for looking at this is that I am trying to get both a Radeon HD card via a PCIE to PCI adapter and a 9250 card runing at the same time on My Sam Flex.

There is mention of secondary graphics cards in the SAM440e_setup docs which you might want to check out. If all else fails you could see if altering system timings with HyperCLock helps. HyperClock alters CPU timing, FSB timing (whatever that is) and PCI timing.
Spectre660
 
Posts: 1485
Joined: Sat Jun 18, 2011 3:16 pm
Location: Montserrat

Re: Graphics Card -Sam 440ep-Flex PCI slot

Postby xenic » Thu Aug 02, 2012 10:03 pm

@Spectre660
Why do you need to boot from an SD Card? Don't you have any spare boot partitions (or empty space on you hard-disk) to use? How are you booting from SD Cards; through USB? I have a spare boot partition on my hard disk that I use for testing.
AmigaOne X1000 with 2GB memory - OS4.1 FE
xenic
 
Posts: 1148
Joined: Sun Jun 19, 2011 1:06 am

Re: Graphics Card -Sam 440ep-Flex PCI slot

Postby Spectre660 » Thu Aug 02, 2012 10:47 pm

I could set up another test partition on my harddrive but dont like to do this with different versions of kickstart.
It only works properly like this if you use parthenope as your boot loader or change your normal boot priorities or mess with your kicklayout.
If not you end up booting with the kickstart loaded from the your first bootable Harddrive. I do use parthenope .
I use a USB SDcard reader or USB flash drive as an emergency boot drive as I am sure that the Kickstart and OS version will match.
Also easier than messing with a Hardrive partition also I can use a PC to create a rawimage file copy of the SDcard for later use if needed rather than redoing it. I have also found that by using SFS0 on the sd card it can be read and written to using Aros from a PC so useful if you have a problem where you cant boot from CD on the Amiga for some reason. Also I have a blank bootable SFS0 raw image file that can be copied to a SDcard etc from a PC and the then the OS files from Amiga OS 4.1 CD can be copied with Aros to create a bootable SDcard. When you only have one NG Amiga and there are no NG Amiga Users around for thousands of miles then you do these things.I have never met an NG Amiga user in person . Last classic Amiga user I spoke to in person was about 15 years ago.




xenic wrote:@Spectre660
Why do you need to boot from an SD Card? Don't you have any spare boot partitions (or empty space on you hard-disk) to use? How are you booting from SD Cards; through USB? I have a spare boot partition on my hard disk that I use for testing.
Spectre660
 
Posts: 1485
Joined: Sat Jun 18, 2011 3:16 pm
Location: Montserrat

Re: Graphics Card -Sam 440ep-Flex PCI slot

Postby xenic » Fri Aug 03, 2012 7:34 pm

Spectre660 wrote:It only works properly like this if you use parthenope as your boot loader or change your normal boot priorities or mess with your kicklayout.
If not you end up booting with the kickstart loaded from the your first bootable Harddrive. I do use parthenope .
I use a USB SDcard reader or USB flash drive as an emergency boot drive as I am sure that the Kickstart and OS version will match.

O.K. I don't like changing boot priorities either but I've done it several times to diagnose serious problems by raising the priority of an alternate boot partition with a different kickstart.
Also easier than messing with a Hardrive partition also I can use a PC to create a rawimage file copy of the SDcard for later use if needed rather than redoing it. I have also found that by using SFS0 on the sd card it can be read and written to using Aros from a PC so useful if you have a problem where you cant boot from CD on the Amiga for some reason. Also I have a blank bootable SFS0 raw image file that can be copied to a SDcard etc from a PC and the then the OS files from Amiga OS 4.1 CD can be copied with Aros to create a bootable SDcard. When you only have one NG Amiga and there are no NG Amiga Users around for thousands of miles then you do these things.I have never met an NG Amiga user in person . Last classic Amiga user I spoke to in person was about 15 years ago.

Since your problems seem to start with update3, I'll point out that there were big changes in the USB files for update3. Lot's of people (including me) reported serious USB problems when update3 was released. Before update3 I could boot with input devices (mouse & keyboard) connected to a USB hub. After update3 I must connect input devices directly to a SAM USB port or my input will be lost when I boot, reset or warm reboot my system. If I have a flash drive plugged in when I boot or reset my system, removing the flash drive after booting frequently causes a system freeze or crash within about 5 minutes.

You might want to try installing the pre-update3 USB files on a current boot device (SD card) or create a boot CD or boot partition in order to boot without USB involved. If USB isn't the problem, diagnosing your problem is probably going to be time consuming since the only method I can think of would be to revert to update2 files one at a time until the problem disappears.
AmigaOne X1000 with 2GB memory - OS4.1 FE
xenic
 
Posts: 1148
Joined: Sun Jun 19, 2011 1:06 am

Re: Graphics Card -Sam 440ep-Flex PCI slot

Postby Spectre660 » Sat Aug 04, 2012 1:12 am

I have used the SDCard method testing clean install version of OS 4.1 from Update 1 to update 4.
The problem sarts with Update 3 and continues with update 4.
No Problems when the 9250 card in in PCI slot number 1. But nothing after the Os 4.1 Splash screen if the 9250 is in slot number 2.
Works ok in slot number two with updates 1 and 2 .
Spectre660
 
Posts: 1485
Joined: Sat Jun 18, 2011 3:16 pm
Location: Montserrat

Re: Graphics Card -Sam 440ep-Flex PCI slot

Postby Spectre660 » Sat Aug 04, 2012 10:23 pm

There is also a problem on the U-Boot and Hardware side.
The Sam440ep-flex wil not boot with a Radeon HD card in slot number 1 and a Radeon 9250 in slot 2.
The rverse will boot, a 9250 in slot 1 and a Radeon HD in slot two but goes into an endless loop after the OS 4.1 boot logo.
With Amiga Os 4.1 update 2 Uboot displays on the Radeon HD Monitor and the OS 4.1 boot logo after on the 9250 Monitor.
Spectre660
 
Posts: 1485
Joined: Sat Jun 18, 2011 3:16 pm
Location: Montserrat

Next

Return to Platform: AmigaOne 500 and Sam series

Who is online

Users browsing this forum: No registered users and 5 guests

cron