Sam440ep and Radeon 9200 problems ...

This forum is for all AmigaOne 500, Sam440 and Sam460 specific issues.

Sam440ep and Radeon 9200 problems ...

Postby dh1 » Thu Feb 28, 2013 4:14 am

I have this same problem.

The MiniGL/Warp3D apps don't work, i get only blank screens-windows / bad colors and the system becomes extremely slow.

But now since the OS4.1 Update 1.

The new updates are always slightly improved the situation.

The OS4.1 Update 6 from any:

http://www.youtube.com/watch?v=SgFXAW4z ... e=g-crec-u
http://www.youtube.com/watch?v=N0l8IjEY ... e=g-crec-u
http://www.youtube.com/watch?v=5aoHyyc2 ... e=g-crec-u
http://www.youtube.com/watch?v=vUnijVvu ... e=g-crec-u
http://www.youtube.com/watch?v=fAd_8xMR ... e=g-crec-u
http://www.youtube.com/watch?v=pgH-HPAy ... e=g-crec-u
http://www.youtube.com/watch?v=souPy7BB ... e=g-crec-u
http://www.youtube.com/watch?v=GJG0qdZh ... e=g-crec-u
http://www.youtube.com/watch?v=Mr-ANij6 ... e=g-crec-u

These problems are real?
Or is it just my system produce?
Please help!
Thanks!

My Configuration:
SAM440ep + latest FW
667 Mhz
512 MByte RAM
R9200 PCI 128 MByte 1920x1200 (DELL 24")
AmigaOS4.1 update 6
User avatar
dh1
 
Posts: 14
Joined: Mon Dec 26, 2011 11:56 pm
Location: Hungary

Re: Sam440ep and Radeon 9200 problems ...

Postby Karlos » Thu Feb 28, 2013 2:41 pm

Can you post the versions of the following files:

LIBS:Warp3D.library
LIBS:Warp3D/GFXDrivers/W3D_Picasso96.library
LIBS:Warp3D/HWDrivers/W3D_R200.library
User avatar
Karlos
AmigaOS Core Developer
AmigaOS Core Developer
 
Posts: 84
Joined: Sun Jun 19, 2011 12:42 pm
Location: United Kingdom of England and anybody else that wishes to remain.

Re: Sam440ep and Radeon 9200 problems ...

Postby cha05e90 » Thu Feb 28, 2013 2:58 pm

dh1 wrote:SAM440ep + latest FW
667 Mhz
512 MByte RAM
R9200 PCI 128 MByte 1920x1200 (DELL 24")
AmigaOS4.1 update 6

Mini-ITX or Flex?
X1000|II/G4|440ep|2000/060|2000/040|1000
User avatar
cha05e90
 
Posts: 86
Joined: Fri Jun 17, 2011 11:15 pm
Location: Germany

Re: Sam440ep and Radeon 9200 problems ...

Postby dh1 » Thu Feb 28, 2013 10:16 pm

cha05e90 wrote:
dh1 wrote:SAM440ep + latest FW
667 Mhz
512 MByte RAM
R9200 PCI 128 MByte 1920x1200 (DELL 24")
AmigaOS4.1 update 6

Mini-ITX or Flex?


Hi!

Mini-ITX, one PCI slot
User avatar
dh1
 
Posts: 14
Joined: Mon Dec 26, 2011 11:56 pm
Location: Hungary

Re: Sam440ep and Radeon 9200 problems ...

Postby dh1 » Thu Feb 28, 2013 10:30 pm

Karlos wrote:Can you post the versions of the following files:

LIBS:Warp3D.library
LIBS:Warp3D/GFXDrivers/W3D_Picasso96.library
LIBS:Warp3D/HWDrivers/W3D_R200.library



Hi!

Warp3D.library v53.18
W3D_Picasso96.library v53.10
W3D_R200.library v53.21
User avatar
dh1
 
Posts: 14
Joined: Mon Dec 26, 2011 11:56 pm
Location: Hungary

Re: Sam440ep and Radeon 9200 problems ...

Postby Karlos » Fri Mar 01, 2013 1:26 am

A few more questions.

Can you tell us exactly which versions of these games you have?

What colour format is your Workbench screen (Check the screenmode prefs 16 bit, 24 bit, 32 bit etc., RGBA, ARGB so on).

Is your Workbench composited or not?

Are you able to run those games full screen on their own display, rather than window mode? Don't worry if they are centred or awkwardly stretched by your monitor, what I am trying to find out is whether there's a problem somewhere copying the back buffer to the window. If they are in radically different formats for some reason, that could be a problem.
User avatar
Karlos
AmigaOS Core Developer
AmigaOS Core Developer
 
Posts: 84
Joined: Sun Jun 19, 2011 12:42 pm
Location: United Kingdom of England and anybody else that wishes to remain.

Re: Sam440ep and Radeon 9200 problems ...

Postby dh1 » Fri Mar 01, 2013 3:54 am

Thanks!

Hurrican: latest 1.0.0.7 - Window mode
Workbench colour format:
if 16 bit
- The game picture falls apart
- Extremely slow
- Wrong colors
- The operating system is extremely slow
if 32 bit
- The game picture is fine, does not fall apart
- Extremely slow
- Wrong colors
- The operating system is extremely slow.
Compositing effects off

Hurrican: latest 1.0.0.7 - Fullscreen mode
Workbench colour format:
if 16 bit
- The game picture falls apart
- Extremely slow
- Wrong colors
- The operating system is extremely slow
if 32 bit
- The game picture falls apart
- Extremely slow
- Wrong colors
- The operating system is extremely slow.
Compositing effects off

GLQuake OS4: latest 1.09b7 - Window mode
Workbench colour format:
if 16 bit
- The game picture falls apart
- Extremely slow
- Wrong colors
- The operating system is extremely slow.
if 32 bit
- The game picture is fine, does not fall apart
- Extremely slow
- Wrong colors
- The operating system is extremely slow.
Compositing effects off

GLQuake OS4: latest 1.09b7 - Fullscreen mode - Does not support 24/32-bit fullscreen
Workbench colour format:
if 16 bit
- The game picture falls apart
- Extremely slow
- Wrong colors
- The operating system is extremely slow.
if 32 bit
- The game picture falls apart
- Extremely slow
- Wrong color
Compositing effects off

There is no difference between a 16 and 32-bit modes. Only difference is that 16-bit mode, the picture falls apart, not 32 bit mode!
24-bit mode does not give me the AmigaOS. Only 8, 16 and 32.

The integrated GPU is working well. There are no errors. Only a few of the graphics memory ...

But the integrated DVI output on my SAM440 wrong colors on my motherboard. I do not know why. From the beginning it is. D-SUB output all good.

The ACUBE did not answer my question with DVI problem.
User avatar
dh1
 
Posts: 14
Joined: Mon Dec 26, 2011 11:56 pm
Location: Hungary

Re: Sam440ep and Radeon 9200 problems ...

Postby cha05e90 » Fri Mar 01, 2013 9:16 am

dh1 wrote:Mini-ITX, one PCI slot

Then you are lost. AFAIK 3D support does not work with "secondary" graphics cards in the Mini-ITX Sams, only with the internal M9 Radeon chip. Maybe you should ask ACube whether it is (or will be) possible one day.
X1000|II/G4|440ep|2000/060|2000/040|1000
User avatar
cha05e90
 
Posts: 86
Joined: Fri Jun 17, 2011 11:15 pm
Location: Germany

Re: Sam440ep and Radeon 9200 problems ...

Postby dh1 » Sat Mar 02, 2013 4:17 am

Some people have claimed that they are working on SAM440EP-ITX system board to the PCI bus on the Radeon 9xxx in 3D.

Officially, there is nowhere written that it does not work!

Also, the ACube selling R9000 series cards to SAM motherboards.

ACube not responding to requests.
Last 3 days I wrote them.
There was no answer.

You can say that the senseless in SAM440EP-ITX motherboards graphics cards installed.
Yes or No?
User avatar
dh1
 
Posts: 14
Joined: Mon Dec 26, 2011 11:56 pm
Location: Hungary

Re: Sam440ep and Radeon 9200 problems ...

Postby cha05e90 » Sat Mar 02, 2013 11:35 am

dh1 wrote:Also, the ACube selling R9000 series cards to SAM motherboards.

They sell them with the Flex variant of the Sam440ep - not the Mini-ITX version. I wrote "AFAIK" - so I'm not sure, but I read more often about non-working 3D with additional graphics cards in M9 equipped Sams. Maybe it is possible with some kind of "PCIgraphics.card" stunt and the right firmware to get it working, but I never heard of this. This is why I supposed you ask ACube about this. Up to now I can't remember that anyone has got 3D with an additional card in the Mini-ITX Sams.
X1000|II/G4|440ep|2000/060|2000/040|1000
User avatar
cha05e90
 
Posts: 86
Joined: Fri Jun 17, 2011 11:15 pm
Location: Germany


Return to Platform: AmigaOne 500 and Sam series

Who is online

Users browsing this forum: No registered users and 4 guests