PCIe x1 based Sillicon Image 3132 in AmigaOne 500?

This forum is for all AmigaOne 500, Sam440 and Sam460 specific issues.

PCIe x1 based Sillicon Image 3132 in AmigaOne 500?

Postby HKvalhe » Fri May 03, 2013 7:29 pm

Hi, i happen to have a PCIe x1 based SATA2 (i think) Sillicon Image 3132 controller that i am curious to test out, now that i have removed the J16 jumper to fully allow for use of PCIe x1 cards, according to the SAM460ex User Manual.

Do any of you know if this PCIe SATA2 controller is supported, with a driver, or is this not available yet? Would help a lot if somebody could tell me this.

This is not really a problem situation, but more like a question of advice to avoid doing mistakes. Any help is good, which i appreciate. :)

UPDATE: I gave the card a test, but doesn't show any support in UBoot or the main AmigaOS4, so i guess i have to wait with this card.
Helge Kvalheim, Norway
AmigaOne 500 @ 1.15Ghz Samsung SSD 840 EVO 500GB, AmigaOS 4.1 Final, 2GB DDR2, Sapphire Radeon HD 6670 1GB GDDR5 PCI-E, ESI@Juli XTe PCIe audio
User avatar
HKvalhe
 
Posts: 256
Joined: Mon Sep 03, 2012 10:39 am
Location: Bergen, Norway

Re: PCIe x1 based Sillicon Image 3132 in AmigaOne 500?

Postby ssolie » Fri May 03, 2013 10:28 pm

The 3132 is not supported and there are no plans to support it at this time.
AmigaOS Development Team Lead
Be authentic. Get AmigaOS.
User avatar
ssolie
AmigaOS Core Developer
AmigaOS Core Developer
 
Posts: 1000
Joined: Mon Dec 20, 2010 9:51 pm
Location: Canada

Re: PCIe x1 based Sillicon Image 3132 in AmigaOne 500?

Postby HKvalhe » Sat May 04, 2013 10:07 am

ssolie wrote:The 3132 is not supported and there are no plans to support it at this time.


Oh, alright. Thank you for informing on this, Ssolie. Will other SATA2/3 cards be supported? How will this be done? The problem with the onboard PCIe x1 and SATA2 is that they can't be used at the same time, as only ONE of these can be used on the SAM460ex board at a time, as these are mutually elusive. That's the limitation of the motherboard, so how will this issue be addressed?
Helge Kvalheim, Norway
AmigaOne 500 @ 1.15Ghz Samsung SSD 840 EVO 500GB, AmigaOS 4.1 Final, 2GB DDR2, Sapphire Radeon HD 6670 1GB GDDR5 PCI-E, ESI@Juli XTe PCIe audio
User avatar
HKvalhe
 
Posts: 256
Joined: Mon Sep 03, 2012 10:39 am
Location: Bergen, Norway

Re: PCIe x1 based Sillicon Image 3132 in AmigaOne 500?

Postby Godfather » Wed Jun 05, 2013 10:09 pm

Dear HKvalhe,

one question ist the PCI-e card shown under uboot with the command "pci" ? try also a gfx and a atheros wlan card with no success. both doesn't recognise from the system. (uboot and AOS 4.1.6 with Ranger)

thanks for a short info.

kind regards

Godfather
Godfather
 
Posts: 9
Joined: Sun Jun 26, 2011 1:24 am

Re: PCIe x1 based Sillicon Image 3132 in AmigaOne 500?

Postby Spectre660 » Wed Jun 05, 2013 10:54 pm

Use the bus number with uboot pci.
pci 2
Will show the pcie graphics card


Godfather wrote:Dear HKvalhe,

one question ist the PCI-e card shown under uboot with the command "pci" ? try also a gfx and a atheros wlan card with no success. both doesn't recognise from the system. (uboot and AOS 4.1.6 with Ranger)

thanks for a short info.

kind regards

Godfather
Spectre660
 
Posts: 1398
Joined: Sat Jun 18, 2011 3:16 pm
Location: Montserrat

Re: PCIe x1 based Sillicon Image 3132 in AmigaOne 500?

Postby HKvalhe » Tue Jun 11, 2013 8:03 am

Thank you everybody for many fine and useful feedback :) But according to Ssolie, the Sillicon Image 3132 card won't be supported. I suppose there will be better solutions. :)
Helge Kvalheim, Norway
AmigaOne 500 @ 1.15Ghz Samsung SSD 840 EVO 500GB, AmigaOS 4.1 Final, 2GB DDR2, Sapphire Radeon HD 6670 1GB GDDR5 PCI-E, ESI@Juli XTe PCIe audio
User avatar
HKvalhe
 
Posts: 256
Joined: Mon Sep 03, 2012 10:39 am
Location: Bergen, Norway


Return to Platform: AmigaOne 500 and Sam series

Who is online

Users browsing this forum: No registered users and 4 guests