DiskImage lockups...

This forum is for all AmigaOne 500, Sam440 and Sam460 specific issues.

DiskImage lockups...

Postby Belxjander » Sun Jun 22, 2014 1:52 pm

There is a thread for this in the X1000 section of the forums, and I have this same lockup issue,

there exists two variations on the lockup.

I either have a complete non-functional/non-response lockup...
or with compositing enabled, everything not the mouse is locked for some graphics issue.

And the above occurs everytime diskimagegui is run to display anything windowed.
Belxjander
 
Posts: 276
Joined: Mon May 14, 2012 11:26 pm
Location: 日本千葉県松戸市 / Matsudo City, Chiba, Japan

Re: DiskImage lockups...

Postby Raziel » Fri Jun 27, 2014 6:12 pm

Belxjander wrote:There is a thread for this in the X1000 section of the forums, and I have this same lockup issue,

there exists two variations on the lockup.

I either have a complete non-functional/non-response lockup...
or with compositing enabled, everything not the mouse is locked for some graphics issue.

And the above occurs everytime diskimagegui is run to display anything windowed.

Have you tried the soltution from X1000 thread?

iirc it had something to do with abroken prefs file (*not* DiskImageGUI's one)
If slaughterhouses had glass walls, everyone would be a vegetarian. ~ Sir Paul McCartney
-
Did everything just taste purple for a second? ~ Philip J. Fry
-
Ain't got no cash, ain't got no style, ladies vomit when I smile. ~ Dr. John Zoidberg
User avatar
Raziel
 
Posts: 839
Joined: Sat Jun 18, 2011 5:00 pm
Location: A haunted Castle somewhere in the Bavarian Mountains

Re: DiskImage lockups...

Postby nbache » Fri Jun 27, 2014 11:16 pm

Raziel wrote:iirc it had something to do with abroken prefs file (*not* DiskImageGUI's one)
It's the gui.prefs.

I have Sundown's backup of the gui.prefs which caused it, and I'm in the process (in spare moments) of trying to isolate which setting triggers the problem. I've captured a couple of crash logs, but they weren't that helpful (to my eye). If/when I find something significant, I'll make a bug report about it, including crashlogs etc. And of course let you all know which setting (or settings?) it was.

Best regards,

Niels
User avatar
nbache
Beta Tester
Beta Tester
 
Posts: 1287
Joined: Mon Dec 20, 2010 8:25 pm
Location: Copenhagen, Denmark

Re: DiskImage lockups...

Postby Belxjander » Sat Jun 28, 2014 9:11 am

Raziel: yes, gui.prefs...and I already reset and played with everything there with no changes.

@nbache: Would a whole set of GUI.prefs file which trigger the problem help narrow down the setting concerned?

I have a copy installation with update 6 which I am pulling base materials from.

the only setting that has any effect so far is composition in disconnecting the mouse from the rest of the graphical lockup conditions

Should I check out anything else?
Belxjander
 
Posts: 276
Joined: Mon May 14, 2012 11:26 pm
Location: 日本千葉県松戸市 / Matsudo City, Chiba, Japan

Re: DiskImage lockups...

Postby nbache » Sat Jun 28, 2014 11:57 pm

Belxjander wrote:@nbache: Would a whole set of GUI.prefs file which trigger the problem help narrow down the setting concerned?
Thanks, but no, not necessary. I can already reproduce it with Sundown's file, so I just have some work to do to isolate it.

Best regards,

Niels
User avatar
nbache
Beta Tester
Beta Tester
 
Posts: 1287
Joined: Mon Dec 20, 2010 8:25 pm
Location: Copenhagen, Denmark

Re: DiskImage lockups...

Postby Belxjander » Sun Jun 29, 2014 4:22 pm

Well it was in this condition from time of installation for me.

update 4 was current at the time, maybe that will help narrow down the change set

edits are typos
Belxjander
 
Posts: 276
Joined: Mon May 14, 2012 11:26 pm
Location: 日本千葉県松戸市 / Matsudo City, Chiba, Japan


Return to Platform: AmigaOne 500 and Sam series

Who is online

Users browsing this forum: Google [Bot] and 5 guests

cron