OS4.1 FE (SAM440) USB stick icon appears twice

This forum is for all AmigaOne 500, Sam440 and Sam460 specific issues.

Re: OS4.1 FE (SAM440) USB stick icon appears twice

Postby xenic » Thu Oct 22, 2015 1:08 am

broadblues wrote:@xenic
The icon is only stuck on the workbench if a lock remains on it.

Apparently Workbench puts a lock on a directory when you open a window for that directory on Workbench. Making a directory the 'current directory' in a shell also locks the directory. I retried my simple procedure of inserting a USB stick, opening it in a Workbench window, removing the USB stick and then closing the window. The USB stick icon remained on my Workbench for over an hour. However, the USB stick I tested is formatted with SFS2. When I tried with a FAT formatted USB stick, the icon disappears after a few seconds. If I select the "Window/Show/All Files" for the FAT USB stick window. I get an "Insert volume" requester for the stuck SFS2 USB flash icon for each file icon that gets displayed. I also noticed that the USB MassStorages window is showing a 'W' (Write) when the USB stick is being read.

EDIT: I tested with an FFS formatted USB stick and it works normally like a FAT formatted USB stick. It looks like the stranded icon issue is an SFS2 issue and not a USB issue. It still should be fixed.
AmigaOne X1000 with 2GB memory - OS4.1 FE
xenic
 
Posts: 978
Joined: Sun Jun 19, 2011 1:06 am

Re: OS4.1 FE (SAM440) USB stick icon appears twice

Postby zabox » Thu Oct 22, 2015 9:25 am

The USB stick I tried all this with and got the described problems with is FAT formated.
zabox
 
Posts: 7
Joined: Sun Jul 26, 2015 8:07 am

Re: OS4.1 FE (SAM440) USB stick icon appears twice

Postby broadblues » Thu Oct 22, 2015 12:56 pm

xenic wrote:
broadblues wrote:@xenic
The icon is only stuck on the workbench if a lock remains on it.

Apparently Workbench puts a lock on a directory when you open a window for that directory on Workbench. Making a directory the 'current directory' in a shell also locks the directory. I retried my simple procedure of inserting a USB stick, opening it in a Workbench window, removing the USB stick and then closing the window. The USB stick icon remained on my Workbench for over an hour. However, the USB stick I tested is formatted with SFS2. When I tried with a FAT formatted USB stick, the icon disappears after a few seconds. If I select the "Window/Show/All Files" for the FAT USB stick window. I get an "Insert volume" requester for the stuck SFS2 USB flash icon for each file icon that gets displayed. I also noticed that the USB MassStorages window is showing a 'W' (Write) when the USB stick is being read.

EDIT: I tested with an FFS formatted USB stick and it works normally like a FAT formatted USB stick. It looks like the stranded icon issue is an SFS2 issue and not a USB issue. It still should be fixed.


Were there any left out icons on the volumes on the stick that showed problems?

I tested last night with a RDB formatted stick with 4 sfs2 partitions, all icons disappear promptly on remove , except the the volume icons for the two partitions that had left out icons.

I raised a BZ on that particular issue.
User avatar
broadblues
AmigaOS Core Developer
AmigaOS Core Developer
 
Posts: 451
Joined: Sat Jun 18, 2011 3:40 am
Location: Portsmouth, UK

Re: OS4.1 FE (SAM440) USB stick icon appears twice

Postby xenic » Thu Oct 22, 2015 7:45 pm

broadblues wrote:Were there any left out icons on the volumes on the stick that showed problems?

No. I just left the window for the USB stick (single partition) open until after the USB stick was removed and then closed the window.

I tested last night with a RDB formatted stick with 4 sfs2 partitions, all icons disappear promptly on remove , except the the volume icons for the two partitions that had left out icons.

I raised a BZ on that particular issue.


What do you mean by RDB formatted? I think my SFS2 USB sticks were formatted with the USB MassStorages window but to be sure I'm going to get a couple of cheap low capacity USB sticks to experiment with. That way I can be sure how they are formatted. I'll let you know the result later.
AmigaOne X1000 with 2GB memory - OS4.1 FE
xenic
 
Posts: 978
Joined: Sun Jun 19, 2011 1:06 am

Re: OS4.1 FE (SAM440) USB stick icon appears twice

Postby broadblues » Thu Oct 22, 2015 8:07 pm

What do you mean by RDB formatted?


I "installed" and partitioned in MediaToolBox
User avatar
broadblues
AmigaOS Core Developer
AmigaOS Core Developer
 
Posts: 451
Joined: Sat Jun 18, 2011 3:40 am
Location: Portsmouth, UK

Re: OS4.1 FE (SAM440) USB stick icon appears twice

Postby zabox » Thu Oct 22, 2015 8:09 pm

For my FAT partitioned USB Stick the info window says the stick has an MBR.
zabox
 
Posts: 7
Joined: Sun Jul 26, 2015 8:07 am

Re: OS4.1 FE (SAM440) USB stick icon appears twice

Postby broadblues » Thu Oct 22, 2015 8:14 pm

It would do by default.

Only change to RDB for amiga specific usage.
User avatar
broadblues
AmigaOS Core Developer
AmigaOS Core Developer
 
Posts: 451
Joined: Sat Jun 18, 2011 3:40 am
Location: Portsmouth, UK

Re: OS4.1 FE (SAM440) USB stick icon appears twice

Postby xenic » Fri Oct 23, 2015 10:44 pm

@broadblues
I picked up a couple of cheap USB sticks. I formatted one as SFS2 with MediaToolBox and the other as SFS2 with USB MassStorage. They both exibit the same problem; If I open a window for either USB stick and remove the stick before closing the window, the drive icon stays on Workbench indefinately after I close the window. This issue seems to apply only to SFS formatted USB sticks since both FFS and FAT partitioned stick icons disappear a second after closing the window.
AmigaOne X1000 with 2GB memory - OS4.1 FE
xenic
 
Posts: 978
Joined: Sun Jun 19, 2011 1:06 am

Previous

Return to Platform: AmigaOne 500 and Sam series

Who is online

Users browsing this forum: No registered users and 3 guests