Sam460ex Audio & Video freeze with PCIEx1 CMI8738 Sound Card

This forum is for all AmigaOne 500, Sam440 and Sam460 specific issues.

Sam460ex Audio & Video freeze with PCIEx1 CMI8738 Sound Card

Postby Spectre660 » Mon Sep 19, 2016 8:47 pm

On Sam460ex using pciex1 CMI8738 with AmigaOS 4.1FE causes frequent audio and video freezes during video playback with random noise during freeze. after about 30 seconds normal playback returns until next freeze. Happens with Mplayer ,DVplayer and alpha Emotion player. Audio playback with out video works ok .Video card is Radeon HD7750 with RadeonHD 2.18 driver .
Audio and video playback work ok with a pciex1 Envy24HT or onboard sound .
Spectre660
 
Posts: 1201
Joined: Sat Jun 18, 2011 3:16 pm
Location: Montserrat

Re: Sam460ex Audio & Video freeze with PCIEx1 CMI8738 Sound

Postby tonyw » Tue Sep 20, 2016 2:32 am

What is the version of Devs/AHI/cmi8738.audio ?
cheers
tony
User avatar
tonyw
AmigaOS Core Developer
AmigaOS Core Developer
 
Posts: 1195
Joined: Wed Mar 09, 2011 2:36 pm
Location: Sydney, Australia

Re: Sam460ex Audio & Video freeze with PCIEx1 CMI8738 Sound

Postby Spectre660 » Tue Sep 20, 2016 3:40 am

cmi8738.audio 5.17 (11/04/2006)
Spectre660
 
Posts: 1201
Joined: Sat Jun 18, 2011 3:16 pm
Location: Montserrat

Re: Sam460ex Audio & Video freeze with PCIEx1 CMI8738 Sound

Postby Spectre660 » Sat Jan 14, 2017 12:17 am

Similar issue seen with X5000 .

viewtopic.php?f=57&t=3625
Spectre660
 
Posts: 1201
Joined: Sat Jun 18, 2011 3:16 pm
Location: Montserrat

Re: Sam460ex Audio & Video freeze with PCIEx1 CMI8738 Sound

Postby Spectre660 » Sat Jan 14, 2017 12:56 am

It is possible that some cards have slightly different versions of something.
(maybe the Asmedia 1083 bridge chip ?)
https://lists.gt.net/linux/kernel/1484406
https://git.kernel.org/cgit/linux/kerne ... 2751d6df85
Spectre660
 
Posts: 1201
Joined: Sat Jun 18, 2011 3:16 pm
Location: Montserrat

Re: Sam460ex Audio & Video freeze with PCIEx1 CMI8738 Sound

Postby Spectre660 » Sat Jan 14, 2017 1:45 pm

My card has the ASM 1083 bridgechip rev 1 which is know to have problems with DMA .
Newer cards with the rev 3 chip should work ok .
Attachments
ASM1083_Rev_1.jpg
Spectre660
 
Posts: 1201
Joined: Sat Jun 18, 2011 3:16 pm
Location: Montserrat


Return to Platform: AmigaOne 500 and Sam series

Who is online

Users browsing this forum: Majestic-12 [Bot] and 1 guest