Page 1 of 1

Internet speed

PostPosted: Fri Sep 01, 2017 2:49 am
by kilaueabart
My ISP says I am signed up for 15 Mbps service (DSL). An on-line test I just took says I get about 11 Mbps download.

Another ISP (my cable TV provider) keeps mailing me an offer of 100 Mbps for a slightly lower price.

I'm tempted. But then I wondered: Maybe ~11 Mbps is about the best I can hope for with a SAM460ex?

Re: Internet speed

PostPosted: Sat Sep 02, 2017 7:39 am
by daveyw
You may not get too much of a speed boost, but I think the culprit is OS4 rather than your SAM.

On my A1XE, I originally used to get an upload speed of around 100 - 130 kb/s on standard broadband. Then I got fibre, and while my other devices got within spitting distance of the stated 10 MB/s upload speed, my A1XE still struggled to make 130 kb/s tops. And even then, the CPU was putting in alot of hard work.

Now that I have my X5000, I was hoping for a big increase in speed, but I still manage the same 130 kb/s upload speed. (I should really do a speed test on Linux).

I wish we had a more robust TCP/IP stack than RoadShow.

Anyway, if it's cheaper, go for it! Presumably you have other devices that would benefit from the increased bandwidth. My fibre package is 30 MB/s download, and with that I can stream HD video from Netficks pretty comfortably, just not on my Amiga.

Re: Internet speed

PostPosted: Sat Sep 09, 2017 3:02 pm
by Raziel
kilaueabart wrote:My ISP says I am signed up for 15 Mbps service (DSL). An on-line test I just took says I get about 11 Mbps download.

Another ISP (my cable TV provider) keeps mailing me an offer of 100 Mbps for a slightly lower price.

I'm tempted. But then I wondered: Maybe ~11 Mbps is about the best I can hope for with a SAM460ex?

The culprit is Roadshow.

You can tweak the settings there but will only gain very few KB/s.

The TCP/IP stack needs to be rewritten to add the possibility to work with Gigabit speeds and need to finally drop the long lasting analogue/ISDN stuff that is slowing it down aswell.

Or so i was told (not meaning that i repeated everything correct)

Fact is, i have a 100 MBit line, a Gigabit speed PCI card and only get 8-9 MBit to my X1000
On the *same* line a Linux notebook leeches the whole 100 Mbit off of the line, so it's clearly not the cable, but the TCP/IP stack.

Re: Internet speed

PostPosted: Sun Sep 10, 2017 5:01 am
by kilaueabart
Raziel wrote:
kilaueabart wrote:... Maybe ~11 Mbps is about the best I can hope for with a SAM460ex?

The culprit is Roadshow.
...
Fact is, i have a 100 MBit line, a Gigabit speed PCI card and only get 8-9 MBit to my X1000
On the *same* line a Linux notebook leeches the whole 100 Mbit off of the line, so it's clearly not the cable, but the TCP/IP stack.

As it happens, I do most of my internet stuff on a Raspberry Pi, nowadays, due to some dissatisfaction with Odyssey. I almost always use the Rpi3 via the Amiga using TwinVNC, but it has its own internet connection, so maybe Roadshow would have no effect.

My newest offer is a 30-day money-back trial, so I'll call them Monday and see.