FreeSpace OS 4.1 Installation issues

FreeSpace OS 4.1 Installation issues

Postby merlinkv » Fri Jun 24, 2011 3:32 pm

Hi to all

Few days a go I bought some Hyperion Games and, of course, the Descent FreeSpace.

My system is a SAM440ep-Flex with OS 4.1 Update2.

I found some troubles in the CD Installation script. Under 4.1 and 4.1 Update 1 game is installed without problems. But under 4.1 Update2 is not possible to install, everytime I get an "Interpreter Error" and installation stops :shock: .

So, I needed to:

- Reformat my System partition
- Reinstall my OS 4.1 Update1
- Install FreeSpace
- Update my OS to Update2
- Apply FreeSpace Patch

I think an update of the installation script (maybe one updated CD image for registered users) is highly recommended.

Best wishes
merlinkv
 
Posts: 12
Joined: Thu Jun 23, 2011 10:25 pm

Re: FreeSpace OS 4.1 Installation issues

Postby nubechecorre » Fri Jun 24, 2011 9:31 pm

Have you registered your game on Hyperion's portal and downloaded the last update for amiga os 4.1?
http://www.os4games.it

Sam440ep mini-itx

Classic System:

Amiga 1200
PowerPC 603+ 68040 25 Mhz + 256MbRam
Radeon 9250 128Mb VRam
Voodoo 3 3000 16Mb VRam
HD-Western Digital Caviar Blue 500 Gb PATA
DVD-RW LG Dual Layer
SoundBlaster PCI 128
4xEIDE Buffered Interface Elbox
Cocolino Interface Elbox
AmigaOne White Mouse
User avatar
nubechecorre
 
Posts: 68
Joined: Sat Jun 18, 2011 12:28 am
Location: Sanremo

Re: FreeSpace OS 4.1 Installation issues

Postby merlinkv » Sun Jun 26, 2011 12:10 am

Hi,

Yes, of course, is registered and the last update installed.

The problem still on installation, as I said, with OS 4.1 Update1 I can install the game without issues. The problem is with the OS 4.1 Update 2.

If I try to install the game under OS 4.1 Update 2 I receive every time a message "Interpreter: Executing non-function in line 9", I have the same error with Heretic II but in this case is "Interpreter: Executing non-function in line 24".

So, the only way to install this games are under 4.1 Update 1 ??? Anyone knows a solution?

Thanks & Best wishes
merlinkv
 
Posts: 12
Joined: Thu Jun 23, 2011 10:25 pm

Re: FreeSpace OS 4.1 Installation issues

Postby nbache » Sun Jun 26, 2011 8:38 pm

merlinkv wrote:The problem still on installation, as I said, with OS 4.1 Update1 I can install the game without issues. The problem is with the OS 4.1 Update 2.

If I try to install the game under OS 4.1 Update 2 I receive every time a message "Interpreter: Executing non-function in line 9", I have the same error with Heretic II but in this case is "Interpreter: Executing non-function in line 24".

What are the versions of SYS:Utilities/Installer in your Update 1 and Update 2 installations?

Also, I assume you don't have any other tool called Installer installed anywhere on either one?

Best regards,

Niels
User avatar
nbache
Beta Tester
Beta Tester
 
Posts: 1183
Joined: Mon Dec 20, 2010 8:25 pm
Location: Copenhagen, Denmark

Re: FreeSpace OS 4.1 Installation issues

Postby merlinkv » Fri Jul 01, 2011 3:52 pm

Hi Niels,

Sorry for the big delay to answer. :oops:

Only the original ones. I don't installed extra soft.

My OS 4.1 Update2 Installer is v53.1

Thanks in advance
merlinkv
 
Posts: 12
Joined: Thu Jun 23, 2011 10:25 pm

Re: FreeSpace OS 4.1 Installation issues

Postby nbache » Sat Jul 02, 2011 12:15 am

merlinkv wrote:My OS 4.1 Update2 Installer is v53.1

And what about under Update 1, is it the same Installer (53.1) or another version? I'd have thought that Update 1 also had 53.1 (but can't check right now myself). So if they are the same, something else must be causing the difference.

Best regards,

Niels
User avatar
nbache
Beta Tester
Beta Tester
 
Posts: 1183
Joined: Mon Dec 20, 2010 8:25 pm
Location: Copenhagen, Denmark

Re: FreeSpace OS 4.1 Installation issues

Postby merlinkv » Sun Jul 03, 2011 7:35 pm

Hi Niels,

Finally I found one solution.

- Installer from Update 1.... CLI command "version Installer" shows only a blank line :shock: Size 317220 bytes

- Installer from Update 2 is 53.1 size 387420 bytes.

My steps:

- Fresh installation of 4.1 Update 1
- Copy "Installer" as "Installer.Update1"
- Installed 4.1 Update2
- Copy "Installer" as "Installer.Update2"
- Copy "Installer.Update1" as "Installer"
- System reboot

All games can be Installed without issues :D

Now I'm sure the Update 2 "Installer" have compatibility installation issues with at least three games: Descent Freespace, Heretic II & Quake II

Thanks for your help

Best regards

Pablo
merlinkv
 
Posts: 12
Joined: Thu Jun 23, 2011 10:25 pm

Re: FreeSpace OS 4.1 Installation issues

Postby Peter Gordon » Mon Jul 04, 2011 5:38 pm

merlinkv wrote:I found some troubles in the CD Installation script. Under 4.1 and 4.1 Update 1 game is installed without problems. But under 4.1 Update2 is not possible to install, everytime I get an "Interpreter Error" and installation stops :shock: .


DON'T use the installer on the CD. Use the installer in the Freespace OS4.1 update. It can install the full game from CD for you. No need to mess around with installer versions.
Peter Gordon
AmigaOS Core Developer
AmigaOS Core Developer
 
Posts: 10
Joined: Sat Jun 18, 2011 9:49 am


Return to Freespace

Who is online

Users browsing this forum: No registered users and 1 guest