Listbrowser AutoVirtualWidth Bug

This forum is for general developer support questions.

Listbrowser AutoVirtualWidth Bug

Postby tbreeden » Fri Jun 14, 2013 7:28 pm

With AOS 4.1 upd 6, ListBrowser.gadget 53.52,
the LISTBROWSER_AutoVirtualWidth tag does not seem to work if
the list has fixed width columns.

The horizontal scroller scrolls well past the end of the columns and
begins re-displaying part of the first columns.

Explicitly using LISTBROWSER_VirtualWidth set to ncols*<staticwidth>
seems to work, as does just using LISTBROWSER_AutoWidth.

This is the same thing reported about a year ago in

"problem with horizontal slider in listbrowser-gadget
http://forum.hyperion-entertainment.biz/viewtopic.php?f=26&t=1144

No followup appears, beyond not using fixed size columns.

Is it on the bug list?

Thanks,

Tom
User avatar
tbreeden
 
Posts: 136
Joined: Sat Jun 18, 2011 1:57 am
Location: Charlottesville, VA, USA

Re: Listbrowser AutoVirtualWidth Bug

Postby Rigo » Fri Jun 14, 2013 9:14 pm

Somehow I managed to miss the original thread, so it's the first I've heard about it. I'll look into this.

Simon
User avatar
Rigo
AmigaOS Core Developer
AmigaOS Core Developer
 
Posts: 330
Joined: Mon Jan 17, 2011 10:42 pm

Re: Listbrowser AutoVirtualWidth Bug

Postby mritter0 » Thu Dec 31, 2015 4:19 am

This issue still exists. Is there going to be a fix for it any time soon?
Workbench Explorer - A better way to browse drawers
User avatar
mritter0
 
Posts: 212
Joined: Mon Aug 25, 2014 10:41 pm
Location: Bettendorf, IA, USA

Re: Listbrowser AutoVirtualWidth Bug

Postby salass00 » Thu Dec 31, 2015 12:11 pm

mritter0 wrote:This issue still exists. Is there going to be a fix for it any time soon?


I just found the cause of the problem after a lot of debugging and fixed it.
User avatar
salass00
AmigaOS Core Developer
AmigaOS Core Developer
 
Posts: 504
Joined: Sat Jun 18, 2011 4:12 pm
Location: Finland


Return to General Developer Support

Who is online

Users browsing this forum: No registered users and 1 guest

cron