Help needed setting up Cubic IDE to work with OS4.x SDK

Have a question about our Software Developer Kit? Ask them here.

Help needed setting up Cubic IDE to work with OS4.x SDK

Postby AmigaDave » Thu Sep 06, 2012 9:30 am

As title says, I need some help in setting up the Cubic IDE to properly use the OS4.x SDK.

I have both items installed, but the Cubic IDE does not appear to know that there is any C/C++ compiler installed on my X1000 as no C/C++ menu choice shows up in the choice of programming languages format menu (or what ever that menu is really called).

If any of you are using Cubic IDE with the OS4.x SDK, I would appreciate knowing how you set them up to work together.

As you might have already guessed, I am just beginning to learn how to program on any platform. I had started learning some AmigaE, but then switched to C/C++ when I learned of the Programming Seminar that will be presented the two days immediately before the 2012 AmiWest Show 6 weeks from now. I started doing C exercises and reading about the C programming language again a few weeks ago, using my G4 PowerBook and MorphOS3.1 with the MorphOS SDK and Scribble editor. That works well, but I should be learning on the same system that I will be using during the Programming Seminar, which is why I want to get set up with Cubic IDE and the OS4.x SDK on my X1000 ASAP.

Any help would be much appreciated.
Proud owner of 10+ Commodore Amiga 680x0 computers
First Contact AmigaOne X1000 Dual Core 1.8GHz PA6T w/OS4.1FE
Dual 2.7GHz G5 PowerMac w/MorphOS3.7
1.5GHz G4 PMac MDD w/MorphOS3.7
1.5GHz G4 MacMini w/MorphOS3.7
17" 1.67GHz G4 PBooks w/MorphOS3.7
Efika 5200b w/MorphOS3.7
FPGA Arcade Replay w/AmigaOS3.x
AmigaDave
 
Posts: 145
Joined: Wed Jan 04, 2012 4:31 am
Location: Lake Shastina, California, USA

Re: Help needed setting up Cubic IDE to work with OS4.x SDK

Postby mechanic » Thu Sep 06, 2012 6:55 pm

AmigaDave wrote: Cubic IDE does not appear to know that there is any C/C++ compiler installed on my X1000 as no C/C++ menu choice shows up in the choice of programming languages format menu (or what ever that menu is really called).


I think it's best to put CodeBench in the same drawer, or on same drive as SDK.

If not, then you will have to set the paths to everything when starting a new project in the Project Information window CodeBench pops up.

You have a PM.
A-Eon A1X1000
User avatar
mechanic
 
Posts: 481
Joined: Sat Jun 25, 2011 10:22 pm

Re: Help needed setting up Cubic IDE to work with OS4.x SDK

Postby Rigo » Thu Sep 06, 2012 8:55 pm

Not quite. The AmigaOS4 SDK sets up an "SDK:" assign once it is installed, and that is what CodeBench looks for, and uses. As a result, CodeBench and the SDK can be installed anywhere you want.

Simon
User avatar
Rigo
AmigaOS Core Developer
AmigaOS Core Developer
 
Posts: 324
Joined: Mon Jan 17, 2011 10:42 pm

Re: Help needed setting up Cubic IDE to work with OS4.x SDK

Postby mechanic » Thu Sep 06, 2012 9:47 pm

oops :oops:

Your right of course. I just like keeping related stuff on the same partition.
A-Eon A1X1000
User avatar
mechanic
 
Posts: 481
Joined: Sat Jun 25, 2011 10:22 pm

Re: Help needed setting up Cubic IDE to work with OS4.x SDK

Postby AmigaDave » Fri Sep 07, 2012 5:05 am

What is Code Bench?

I am asking how to set up Cubic IDE (aka GoldED Studio) to use with the OS4.x SDK.

I found an article written some time ago with step-by-step instructions, but it is not accurate and I am unable to follow the steps without running into trouble with the installation program for Cubic IDE.

I might be able to figure out how to set it all up manually, using the information contained in that article that I found a link to on Amigans.net.
Proud owner of 10+ Commodore Amiga 680x0 computers
First Contact AmigaOne X1000 Dual Core 1.8GHz PA6T w/OS4.1FE
Dual 2.7GHz G5 PowerMac w/MorphOS3.7
1.5GHz G4 PMac MDD w/MorphOS3.7
1.5GHz G4 MacMini w/MorphOS3.7
17" 1.67GHz G4 PBooks w/MorphOS3.7
Efika 5200b w/MorphOS3.7
FPGA Arcade Replay w/AmigaOS3.x
AmigaDave
 
Posts: 145
Joined: Wed Jan 04, 2012 4:31 am
Location: Lake Shastina, California, USA

Re: Help needed setting up Cubic IDE to work with OS4.x SDK

Postby trixie » Fri Sep 07, 2012 8:11 am

@AmigaDave
What is Code Bench?

CodeBench is a development environment, much more user-friendly than Cubic. You might give it a try. CodeBench uses an installed SDK from where it has been installed, without any additional setup. I've been using it myself, it's free and it's quite good:
http://www.codebench.co.uk/

Cubic IDE does not appear to know that there is any C/C++ compiler installed on my X1000

Cubic predates the OS4 SDK. It installs its own set of compilers (the C/C++ Add-On) in a path named "devkits:". Cubic will not offer you a C/C++ menu choice unless you have the add-on installed and the devkits: assign present in the system. So first check that you have installed the add-on, and if not, download it from here and install:
http://www.softwareandcircuits.com/division/amiga/products/cubic/sdk.html

Then I could possibly be of more help.
Smoke me a kipper, I'll be back for breakfast!
SAM440ep-flex @ 667MHz / 1GB RAM / Radeon 9250 / AmigaOS 4.1 Final Edition
User avatar
trixie
 
Posts: 351
Joined: Thu Jun 30, 2011 3:54 pm
Location: Czech Republic

Re: Help needed setting up Cubic IDE to work with OS4.x SDK

Postby AmigaDave » Sat Sep 08, 2012 12:43 am

trixie wrote:@AmigaDave

Cubic predates the OS4 SDK. It installs its own set of compilers (the C/C++ Add-On) in a path named "devkits:". Cubic will not offer you a C/C++ menu choice unless you have the add-on installed and the devkits: assign present in the system. So first check that you have installed the add-on, and if not, download it from here and install:
http://www.softwareandcircuits.com/division/amiga/products/cubic/sdk.html

Then I could possibly be of more help.


Cubic IDE (at least the version I have of it) will not install the C/C++ add-on, when run on any AmigaOne computer. When it gets to that point in the installation program, it spits out an error message that is long, so I can't remember it word-for-word. In effect, the error message states that because Hyperion does not allow the Cubic IDE installer to download and install their OS4.x SDK, the Cubic IDE installer cannot continue the installation of any C/C++ add-on, as well as not being able to install the OS4.x SDK. It then skips over the installation of the C/C++ add-on and installs all the other parts and add-ons for Cubic IDE.

I guess I will check out the Code Bench IDE, but after spending so much money on the Cubic IDE, and having it replaced by a better IDE in the MorphOS SDK, I was hoping to get my "money's worth" from the Cubic IDE, by using it on OS4.x.

If none of the OS4.x programmers is using Cubic IDE, then I can't expect any help on how to set it up with the OS4.x SDK, but thanks for trying.
Proud owner of 10+ Commodore Amiga 680x0 computers
First Contact AmigaOne X1000 Dual Core 1.8GHz PA6T w/OS4.1FE
Dual 2.7GHz G5 PowerMac w/MorphOS3.7
1.5GHz G4 PMac MDD w/MorphOS3.7
1.5GHz G4 MacMini w/MorphOS3.7
17" 1.67GHz G4 PBooks w/MorphOS3.7
Efika 5200b w/MorphOS3.7
FPGA Arcade Replay w/AmigaOS3.x
AmigaDave
 
Posts: 145
Joined: Wed Jan 04, 2012 4:31 am
Location: Lake Shastina, California, USA

Re: Help needed setting up Cubic IDE to work with OS4.x SDK

Postby LyleHaze » Sat Sep 08, 2012 1:14 am

From Wikipedia:http://en.wikipedia.org/wiki/Cubic_IDE
Cubic IDE is a modular development environment (IDE) for AmigaOS (versions 3.5 and 3.9 only) and MorphOS.


Wikipedia says the "Official Website link" for CubicIDE is http://www.softwareandcircuits.com/division/amiga/products/cubic/index.html

I hope they will be able to help you out!
User avatar
LyleHaze
AmigaOS Core Developer
AmigaOS Core Developer
 
Posts: 508
Joined: Sat Jun 18, 2011 5:06 pm
Location: Georgia, USA, just North of the Florida border

Re: Help needed setting up Cubic IDE to work with OS4.x SDK

Postby AmigaDave » Sat Sep 08, 2012 8:07 am

LyleHaze wrote:From Wikipedia:http://en.wikipedia.org/wiki/Cubic_IDE
Cubic IDE is a modular development environment (IDE) for AmigaOS (versions 3.5 and 3.9 only) and MorphOS.


Wikipedia says the "Official Website link" for CubicIDE is http://www.softwareandcircuits.com/division/amiga/products/cubic/index.html

I hope they will be able to help you out!


Wiki's are not the most accurate resources for information. The CubicIDE's installation program has a list of platforms to install onto and one of the choices in this list is AmigaOne. Without running UAE, you can't run AmigaOS versions 3.5 and 3.9 only, or MorphOS, as quoted from that Wiki above, on any AmigaOne computer.

If no one here is using CubicIDE, I will find the information I need somewhere else. Since there is no "Official" OS4.x IDE, I thought that there might be a few OS4.x programmers who are using CubicIDE, seeing how popular GoldED was in the past.

I am sure I will find someone who has experience installing and using CubicIDE on an OS4.x computer. Programmers are probably too busy coding to check this forum very often, so it might take some days or weeks before I get the information I am seeking from someone on this forum site.

It would be better for me to use IRC to try to find someone using CubicIDE on OS4.x.

Edit: I think I found my problem in installing CubicIDE on OS4.x. I need the older OS4.x SDK 51.22 to install CubicIDE, then I can use the guide on Amigans.net to complete the configuration for CubicIDE to use the newest version of the OS4.x SDK and gcc. I hope that I can still find the older version of the OS4.x SDK to download, or if it is not available for download any longer, I hope that someone still has it on their hard drive and can email it to me. My email address is amigadave at earthlink dot net.
Proud owner of 10+ Commodore Amiga 680x0 computers
First Contact AmigaOne X1000 Dual Core 1.8GHz PA6T w/OS4.1FE
Dual 2.7GHz G5 PowerMac w/MorphOS3.7
1.5GHz G4 PMac MDD w/MorphOS3.7
1.5GHz G4 MacMini w/MorphOS3.7
17" 1.67GHz G4 PBooks w/MorphOS3.7
Efika 5200b w/MorphOS3.7
FPGA Arcade Replay w/AmigaOS3.x
AmigaDave
 
Posts: 145
Joined: Wed Jan 04, 2012 4:31 am
Location: Lake Shastina, California, USA

Re: Help needed setting up Cubic IDE to work with OS4.x SDK

Postby AmigaDave » Sat Sep 08, 2012 8:41 am

I have found the problem and solution on how to get Cubic IDE setup with OS4.x SDK, but I need the older version of the OS4.x SDK with the number 51.22, but it is not available for download any longer on the Hyperion website.

Do any of you reading this forum have this old version of the SDK that you could email to me. If Yes, please send to amigadave at earthlink dot net.

Thanks
Proud owner of 10+ Commodore Amiga 680x0 computers
First Contact AmigaOne X1000 Dual Core 1.8GHz PA6T w/OS4.1FE
Dual 2.7GHz G5 PowerMac w/MorphOS3.7
1.5GHz G4 PMac MDD w/MorphOS3.7
1.5GHz G4 MacMini w/MorphOS3.7
17" 1.67GHz G4 PBooks w/MorphOS3.7
Efika 5200b w/MorphOS3.7
FPGA Arcade Replay w/AmigaOS3.x
AmigaDave
 
Posts: 145
Joined: Wed Jan 04, 2012 4:31 am
Location: Lake Shastina, California, USA

Next

Return to SDK Support

Who is online

Users browsing this forum: No registered users and 3 guests