Page 1 of 1

(Solved) AmiDevCPP as.exe and "mppc" support.

PostPosted: Wed Sep 23, 2015 3:33 pm
by AmiDARK
Hello.

With the previous SDK 53.20 I was able to compile projects under AmiDevCPP.
But I installed 53.30, I now get an error concerning AS saying that paramater -mppc is unknown.
Can someone help me with this ?

Regards,
AmiDARK

Re: AmiDevCPP as.exe and "mppc" support.

PostPosted: Wed Sep 23, 2015 6:08 pm
by salass00
AmiDARK wrote:Hello.

With the previous SDK 53.20 I was able to compile projects under AmiDevCPP.
But I installed 53.30, I now get an error concerning AS saying that paramater -mppc is unknown.
Can someone help me with this ?

Regards,
AmiDARK


I don't see what this has to do with the SDK since the AmigaOS 4.x SDK doesn't include any cross-compilers...

Your problem seems to be with your cross-compiler binutils install rather. I assume you are invoking "as" with the correct cross prefix ("ppc-amigaos-as" rather than just plain "as")?

I'm also not sure what the -mppc option is supposed to be doing as ppc code should be the default for ppc-amigaos-as...

Re: AmiDevCPP as.exe and "mppc" support.

PostPosted: Wed Sep 23, 2015 7:53 pm
by Daytona675x
I'm also not sure what the -mppc option is supposed to be doing as ppc code should be the default for ppc-amigaos-as...

Finetuning for concrete CPUs.
https://sourceware.org/binutils/docs/as/PowerPC_002dOpts.html
Anyway, no idea why an SDK update would break / influence the cross-compiler setup.

Re: (Solved) AmiDevCPP as.exe and "mppc" support.

PostPosted: Fri Sep 25, 2015 10:15 am
by AmiDARK
In fact a folder in my AmiDevCPP AmigaOS4 SDK location was missing.
The AS.EXE that should be used for Amiga compilation was no more.
Reinstalling AmiDevCPP 0.98 fixed this problem fixing the issue.