Missing function or incorrect function reference

Have a question about our Software Developer Kit? Ask them here.

Missing function or incorrect function reference

Postby xenic » Sun Dec 03, 2017 8:53 pm

The notes for WA_PointerDelay in SDK:Include/include_h/intuition/intuition.h reference the function: "NewSetPointer()" which I can't find anywhere in the SDK. The notes need to be corrected to reference the correct function or the NewSetPointer() function needs to be added to the Intuition autodoc. Can someone please acknowledge the problem and correct it?
AmigaOne X1000 with 2GB memory - OS4.1 FE
xenic
 
Posts: 1145
Joined: Sun Jun 19, 2011 1:06 am

Re: Missing function or incorrect function reference

Postby tboeckel » Mon Dec 04, 2017 11:58 am

I suppose the SetWindowPointer() function initially was named NewSetPointer() to be distinguishable from the old SetPointer() function. Most probably that old function name was left in the Autodoc even after the name change.

I just fixed that typo.
User avatar
tboeckel
AmigaOS Core Developer
AmigaOS Core Developer
 
Posts: 68
Joined: Mon Jun 20, 2011 9:56 am

Re: Missing function or incorrect function reference

Postby xenic » Tue Dec 05, 2017 3:22 am

tboeckel wrote:I suppose the SetWindowPointer() function initially was named NewSetPointer() to be distinguishable from the old SetPointer() function. Most probably that old function name was left in the Autodoc even after the name change.

I just fixed that typo.


Thanks.
AmigaOne X1000 with 2GB memory - OS4.1 FE
xenic
 
Posts: 1145
Joined: Sun Jun 19, 2011 1:06 am


Return to SDK Support

Who is online

Users browsing this forum: No registered users and 1 guest