Forum does not remember my login

This is the place to ask if you have any issues with our forum system. These include questions about your account, PM's, login trouble, etc.

Forum does not remember my login

Postby abalaban » Tue Dec 04, 2012 3:30 pm

Using the URL support.amigaos.net the forum does not remember my login details, while using forum.hyperion-entertainment.biz it does. I'm currently using Chrome under Win7/64bits. It may also be the reason why each time I'm trying to visit the forum from Timberwolf I have to login again (even when I specified the "remember me" option).
Chrome does seem to block any cookie when using support.amigaos.net
AmigaOne X1000 running AOS 4 beta
AmigaOne XE/G4
Amiga 1200/PPC 603e + BVision PPC
User avatar
abalaban
Beta Tester
Beta Tester
 
Posts: 456
Joined: Mon Dec 20, 2010 3:09 pm
Location: France

Re: Forum does not remember my login

Postby ssolie » Tue Dec 04, 2012 6:36 pm

The cookie won't work if you enter the site from support.amigaos.net. It only works if you use forum.hyperion-entertainment.biz. I haven't had time to look into how to fix it to work with both yet.
AmigaOS Development Team Lead
Be authentic. Get AmigaOS.
User avatar
ssolie
AmigaOS Core Developer
AmigaOS Core Developer
 
Posts: 994
Joined: Mon Dec 20, 2010 9:51 pm
Location: Canada

Re: Forum does not remember my login

Postby abalaban » Tue Dec 04, 2012 6:44 pm

Ok at least it's a know issue. As support.amigaos.net is the URL used in the notification messages sent by the forum it would be good to have this one working while looking for a solution to have both working at the same time?
A workaround can be to have one just redirect to the second URL, using HTTP redirect or anything else?
AmigaOne X1000 running AOS 4 beta
AmigaOne XE/G4
Amiga 1200/PPC 603e + BVision PPC
User avatar
abalaban
Beta Tester
Beta Tester
 
Posts: 456
Joined: Mon Dec 20, 2010 3:09 pm
Location: France

Re: Forum does not remember my login

Postby Phantom » Wed Dec 05, 2012 2:02 am

Yes I had the same problem and switched to forum.hyperion-entertainment.biz too.
To Be A True Adventurer, You Ought To Play Real Text Adventures
User avatar
Phantom
 
Posts: 73
Joined: Sun Jun 19, 2011 3:15 pm
Location: Colossal Cave, Valaii

Re: Forum does not remember my login

Postby ssolie » Mon Aug 26, 2013 5:40 pm

I think I finally fixed this problem.

Instead of support.amigaos.net being an alias I added an Apache rewrite rule to change that to forum.hyperion-entertainment.biz. The phpBB software we use for the forums does not allow multiple names for the same site and likely never will so this is probably the best workaround.
AmigaOS Development Team Lead
Be authentic. Get AmigaOS.
User avatar
ssolie
AmigaOS Core Developer
AmigaOS Core Developer
 
Posts: 994
Joined: Mon Dec 20, 2010 9:51 pm
Location: Canada


Return to Forum Questions

Who is online

Users browsing this forum: Majestic-12 [Bot] and 1 guest