CFE bug fixes

AmigaOne X1000 platform specific issues.

CFE bug fixes

Postby vox » Wed May 10, 2017 7:47 am

tonyw wrote:The difference is that the X1000 uses CFE, the X5000 uses U-Boot. It's the BIOS that initialises the ports and selects one for the keyboard, one for the mouse.

I guess that U-Boot is a bit smarter and can tell what's a mouse, what's a keyboard and what ain't.


Its a bit more then that.

Its an unfixed bug that it can initialize only one USB port without halt.
Sorry, I cannot discribe it no other way.

Since SD Card could get corrupted (e.g. 2GB and larger fat16 partitions) - another CFE bug
it would be wise to fix it and allow us at least to have also USB ready on boot (one more port please)

That plus a bit more friendly cmd line editing and fixing nasty crash bug if amigaboot.of fails would be nice.
A bit faster init if possible since CFE is slow champion there.
User avatar
vox
 
Posts: 145
Joined: Thu Jun 23, 2011 3:19 pm
Location: Belgrade Country:Serbia

Re: CFE bug fixes

Postby mechanic » Tue May 16, 2017 4:09 pm

Sounds weird, but I prefer CFE.

Since CFE can only be controlled by a keyboard only one USB port is required. I use a Logitec wireless Kbd & mouse and have no problems.

The easiest way to screw up the CFcard is to delete a file. It messes with the pointers on the card. If you wish to delete a file copy all the files you want someplace then format the CFcard and copy the wanted files back to the card. You can use FAT16, FAT32, or ext2 file systems.

If you wish to keep amigaboot.of on the CFcard then also keep it on the first partition of your Amiga HD and add another Menu boot line to CFE so if one fails the other is there as a backup.

Have a nice day. :)
A-Eon A1X1000
User avatar
mechanic
 
Posts: 478
Joined: Sat Jun 25, 2011 10:22 pm

Re: CFE bug fixes

Postby vox » Sun Jun 04, 2017 12:22 am

mechanic wrote:Sounds weird, but I prefer CFE.

Since CFE can only be controlled by a keyboard only one USB port is required. I use a Logitec wireless Kbd & mouse and have no problems.
The easiest way to screw up the CFcard is to delete a file. It messes with the pointers on the card. If you wish to delete a file copy all the files you want someplace then format the CFcard and copy the wanted files back to the card. You can use FAT16, FAT32, or ext2 file systems.
If you wish to keep amigaboot.of on the CFcard then also keep it on the first partition of your Amiga HD and add another Menu boot line to CFE so if one fails the other is there as a backup.
Have a nice day. :)


So you just confirm CFE needs an update :-) Thanks!

Exact Logitech model?
Thanks for the tip, but yet it shows how poorly CF card is supported by CFE and AmigaOS when one file change
screws it all. And I had high hopes of easy intermmediate 4GB drive for file exchange between Linux and AOS.

How do you cope with no video signal properly init?
User avatar
vox
 
Posts: 145
Joined: Thu Jun 23, 2011 3:19 pm
Location: Belgrade Country:Serbia


Return to Platform: AmigaOne X1000

Who is online

Users browsing this forum: No registered users and 2 guests