ssd mounting

AmigaOne X1000 platform specific issues.

ssd mounting

Postby ggw » Tue Dec 20, 2016 6:33 am

I would like 2 suggestions. 1) brands of SSD to avoid; 2) are there mounting issues?

I've never owned an SSD I had access to.

1) prices vary from 60$ to 120$ for SSDs.

2) they all seem smaller than the WD 1TB dead disk in the X1000. Do I need to buy a bracket?
George Wyche
ggw
 
Posts: 106
Joined: Wed May 02, 2012 5:19 am
Location: Austin, TX

Re: ssd mounting

Postby tonyw » Tue Dec 20, 2016 1:55 pm

SSDs are generally 2.5" mounting (same size as a laptop HD). You can get an adapter plate for a couple of dollars that will make it fit a "normal" 3.5" HD drive slot, or you can make something up out of scrap aluminium sheet.

I am currently testing as many as I can get my hands on (and afford). I have not found any that don't perform flawlessly. All so far tested support Trim and all (so far) have 4096-byte sectors that are addressable as 512-bytes. The big ones (>480 GB) are expensive and probably not worth the money.

All of them seem to claim the same top speed (500-550 MB/sec), but that is of course only for short bursts. Long transfer speeds depend more on the file system and device driver.

If I were to recommend a brand, I would suggest you choose from one of the big names like Corsair, Crucial, Kingston, SanDisk, etc. I have read that some Samsung drives have had issues in the past, but that may not be true of today's offerings, of course. I have only one Samsung drive but it has no problems.
cheers
tony
User avatar
tonyw
AmigaOS Core Developer
AmigaOS Core Developer
 
Posts: 1248
Joined: Wed Mar 09, 2011 2:36 pm
Location: Sydney, Australia

Re: ssd mounting

Postby LyleHaze » Wed Dec 21, 2016 4:11 am

If you have the Official X1000 case, an SSD drive can be screwed directly to the hard drive tray. It is NOT through the vibration rubbers that regular drives use, but there's not much need for those on an SSD anyway.

I have some type of SanDisk, details not remembered, it has worked without issue.

The partition that holds my projects (and SDK) is on the SSD, but out of caution my backup script also saves a copy off to a PATA drive as well. Having two copies of each backup is quite comforting, and being able to make backups easily has really helped me to keep backups fresh. Considering the low cost of storage nowadays there's no reason not to make LOTS of backups.
User avatar
LyleHaze
AmigaOS Core Developer
AmigaOS Core Developer
 
Posts: 508
Joined: Sat Jun 18, 2011 5:06 pm
Location: Georgia, USA, just North of the Florida border

Re: ssd mounting

Postby ggw » Wed Dec 21, 2016 7:17 am

Hi Lyle,

The PATA's controller is necessarily different from the sata2 controller (other than sharing the motherboard resources and connectivity to a bus).
Is that fair to say?

I'm grumpy about it because the replacement 1TB which has been running unused in the X1000 (My X1000 is typically on for 4 hours / day.) refused to boot up about 4 times in a row, stopping in CFE with words to the effect that no boot could be found. I went away in disgust, but returned at the end of the 4 hours after removing the side panel staring that the cables, babying them, nothing loose all looked normal, back together and.... all was normal... what was *my* problem it seemed to say. No more problems since then (last weekend).

What I really want for a backup is not that much, so a PATA drive should be plenty. How to keep it organized and how to use it specifically WHEN the #2 1TB (also) dies is not that clear (as when #1 TB did die and my backups did not just organize themselves into my salvation).

As my original post said, I don't know anything about SSDs when it comes to "who is a name brand", but your list is sufficient to pick from. Thanks in particular about the 2.5 mounting into the X1000 straight away. I'll do that!.

George
George Wyche
ggw
 
Posts: 106
Joined: Wed May 02, 2012 5:19 am
Location: Austin, TX

Re: ssd mounting

Postby LyleHaze » Wed Dec 21, 2016 1:58 pm

Sounds like you've had some bad luck.
I don't know much on the difference between SATA and PATA. I believe the command set is similar but the interface has gone serial.

While some may disagree, I have always believed that IF you have good power, it's better for a computer to stay on 24/7 than to power it up and down with each use.
This reduces the thermal changes, as well as reducing the power up inrush. Of course it does add wear to the fans.

The list of brands to choose from was from Tony. I have only one SSD, it's a SanDisk. I expect to be getting another soon for a different computer.

I have never tried booting to a PATA on my X1000. When I was writing my backup script I wanted a completely separate drive for the second backup location, so I grabbed an old PATA from the pile of old parts and added it. One day I might use a NAS for the purpose.

Good Luck,
Lyle
User avatar
LyleHaze
AmigaOS Core Developer
AmigaOS Core Developer
 
Posts: 508
Joined: Sat Jun 18, 2011 5:06 pm
Location: Georgia, USA, just North of the Florida border

Re: ssd mounting

Postby Raziel » Wed Dec 21, 2016 7:05 pm

ggw wrote:Hi Lyle,

The PATA's controller is necessarily different from the sata2 controller (other than sharing the motherboard resources and connectivity to a bus).
Is that fair to say?

I'm grumpy about it because the replacement 1TB which has been running unused in the X1000 (My X1000 is typically on for 4 hours / day.) refused to boot up about 4 times in a row, stopping in CFE with words to the effect that no boot could be found. I went away in disgust, but returned at the end of the 4 hours after removing the side panel staring that the cables, babying them, nothing loose all looked normal, back together and.... all was normal... what was *my* problem it seemed to say. No more problems since then (last weekend).

What I really want for a backup is not that much, so a PATA drive should be plenty. How to keep it organized and how to use it specifically WHEN the #2 1TB (also) dies is not that clear (as when #1 TB did die and my backups did not just organize themselves into my salvation).

As my original post said, I don't know anything about SSDs when it comes to "who is a name brand", but your list is sufficient to pick from. Thanks in particular about the 2.5 mounting into the X1000 straight away. I'll do that!.

George

Ah, the infamous "not enough memory" error when booting off of SSD's...that specific error bit me too thrice upto now, very randomly and very seldom here.
Not sure what the cause is, but it seems the SSD is not known/initialized to the system when cfe wants to access it, maybe a power cord problem, don't know.
Normally doing a system shut down, leaving it be for five minutes and powering it up again will solve the problem (at least for me).

wrt your brands question i can only tell you the brand and drive i got in my x1000

It's a Samsung SSD 850 EVO with 500GB, haven't had any need for more
The 1TB version should work as well though

Good luck
If slaughterhouses had glass walls, everyone would be a vegetarian. ~ Sir Paul McCartney
-
Did everything just taste purple for a second? ~ Philip J. Fry
-
Ain't got no cash, ain't got no style, ladies vomit when I smile. ~ Dr. John Zoidberg
User avatar
Raziel
 
Posts: 767
Joined: Sat Jun 18, 2011 5:00 pm
Location: A haunted Castle somewhere in the Bavarian Mountains

Re: ssd mounting

Postby tonyw » Thu Dec 22, 2016 12:27 am

Hmmm, I've never had a failure to boot (from a cold boot), but sometimes the X1000 won't perform a warm boot - the device driver locks up saying the SSD is not ready.

I think the SSD is doing a garbage collection and is busy, but it has only started doing it recently. Maybe it's because the "disk" is becoming more full and wear-levelling takes more time.
cheers
tony
User avatar
tonyw
AmigaOS Core Developer
AmigaOS Core Developer
 
Posts: 1248
Joined: Wed Mar 09, 2011 2:36 pm
Location: Sydney, Australia

Re: ssd mounting

Postby AlfredOne » Thu Dec 22, 2016 11:40 pm

ggw wrote:I would like 2 suggestions. 1) brands of SSD to avoid; 2) are there mounting issues?

I've never owned an SSD I had access to.

1) prices vary from 60$ to 120$ for SSDs.

2) they all seem smaller than the WD 1TB dead disk in the X1000. Do I need to buy a bracket?


I'm using a Crucial MX300. I read some benchmarks and what convinced to buy this is that performances does not degrade over time as with other ones.
Time will tell if it is true.
What I can say is that AmigaOS4 (beta) boot time decreased from 42 seconds to 17 seconds. Consider that if we could use a SATA3 controller, it would be twice more fast.
Amiga500 Kickstart1.3
AmigaONE XE G4 833MHz - 2GB RAM - Radeon9200 256MB
AmigaONE X1000 - 2GB RAM - Radeon R9-280X 3GB + Radeon HIS4670 1GB DDR3 - AmigaOS4.1
My site: http://project4a.webs.com
User avatar
AlfredOne
Beta Tester
Beta Tester
 
Posts: 112
Joined: Thu Dec 23, 2010 12:45 am
Location: Rome , Italy

Re: ssd mounting

Postby ssolie » Wed Jan 04, 2017 12:13 am

AlfredOne wrote:I'm using a Crucial MX300. I read some benchmarks and what convinced to buy this is that performances does not degrade over time as with other ones.
Time will tell if it is true...

All flash chips degrade over time. There is no way around that fact. What makes the difference is the software in the controller. A good controller will spread the wear out over all the flash chips and attempt to avoid erase/write cycles as much as possible. It is all up to the firmware.
AmigaOS Development Team Lead
Be authentic. Get AmigaOS.
User avatar
ssolie
AmigaOS Core Developer
AmigaOS Core Developer
 
Posts: 1000
Joined: Mon Dec 20, 2010 9:51 pm
Location: Canada


Return to Platform: AmigaOne X1000

Who is online

Users browsing this forum: No registered users and 1 guest

cron