Kernel 4.14

AmigaOne X1000 platform specific issues related to Linux only.

Kernel 4.14

Postby xeno74 » Thu Sep 07, 2017 6:29 pm

Hi Everyone,

The merge window is open for the future kernel 4.14. A lot of source code has been added for the kernel 4.14 to the Linux git.

Here is the first alpha for the X5000 and X1000.

New:


Download: vmlinux-4.14-alpha1-AmigaOne_X1000_X5000.tar.gz

Image

Please test it.

Thanks,
Christian
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.
User avatar
xeno74
 
Posts: 2939
Joined: Fri Mar 23, 2012 8:58 am

Re: Kernel 4.14

Postby xeno74 » Sat Sep 09, 2017 1:20 pm

Hi All,

Here is the second alpha with the first PowerPC updates for the X5000 and X1000.

New:


Download: vmlinux-4.14-alpha2-AmigaOne_X1000_X5000.tar.gz

Image

Please test it.

Thanks,
Christian
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.
User avatar
xeno74
 
Posts: 2939
Joined: Fri Mar 23, 2012 8:58 am

Re: Kernel 4.14

Postby xeno74 » Tue Sep 12, 2017 11:36 am

Hi All,

I released the alpha3 for the X5000 and X1000 today. The hardware 3D acceleration works again on the AmigaOne X5000 because I have removed the problematic instruction emulation patch.

New:


Download: vmlinux-4.14-alpha3-AmigaOne_X1000_X5000.tar.gz

Screenshot of ubuntu MATE 16.04.3 LTS PowerPC with the alpha3 of kernel 4.14 with access to my OSX server:

Image

Cheers,
Christian
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.
User avatar
xeno74
 
Posts: 2939
Joined: Fri Mar 23, 2012 8:58 am

Re: Kernel 4.14

Postby xeno74 » Wed Sep 13, 2017 11:48 pm

Hi All,

Paul Mackerras has fixed the problem with the emulation of the dcbz instruction in the alignment interrupt handler. Therefore the hardware 3D acceleration works again on the AmigaOne X5000.

I compiled the alpha4 with his patch for the AmigaOne X5000 today. Additionally I compiled the alpha4 for the X1000. The X1000 isn't affected by this issue so it doesn't need this patch. Both kernels are included in the package below.

Further news:


Download: vmlinux-4.14-alpha4-AmigaOne_X1000_X5000.tar.gz

Image

Please test it.

Thanks,
Christian
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.
User avatar
xeno74
 
Posts: 2939
Joined: Fri Mar 23, 2012 8:58 am

Re: Kernel 4.14

Postby xeno74 » Sat Sep 16, 2017 3:36 pm

Hi All,

I compiled the alpha5 yesterday.

It works with ubuntu MATE 16.04.3 LTS and with the MATE PowerPC Remix 2017. Unfortunately lightdm doesn't work anymore on Debian Sid.

Error messages:

Code: Select all
[+0.09s] DEBUG: Loading configuration from /usr/share/lightdm/lightdm.conf.d/01_debian.conf
[+0.09s] DEBUG: Loading configuration from /etc/lightdm/lightdm.conf
[+0.09s] DEBUG: Using D-Bus name org.freedesktop.DisplayManager
[+0.33s] DEBUG: Registered seat module xlocal
[+0.33s] DEBUG: Registered seat module xremote
[+0.33s] DEBUG: Registered seat module unity
[+0.33s] DEBUG: Registered seat module surfaceflinger
[+0.33s] DEBUG: Adding default seat
[+0.33s] DEBUG: Seat: Starting
[+0.33s] DEBUG: Seat: Creating greeter session
[+0.59s] DEBUG: Seat: Setting XDG_SEAT=seat0
[+0.59s] DEBUG: Seat: Creating display server of type x
[+0.59s] DEBUG: Seat: Starting local X display
[+0.59s] DEBUG: Could not run plymouth --ping: Failed to execute child process “plymouth” (No such file or directory)
[+0.59s] DEBUG: Using VT 7
[+0.59s] DEBUG: DisplayServer x-0: Logging to /var/log/lightdm/x-0.log
[+0.59s] DEBUG: DisplayServer x-0: Writing X server authority to /var/run/lightdm/root/:0
[+0.59s] DEBUG: DisplayServer x-0: Launching X Server
[+0.59s] DEBUG: Launching process 3781: /usr/bin/Xorg :0 -auth /var/run/lightdm/root/:0 -nolisten tcp vt7 -novtswitch
[+0.59s] DEBUG: DisplayServer x-0: Waiting for ready signal from X server :0
[+0.59s] DEBUG: Acquired bus name org.freedesktop.DisplayManager
[+0.59s] DEBUG: Registering seat with bus path /org/freedesktop/DisplayManager/Seat0
[+5.71s] DEBUG: Got signal 10 from process 3781
[+5.71s] DEBUG: DisplayServer x-0: Got signal from X server :0
[+5.71s] DEBUG: DisplayServer x-0: Connecting to XServer :0
[+5.71s] DEBUG: Seat: Display server ready, starting session authentication
[+5.71s] DEBUG: Session: Setting XDG_VTNR=7
[+5.71s] DEBUG: Session pid=3918: Started with service 'lightdm-greeter', username 'lightdm'
[+6.35s] DEBUG: Session pid=3918: Authentication complete with return value 0: Success
[+6.35s] DEBUG: Seat: Session authenticated, running command
[+6.35s] DEBUG: Session pid=3918: Setting XDG_VTNR=7
[+6.35s] DEBUG: Session pid=3918: Running command /usr/sbin/lightdm-kde-greeter
[+6.36s] DEBUG: Session pid=3918: Logging to /var/log/lightdm/x-0-greeter.log
[+6.88s] DEBUG: Activating VT 7
[+6.88s] WARNING: Error using VT_WAITACTIVE 7 on /dev/console: No such device or address
[+15.16s] DEBUG: Session pid=3918: Greeter connected version=1.8.5
[+78.29s] DEBUG: Got signal 15 from process 4397
[+78.29s] DEBUG: Caught Terminated signal, shutting down
[+78.29s] DEBUG: Stopping display manager
[+78.29s] DEBUG: Seat: Stopping
[+78.29s] DEBUG: Seat: Stopping display server
[+78.29s] DEBUG: Sending signal 15 to process 3781
[+78.29s] DEBUG: Seat: Stopping session
[+78.29s] DEBUG: Session pid=3918: Sending SIGTERM
[+78.35s] DEBUG: Session pid=3918: Greeter closed communication channel
[+78.35s] DEBUG: Session pid=3918: Exited with return value 15
[+78.35s] DEBUG: Seat: Session stopped


Lightdm works with the alpha4 without any problems.

Maybe we have a new bug somewhere in the patches from Sep 13, 11:48AM till 15 Sep, 1:12PM.

Additionally the PCSX emulator doesn't work anymore with the new alpha5. If I start a game with the XVideo driver then I get the following error messages:

Code: Select all
The program 'pcsx' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadAccess (attempt to access private resource denied)'.
  (Details: serial 49 error_code 10 request_code 130 minor_code 1)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)


I don't have these problems with the alpha4.

Please test it. Maybe some other X apps don't work anymore.

Download: vmlinux-4.14-alpha5-AmigaOne_X1000_X5000.tar.gz

This bug affects the X1000 and the X5000.

Thanks,
Christian
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.
User avatar
xeno74
 
Posts: 2939
Joined: Fri Mar 23, 2012 8:58 am

Re: Kernel 4.14

Postby xeno74 » Sat Sep 16, 2017 7:24 pm

Hi All,

I was able to remove the fbdev updates. Maybe these patches are the problem.

Code: Select all
git revert 503f04530fec97f93673ae9048b5312cc4455cfe -m 1


Code: Select all
[master 0736a7d] Revert "Merge tag 'fbdev-v4.14' of git://github.com/bzolnier/linux"


After that I compiled the alpha6 without the fbdev updates.

Unfortunately, it didn't solve the problem.

Rgds,
Christian
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.
User avatar
xeno74
 
Posts: 2939
Joined: Fri Mar 23, 2012 8:58 am

Re: Kernel 4.14

Postby xeno74 » Sat Sep 16, 2017 9:09 pm

I updated lightdm on Debian Sid but without any success.

Error messages:

Code: Select all
[+1.93s] DEBUG: Using VT 7
[+1.93s] DEBUG: Seat seat0: Starting local X display on VT 7
[+1.93s] DEBUG: DisplayServer x-0: Logging to /var/log/lightdm/x-0.log
[+1.93s] DEBUG: DisplayServer x-0: Writing X server authority to /var/run/lightdm/root/:0
[+1.93s] DEBUG: DisplayServer x-0: Launching X Server
[+1.93s] DEBUG: Launching process 3702: /usr/bin/Xorg :0 -seat seat0 -auth /var/run/lightdm/root/:0 -nolisten tcp vt7 -novtswitch
[+1.93s] DEBUG: DisplayServer x-0: Waiting for ready signal from X server :0
[+1.93s] DEBUG: Acquired bus name org.freedesktop.DisplayManager
[+1.93s] DEBUG: Registering seat with bus path /org/freedesktop/DisplayManager/Seat0
[+2.55s] DEBUG: Loading users from org.freedesktop.Accounts
[+2.55s] DEBUG: User /org/freedesktop/Accounts/User1000 added
[+6.17s] DEBUG: Got signal 10 from process 3702
[+6.17s] DEBUG: DisplayServer x-0: Got signal from X server :0
[+6.17s] DEBUG: DisplayServer x-0: Connecting to XServer :0
[+6.17s] DEBUG: Seat seat0: Display server ready, starting session authentication
[+6.17s] DEBUG: Session pid=3863: Started with service 'lightdm-greeter', username 'lightdm'
[+6.40s] DEBUG: Session pid=3863: Authentication complete with return value 0: Success
[+6.40s] DEBUG: Seat seat0: Session authenticated, running command
[+6.40s] DEBUG: Session pid=3863: Running command /usr/sbin/lightdm-kde-greeter
[+6.40s] DEBUG: Creating shared data directory /var/lib/lightdm/data/lightdm
[+6.40s] DEBUG: Session pid=3863: Logging to /var/log/lightdm/seat0-greeter.log
[+6.62s] DEBUG: Activating VT 7
[+6.62s] WARNING: Error using VT_WAITACTIVE 7 on /dev/tty0: No such device or address
[+6.62s] DEBUG: Activating ConsoleKit session d4f561b636716de50fe4740051265e84-1505587303.5374-678774364
[+6.63s] WARNING: Error activating ConsoleKit session: GDBus.Error:org.freedesktop.DBus.GLib.UnmappedError.CkVtMonitorError.Code0: Session is already active
[+14.25s] DEBUG: Greeter connected version=1.8.5 resettable=false
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.
User avatar
xeno74
 
Posts: 2939
Joined: Fri Mar 23, 2012 8:58 am

Re: Kernel 4.14

Postby xeno74 » Tue Sep 19, 2017 9:38 am

Hi All,

I updated Mesa to version 17.2.1/LLVM 5.0.0 on Debian Sid yesterday. Unfortunately Lightdm doesn't work again but I can start Xorg (MATE) with startx on VT1 without any problems.

There is another problem. I tried to compile the RC1 today but I got some error messages:

Code: Select all
 CHK     scripts/mod/devicetable-offsets.h
  CHK     include/generated/compile.h
  CALL    arch/powerpc/kernel/systbl_chk.sh
  CALL    arch/powerpc/kernel/prom_init_check.sh
  CC      arch/powerpc/kvm/../../../virt/kvm/eventfd.o
arch/powerpc/kvm/../../../virt/kvm/eventfd.c: In function 'kvm_irqfd':
arch/powerpc/kvm/../../../virt/kvm/eventfd.c:568:19: error: 'KVM_MAX_IRQ_ROUTES' undeclared (first use in this function)
  if (args->gsi >= KVM_MAX_IRQ_ROUTES)
                   ^~~~~~~~~~~~~~~~~~
arch/powerpc/kvm/../../../virt/kvm/eventfd.c:568:19: note: each undeclared identifier is reported only once for each function it appears in
make[1]: *** [arch/powerpc/kvm/../../../virt/kvm/eventfd.o] Error 1
make: *** [arch/powerpc/kvm] Error 2


I had to remove the kvm support. After that it compiled. The kernel developers know the problem. Link: [mainline][bisected 36ae3c0] Build fail at virt/kvm/eventfd.c:568

Cheers,
Christian
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.
User avatar
xeno74
 
Posts: 2939
Joined: Fri Mar 23, 2012 8:58 am

Re: Kernel 4.14

Postby xeno74 » Tue Sep 19, 2017 6:52 pm

Hi All,

I released the RC1 for the X5000 and X1000 today.


Download: vmlinux-4.14-rc1-AmigaOne_X1000_X5000.tar.gz

The kernel developers have removed some firmwares from the Linux Git. Maybe some firmwares are missing for some graphics cards. I restored these firmwares and after that I compiled an extra kernel for testing for your X5000. (uImage-4.14-4870)

Code: Select all
git revert df85b2d767aad90fd2746f993fcd66dd322768f8


Output:

Code: Select all
[master f7615c9] Revert "firmware: Restore support for built-in firmware"


Code: Select all
git revert b38923a068c10fc36ca8f596d650d095ce390b85 -m 1


Output:

Code: Select all
[master d9ae2e8] Revert "Merge tag 'firmware_removal-4.14-rc1' of git://git.kernel.org/pub/scm/linux/kernel/git/gregkh/driver-core"


Code: Select all
create mode 100644 firmware/radeon/RV710_me.bin.ihex
create mode 100644 firmware/radeon/RV710_pfp.bin.ihex
create mode 100644 firmware/radeon/RV730_me.bin.ihex
create mode 100644 firmware/radeon/RV730_pfp.bin.ihex
create mode 100644 firmware/radeon/RV770_me.bin.ihex
create mode 100644 firmware/radeon/RV770_pfp.bin.ihex


Please test it.

Thanks,
Christian
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.
User avatar
xeno74
 
Posts: 2939
Joined: Fri Mar 23, 2012 8:58 am

Re: Kernel 4.14

Postby xeno74 » Thu Sep 21, 2017 8:15 am

@Tom
Please Please Please test the RC1 on your X1000.
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.
User avatar
xeno74
 
Posts: 2939
Joined: Fri Mar 23, 2012 8:58 am

Next

Return to Platform: AmigaOne X1000 - Linux Only

Who is online

Users browsing this forum: No registered users and 3 guests