X1000 success with CruxPPC and MintPPC Linux Distros

AmigaOne X1000 platform specific issues related to Linux only.

Re: X1000 success with CruxPPC and MintPPC Linux Distros

Postby trevordick » Sun May 20, 2012 12:26 am

Pat,

I can confirm that your quick fix works! I now have onboard audio under Ubuntu 12.04. You are the man!! :-)

Trevor
I'm just Breezin'
User avatar
trevordick
A-Eon Technology
A-Eon Technology
 
Posts: 1379
Joined: Mon Dec 20, 2010 2:28 pm

Re: X1000 success with CruxPPC and MintPPC Linux Distros

Postby musa » Sun May 20, 2012 12:01 pm

trevordick wrote:Pat,

I can confirm that your quick fix works! I now have onboard audio under Ubuntu 12.04. You are the man!! :-)

Trevor

Same for me. Sound on
Peter
AmigaX1000
Follow me on twitter @basjoo_dk
User avatar
musa
 
Posts: 323
Joined: Tue Aug 23, 2011 8:58 pm

Re: X1000 success with CruxPPC and MintPPC Linux Distros

Postby gerograph » Sun May 27, 2012 5:54 pm

need a suggestion on which LinuxDistro to install...

I need:
- sound and video playback
- a "snappy" Desktop (Well, I am coming from SAM440@677 and GNOME is really slow on this machine ... -> maybe all GUI/Desktop/Windowmanagers are fast on X1000 anyway, donnot know ?)
- OpenOffice, Printer and maybe SANE Scanner support (probably included everywhere anyway ?)
- Easy configureability/usage as I am more into AmigaOS and Windows and not into Linux at all (guess for this one Ubuntu is the way to go ?)
- WinXP Emulation ?

I donnot need:
- games, 3D games
- CAD or raytracing / 3D modelling

Thanx for advice
User avatar
gerograph
 
Posts: 78
Joined: Sun Mar 25, 2012 10:24 am
Location: Moers

Re: X1000 success with CruxPPC and MintPPC Linux Distros

Postby tommysammy » Sun May 27, 2012 6:00 pm

gerograph wrote:need a suggestion on which LinuxDistro to install...

I need:
- sound and video playback
- a "snappy" Desktop (Well, I am coming from SAM440@677 and GNOME is really slow on this machine ... -> maybe all GUI/Desktop/Windowmanagers are fast on X1000 anyway, donnot know ?)
- OpenOffice, Printer and maybe SANE Scanner support (probably included everywhere anyway ?)
- Easy configureability/usage as I am more into AmigaOS and Windows and not into Linux at all (guess for this one Ubuntu is the way to go ?)
- WinXP Emulation ?

I donnot need:
- games, 3D games
- CAD or raytracing / 3D modelling

Thanx for advice

I am running here Mint11 .It is my taste.
I can play DVD Movies ,all sorts of videos,have sound,2D and 3D acceleration,LibreOffice and much more
WinXP emulation is not possible .Wine doesn`t work on PPC hardware
AmigaOne X1000 Betatester A1-X1090
AmigaOne X1000/4GB Ram/Saphire Radeon 7850 1GB/256GB SSD HD/2GB CF Card/RTL8169Network
User avatar
tommysammy
 
Posts: 942
Joined: Mon Dec 20, 2010 10:03 pm
Location: Isselburg,Germany

Re: X1000 success with CruxPPC and MintPPC Linux Distros

Postby gerograph » Sun May 27, 2012 6:14 pm

@tommysammy
danke... hast du Ubuntu auch schon getestet ?

@all
Well, somebody suggestions regarding Ubuntu ?
User avatar
gerograph
 
Posts: 78
Joined: Sun Mar 25, 2012 10:24 am
Location: Moers

Re: X1000 success with CruxPPC and MintPPC Linux Distros

Postby tommysammy » Sun May 27, 2012 6:41 pm

gerograph wrote:@tommysammy
danke... hast du Ubuntu auch schon getestet ?

@all
Well, somebody suggestions regarding Ubuntu ?

Nein
AmigaOne X1000 Betatester A1-X1090
AmigaOne X1000/4GB Ram/Saphire Radeon 7850 1GB/256GB SSD HD/2GB CF Card/RTL8169Network
User avatar
tommysammy
 
Posts: 942
Joined: Mon Dec 20, 2010 10:03 pm
Location: Isselburg,Germany

Re: X1000 success with CruxPPC and MintPPC Linux Distros

Postby mechanic » Wed May 30, 2012 12:45 pm

I think we need a place to discuss X1000 (and others) Linux stuff.

While digging around in the 2.6.39.4 source code it looks like the /platforms/pasemi/iommu.c is using 0x8000_0000 not only as the amount of RAM installed in a 2G system, but also as the Top-Of-RAM. Should not the Top-Of-RAM be 0x7FFF_FFFF ?

7FFF_FFFF + the zero bit = 8000_0000 total.

:?
A-Eon A1X1000
User avatar
mechanic
 
Posts: 481
Joined: Sat Jun 25, 2011 10:22 pm

Re: X1000 success with CruxPPC and MintPPC Linux Distros

Postby AmigaDave » Tue Jul 03, 2012 1:22 am

mechanic wrote:I think we need a place to discuss X1000 (and others) Linux stuff.

While digging around in the 2.6.39.4 source code it looks like the /platforms/pasemi/iommu.c is using 0x8000_0000 not only as the amount of RAM installed in a 2G system, but also as the Top-Of-RAM. Should not the Top-Of-RAM be 0x7FFF_FFFF ?

7FFF_FFFF + the zero bit = 8000_0000 total.

:?


What is wrong with discussing Linux on the X1000 here in these support forums? I guess if you want to discuss Linux on other hardware, another location would be more appropriate, but I am sure that there are probably hundreds of other Linux forum sites already set up, so setting up another one does not make much sense to me.

To the rest of you, I am amazed at how quickly all of you have gotten so many different Linux flavors running on the X1000, so congrats on all of your hard work. I hope Trevor is not having too much trouble in keeping the X1000 Linux installation manual, or guide up to date with all of these changes. Seems like that is almost a full time job, since the changes are happening so fast. Unfortunately, I have installed a second hard drive into my X1000, but have not yet found the time to install any version of Linux on to it.

Do the rest of you find that having a second SATA hard drive slows down the OS4.1.5 boot time by several minutes, even though there is nothing on that hard drive? If yes, is there a documented way to reduce this delay when using two hard drives, or will it automatically get better, once I complete the dual boot installation of one or more versions of Linux on my 2nd hard drive?

I am open to suggestions on which version of Linux is the best to install on my X1000's 2nd hard drive, and the reasons why you prefer it over all other Linux versions (speed, ease of use, number of included software programs, etc.).

I can't wait for my back to get fixed, so I can spend more time in front of my X1000. Only 10 more days until I can discuss the possibility of a 2nd back surgery which will hopefully fix me up good as new (or at least good enough).

I look forward to seeing several of you at this year's 2012 AmiWest Show in Oct. (back surgery scheduling permitting).

Edit: I forgot to ask, have any of you experienced any problems booting OS4.1.5 while you have more than 2gb of RAM installed within your X1000? When I installed my 2nd SATA hard drive, I also installed my additional 4gb of RAM giving me a total of 6gb RAM, but my X1000 refused to boot with that configuration. Is there a setting I am missing which is documented in the manual or guide somewhere, but I missed in my quick reading of them?
Proud owner of 10+ Commodore Amiga 680x0 computers
First Contact AmigaOne X1000 Dual Core 1.8GHz PA6T w/OS4.1FE
Dual 2.7GHz G5 PowerMac w/MorphOS3.7
1.5GHz G4 PMac MDD w/MorphOS3.7
1.5GHz G4 MacMini w/MorphOS3.7
17" 1.67GHz G4 PBooks w/MorphOS3.7
Efika 5200b w/MorphOS3.7
FPGA Arcade Replay w/AmigaOS3.x
AmigaDave
 
Posts: 145
Joined: Wed Jan 04, 2012 4:31 am
Location: Lake Shastina, California, USA

Re: X1000 success with CruxPPC and MintPPC Linux Distros

Postby AmigaDave » Mon Aug 13, 2012 11:39 pm

Bump!

Can anyone answer the questions I asked in my previous message in this thread?

Thanks!
Proud owner of 10+ Commodore Amiga 680x0 computers
First Contact AmigaOne X1000 Dual Core 1.8GHz PA6T w/OS4.1FE
Dual 2.7GHz G5 PowerMac w/MorphOS3.7
1.5GHz G4 PMac MDD w/MorphOS3.7
1.5GHz G4 MacMini w/MorphOS3.7
17" 1.67GHz G4 PBooks w/MorphOS3.7
Efika 5200b w/MorphOS3.7
FPGA Arcade Replay w/AmigaOS3.x
AmigaDave
 
Posts: 145
Joined: Wed Jan 04, 2012 4:31 am
Location: Lake Shastina, California, USA

Re: X1000 success with CruxPPC and MintPPC Linux Distros

Postby nbache » Tue Aug 14, 2012 12:02 am

AmigaDave wrote:Can anyone answer the questions I asked in my previous message in this thread?
It might have been better to ask them in their own thread.

But I'll try.

What is wrong with discussing Linux on the X1000 here in these support forums?
Nothing, AFAIAC.

Do the rest of you find that having a second SATA hard drive slows down the OS4.1.5 boot time by several minutes, even though there is nothing on that hard drive?
I didn't notice such a delay when I had that setup (long ago; I've since created several partitions on the secondary drive).

I am open to suggestions on which version of Linux is the best to install on my X1000's 2nd hard drive
I can't contribute much there; I simply installed Debian on my machine and don't need anything else. I don't use Linux that much anyway.

I didn't install it purely on the second drive, though; both my drives have RDBs, and the Linux partitions (root, /home and swap) are spread across both drives, as are my AmigaOS partitions.

Edit: I forgot to ask, have any of you experienced any problems booting OS4.1.5 while you have more than 2gb of RAM installed within your X1000?
Not me. I have 4 GB (2 × 2). There is something about making sure you populate both of the inner slots, i.e. the ones closest to the CPU, for optimal operation, but even if you don't, it shouldn't have such grave consequences. Try swapping the sticks around, removing one at a time, to see if one of them might be faulty.

Best regards,

Niels
User avatar
nbache
Beta Tester
Beta Tester
 
Posts: 1210
Joined: Mon Dec 20, 2010 8:25 pm
Location: Copenhagen, Denmark

PreviousNext

Return to Platform: AmigaOne X1000 - Linux Only

Who is online

Users browsing this forum: Bing [Bot] and 4 guests

cron