Qemu

AmigaOne X1000 platform specific issues related to Linux only.

Re: Qemu

Postby JohnFante » Fri Oct 17, 2014 5:41 pm

xeno74 wrote:
JohnFante wrote:Now I got MOL running :-). However it freezes during boot (I "found" a PearPC made Jaguar image) when it comes to the "+ Video Driver v1.12" section. See this https://dl.dropboxusercontent.com/u/139090/MOL.png screenshot.


Oh sorry. I didn't mention it that MoL doesn't support Mac OS X 10.2.X Jaguar. I told it Alexander Graf the developer of MoL/KVM. He told me, he will investigate the problem with 10.2 Jaguar. Currently only Mac OS X 10.3.X Panther and 10.4.XX Tiger are supported. Sorry.


I have tried with an Panther image made for PearPC. Still no luck. Halts the same place.

Just to be clear. You made a Panther install on PearPC on a PC and then copied the image over?
X5000 :-)
User avatar
JohnFante
Beta Tester
Beta Tester
 
Posts: 133
Joined: Tue Sep 04, 2012 7:48 am
Location: Copenhagen, Denmark

Re: Qemu

Postby xeno74 » Fri Oct 17, 2014 6:35 pm

JohnFante wrote:Just to be clear. You made a Panther install on PearPC on a PC and then copied the image over?


Yes, that's right.
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.
User avatar
xeno74
 
Posts: 2628
Joined: Fri Mar 23, 2012 8:58 am

Re: Qemu

Postby xeno74 » Fri Oct 24, 2014 9:17 pm

Classic_boots_Mac-on-Linux.jpg


Classic_Mac-on-Linux.jpg
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.
User avatar
xeno74
 
Posts: 2628
Joined: Fri Mar 23, 2012 8:58 am

Re: Qemu

Postby sailorMH » Mon Oct 27, 2014 11:18 am

xeno74 wrote:I don't have Windows 95 installed. But I have found a good guide about installing Windows 95 on QEMU.
Download: Installing_Windows_95_on_Qemu


Many thanks. I tried it, but the problem is the same. After installation of sb16 driver onw95 it hangs. Maybe there is problem with bios. In Hardware window/system devices/BIOS there is yellow exclamation mark...
Pls, If anybody runs W95 - what bios do you use?
Pegasos 2: MorphOS, AmigaOS, MintPPC 11, NetBSD, MacOS X (molk)
AmigaOne X1000: AmigaOS, MintPPC 11
User avatar
sailorMH
 
Posts: 17
Joined: Wed Aug 28, 2013 7:01 pm
Location: Czech republic

Re: Qemu

Postby xeno74 » Fri Aug 19, 2016 2:09 pm

Image

Hi All,

I try to install NetBSD 7.0.1 with KVM PR. :-) Host system: ubuntu MATE 16.04.1 LTS PowerPC with QEMU 2.5.0 (Debian 1:2.5+dfsg-5ubuntu10.4) kernel 4.7.1

  1. Code: Select all
    qemu-img create netbsd.img 10G
  2. Code: Select all
    sudo modprobe kvm-pr
  3. Code: Select all
    qemu-system-ppc -enable-kvm -machine g3beige -cdrom NetBSD-7.0.1-macppc.iso -boot d -m 2047 -drive file=netbsd.img,format=raw,index=0,media=disk
  4. OpenBIOS v1.1 boot:
    Code: Select all
    0 > boot cd:,ofwboot.xcf netbsd.macppc

Unfortunately the installation is very slow. I don't know why.
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.
User avatar
xeno74
 
Posts: 2628
Joined: Fri Mar 23, 2012 8:58 am

Re: Qemu

Postby xeno74 » Sun Aug 21, 2016 11:37 am

OpenBIOS download: openbios-ppc
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.
User avatar
xeno74
 
Posts: 2628
Joined: Fri Mar 23, 2012 8:58 am

Re: Qemu

Postby xeno74 » Tue Nov 08, 2016 2:37 am

Hi All,

I installed the old S.u.S.E. Linux 6.0 (released 1998) with QEMU on my X1000 today.

Part 1 with the StarOffice installation:

Image

Part 2 with StarOffice 5.0:

Image

Part 3 with Applixware Office:

Image

Part 4 with KDE 1.0:

Image

Cheers,
Christian
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.
User avatar
xeno74
 
Posts: 2628
Joined: Fri Mar 23, 2012 8:58 am

Previous

Return to Platform: AmigaOne X1000 - Linux Only

Who is online

Users browsing this forum: No registered users and 3 guests