(X)(L)ubuntu (MATE) 15.04

AmigaOne X1000 platform specific issues related to Linux only.

(X)(L)ubuntu (MATE) 15.04

Postby xeno74 » Sat Jan 31, 2015 5:54 pm

Image

I updated my ubuntu MATE 14.10 to 15.04 today. I want to do some beta testing.

Important notes:
I got the following error message after the update:
Code: Select all
systemd-logind[7220]: Failed to apply ACLs: Operation not supported


Therefore I had to compile a new kernel 3.19 with the following special options:

Code: Select all
CONFIG_TMPFS_POSIX_ACL=y
CONFIG_TMPFS_XATTR=y


You need the new kernel 3.19 RC6-2 because of the ACL problems.

Additionally the system showed me the following error message:
Code: Select all
Disk Drive / not ready yet or not available

I pressed 's' for skip and then I mounted it rw with
Code: Select all
mount -o remount, rw /


I added rw to the boot arguments. This solved this problem.

Update instructions:

  1. Download the kernel 3.19 RC6-2: vmlinux-3.19.0-rc6-2-KVM-PR-AMIGA_one_X1000.tar.bz2
  2. Unpack the kernel package
  3. Copy the kernel vmlinux-3.19 to the CF card
  4. Copy the kernel modules directory to /lib/modules:
    Code: Select all
    sudo cp -R 3.19.0-rc6_A-EON_AMIGA_one_X1000_Nemo /lib/modules
  5. Reboot your AMIGA one X1000 and enter the firmware. If you have autoboot set up, press
    CTRL-C. If you have the latest menu-enabled firmware, press the F key to enter the firmware. In
    any case, you should end up on the firmware's command prompt which looks like this:
    Code: Select all
    CFE>
  6. Create a CFE boot entry for your new ubuntu MATE 15.04 for example:
    Code: Select all
    CFE> setenv -p MENU_3_LABEL "ubuntu MATE 15.04 Kernel 3.19"

    Code: Select all
    CFE> setenv -p MENU_3_COMMAND 'set pmu -astate=A4 ; setenv bootargs "root=/dev/sdb7 quiet ro splash rw" ; boot -elf -noints -fatfs cf0:vmlinux-3.19'
  7. To activate the new Boot Menu type menu and use the arrow keys to select and highlight 3: ubuntu MATE 15.04 Kernel 3.19 before the timer bar runs down.
  8. CTRL+ALT+F1 to change to the console login.
  9. Login as user
  10. Change your user to the root user with
    Code: Select all
    sudo su
  11. Stop X11 with
    Code: Select all
    service lightdm stop
  12. Update the package index of your old 14.10 system:
    Code: Select all
    apt-get update
  13. Upgrade your packages to the latest packages on your old 14.10 system:
    Code: Select all
    apt-get upgrade
  14. Remove those dependencies that were installed with applications and that are no longer used by anything else on the system:
    Code: Select all
    apt-get autoremove
  15. Remove .deb files for packages that are no longer installed on your system:
    Code: Select all
    apt-get autoclean
  16. Update your repositories to the new 15.04 repositories
    Code: Select all
    sed -i 's/utopic/vivid/g' /etc/apt/sources.list

    FYI: ubuntu MATE repository for splash screen, artwork, icons, and themes:
    /etc/apt/sources.list:
    Code: Select all
    deb http://ppa.launchpad.net/ubuntu-mate-dev/ppa/ubuntu vivid main

    If you don't have the ubuntu MATE PPA key, then you get it with:
    Code: Select all
    add-apt-repository ppa:ubuntu-mate-dev/ppa
  17. Update the package index of the new 15.04 system:
    Code: Select all
    apt-get update
  18. Upgrade your 14.10 system to version 15.04:
    Code: Select all
    apt-get dist-upgrade
  19. Reboot
  20. Login with your user
  21. Tidy up :D
    Code: Select all
    sudo apt-get autoremove
    and
    Code: Select all
    sudo apt-get autoclean
  22. Unfortunately, X11 doesn't work automatically. You need a xorg.conf.
  23. sudo su
  24. X -configure
  25. copy the xorg.conf.new to /etc/X11/xorg.conf:
    Code: Select all
    cp xorg.conf.new /etc/X11/xorg.conf
  26. Change the driver to radeon in the xorg.conf:
    Code: Select all
    Driver   "radeon"
  27. Reboot your AMIGA one X1000
  28. Login in your new ubuntu MATE 15.04 system.
  29. Download the unofficial Mesa: MesaLib-10.0.4-powerpc-unofficial.tar.bz2
  30. Extract it in your home folder
  31. Rename the original r600_dri.so to r600_dri.so.bak:
    Code: Select all
    sudo mv /usr/lib/powerpc-linux-gnu/dri/r600_dri.so /usr/lib/powerpc-linux-gnu/dri/r600_dri.so.bak
  32. Copy the patched r600_dri.so to /usr/lib/powerpc-linux-gnu/dri:
    Code: Select all
    sudo cp mesa-10.0.4/lib/dri/r600_dri.so /usr/lib/powerpc-linux-gnu/dri
  33. Rename the original LibGL.so.1.2.0 to LibGL.so.1.2.0.bak:
    Code: Select all
    sudo mv /usr/lib/powerpc-linux-gnu/mesa/libGL.so.1.2.0 /usr/lib/powerpc-linux-gnu/mesa/libGL.so.1.2.0.bak
  34. Copy the patched LibGL.so.1.2.0 to /usr/lib/powerpc-linux-gnu/mesa:
    Code: Select all
    sudo cp mesa-10.0.4/lib/LibGL.so.1.2.0 /usr/lib/powerpc-linux-gnu/mesa
  35. Copy the whole Mesa directory to /usr/local:
    Code: Select all
    sudo cp -R mesa-10.0.4 /usr/local
Unfortunately you need the environment variable LD_LIBRARY_PATH additionally.
Code: Select all
export LD_LIBRARY_PATH=/usr/local/mesa-10.0.4/lib


You can test it with glxgears:

Code: Select all
vblank_mode=0 glxgears


ubuntu_MATE_15.04_AMIGA_one_X1000.jpg
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.
User avatar
xeno74
 
Posts: 3963
Joined: Fri Mar 23, 2012 8:58 am

Re: (X)(L)ubuntu (MATE) 15.04

Postby Srtest » Mon Feb 02, 2015 3:01 am

"systemd-logind[7220]: Failed to apply ACLs: Operation not supported"

That's exactly what I got when I tried to upgrade to the latest Mesa! And I thought what did I do wrong!

(on 14.10)
User avatar
Srtest
 
Posts: 240
Joined: Wed Jun 11, 2014 6:06 pm

Re: (X)(L)ubuntu (MATE) 15.04

Postby nexus » Mon Feb 02, 2015 2:02 pm

Srtest wrote:"systemd-logind[7220]: Failed to apply ACLs: Operation not supported"

That's exactly what I got when I tried to upgrade to the latest Mesa! And I thought what did I do wrong!

(on 14.10)


I think, I've seen the same error messages in my syslog file. Maybe it is specific to the 14.10 installation with vmlinux 3.18?

ACL stand for "Access Control Lists" to allow for user-level permission settings.
So my guess is missing or wrong permission on some device? (-- as in the audio case). So, is your user or even root in the group "video" or any other required group needed to do the task you want to achieve :) ?

cheers,
nexus
User avatar
nexus
Beta Tester
Beta Tester
 
Posts: 347
Joined: Mon Dec 20, 2010 3:11 pm
Location: Germany

Re: (X)(L)ubuntu (MATE) 15.04

Postby xeno74 » Sun Feb 08, 2015 4:24 pm

Image

Mac-on-Linux/"PR" KVM works without any problems on ubuntu MATE 15.04 with kernel 3.19 RC7. :-)

I installed it with the following Debian package today: mol-kvm_0.9.73.0-ubuntu_powerpc.deb.

ubuntu_MATE_15.04_with_Mac-on-Linux.jpg


ubuntu_MATE_15.04_with_Mac-on-Linux_2.jpg
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.
User avatar
xeno74
 
Posts: 3963
Joined: Fri Mar 23, 2012 8:58 am

Re: (X)(L)ubuntu (MATE) 15.04

Postby zzd10h » Mon Feb 09, 2015 1:01 am

Thanks to your procedure, installation was without problem !

What is the window manager that you installed in your picture where STK is shown at the end of your first post ?

glxgears seems OK nevertheless STK is very slow to start and complains about r600 driver at startup (error shown in the upper left xterm in the following picture)

Edit : maybe that I made a mistake when I added the "export LD_LIBRARY_PATH..." ? I added it in my .bashrc and in my .profile (to be sure...)
Where do you add this export, please ?
Attachments
LUbuntu_15.04.png
http://apps.amistore.net/zTools
X1000 - AmigaOS 4.1.6 / 4.1 FE
zzd10h
 
Posts: 546
Joined: Sun Sep 16, 2012 6:40 am
Location: France

Re: (X)(L)ubuntu (MATE) 15.04

Postby xeno74 » Mon Feb 09, 2015 7:25 am

zzd10h wrote:Thanks to your procedure, installation was without problem !


Fantasic! Thank you!

zzd10h wrote:What is the window manager that you installed in your picture where STK is shown at the end of your first post ?


This is a MATE desktop with the Marco window manager.

This will install the complete MATE desktop in Lubuntu:

Code: Select all
sudo apt-get install mate-desktop-environment


This will install the complete MATE desktop including a few extras in Lubuntu:

Code: Select all
sudo apt-get install mate-desktop-environment-extras


For the ubuntu MATE splash screen, artwork, icons, and themes you have to add the Ubuntu MATE PPA to the sources.list.

/etc/apt/sources.list

Code: Select all
...
deb http://ppa.launchpad.net/ubuntu-mate-dev/ppa/ubuntu vivid main


zzd10h wrote:glxgears seems OK nevertheless STK is very slow to start and complains about r600 driver at startup (error shown in the upper left xterm in the following picture)

Edit : maybe that I made a mistake when I added the "export LD_LIBRARY_PATH..." ? I added it in my .bashrc and in my .profile (to be sure...)
Where do you add this export, please ?


Unfortunately you have to modify the file run_game.sh for STK to use the unofficial Mesa.

Edit run_game.sh:

Code: Select all
LD_LIBRARY_PATH=.bin:/usr/local/mesa-10.0.4/lib: bin/supertuxkart


Have a lot of fun with testing the version 15.04. :-)
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.
User avatar
xeno74
 
Posts: 3963
Joined: Fri Mar 23, 2012 8:58 am

Re: (X)(L)ubuntu (MATE) 15.04

Postby zzd10h » Mon Feb 09, 2015 9:00 am

Yes, STK works now. Speed and sound are OK.

I will try to install LUbuntu and Mate-desktop this evening.

Thank you
http://apps.amistore.net/zTools
X1000 - AmigaOS 4.1.6 / 4.1 FE
zzd10h
 
Posts: 546
Joined: Sun Sep 16, 2012 6:40 am
Location: France

Re: (X)(L)ubuntu (MATE) 15.04

Postby zzd10h » Tue Feb 10, 2015 11:12 pm

Hi,
I installed all the WM (X-K-L Ubuntu) and I was trying all the desktop environment.

Is someone tried Plasma desktop (maybe from KUbuntu) ?
Thank you

It looks very strange (psychedelic, slow and flashy). I don't know if it's normal :o
Attachments
Plasma.png
http://apps.amistore.net/zTools
X1000 - AmigaOS 4.1.6 / 4.1 FE
zzd10h
 
Posts: 546
Joined: Sun Sep 16, 2012 6:40 am
Location: France

Re: (X)(L)ubuntu (MATE) 15.04

Postby xeno74 » Wed Feb 11, 2015 7:57 am

zzd10h wrote:Hi,
I installed all the WM (X-K-L Ubuntu) and I was trying all the desktop environment.

Is someone tried Plasma desktop (maybe from KUbuntu) ?
Thank you

It looks very strange (psychedelic, slow and flashy). I don't know if it's normal :o


Thank you for testing the KDE desktop. I think there are some colors wrong.
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.
User avatar
xeno74
 
Posts: 3963
Joined: Fri Mar 23, 2012 8:58 am

Re: (X)(L)ubuntu (MATE) 15.04

Postby xeno74 » Sun Feb 22, 2015 1:11 pm

Hi All,

I tested QEMU 2.2 on ubuntu MATE 15.04 with the kernel 4.00 alpha 4 today. I booted my first Linux distribution that I ever bought. It's S.u.S.E Linux 5.0 from 1997. That's really impressed to work with my first Linux distribution and with the modern ubuntu MATE 15.04 PowerPC together at the same time.

ubuntu_MATE_15.04_PowerPC_with_kernel_4.00_alpha4_SuSE_5.0_i686_QEMU_A1-X1000.jpg


It's nice to see the old S.u.S.E FVWM 2 and the old Netscape browsers.

Have a nice weekend!

Christian
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.
User avatar
xeno74
 
Posts: 3963
Joined: Fri Mar 23, 2012 8:58 am

Next

Return to Platform: AmigaOne X1000 - Linux Only

Who is online

Users browsing this forum: No registered users and 9 guests