Kernel 4.1

AmigaOne X1000 platform specific issues related to Linux only.

Re: Kernel 4.1

Postby Srtest » Tue Jun 16, 2015 12:57 am

Here is Lubuntu developmental on kernel RC8 on a ext4 partition.

A question about the kernel panic issues with a btrfs partition - do you think this procedure can be used on the X1000?
https://youtu.be/L7jIAvs5bFU
Attachments
s1.jpg
User avatar
Srtest
 
Posts: 240
Joined: Wed Jun 11, 2014 6:06 pm

Re: Kernel 4.1

Postby xeno74 » Tue Jun 16, 2015 9:44 am

musa wrote:Hi
the error is
FAILED failed to start load kernel modules.
see 'systemctl status systemd-modules-load.service' for details.

And the output of 'systemctl status systemd-modules-load.service are:
● systemd-modules-load.service - Load Kernel Modules
Loaded: loaded (/lib/systemd/system/systemd-modules-load.service; static)
Active: failed (Result: exit-code) since søn 2015-06-14 11:10:40 CEST; 15min ago
Docs: man:systemd-modules-load.service(8)
man:modules-load.d(5)
Process: 2182 ExecStart=/lib/systemd/systemd-modules-load (code=exited, status=1/FAILURE)
Main PID: 2182 (code=exited, status=1/FAILURE)

Thk.


Hi Musa,

Sorry for my late answer. First of all many thanks for testing. I have found some help about systemd in combination with kernel modules: wiki.archlinux.org. Could you try it out, please?

Rgds,

Christian
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.
User avatar
xeno74
 
Posts: 4118
Joined: Fri Mar 23, 2012 8:58 am

Re: Kernel 4.1

Postby musa » Tue Jun 16, 2015 11:38 am

xeno74 wrote:
Hi Musa,

Sorry for my late answer. First of all many thanks for testing. I have found some help about systemd in combination with kernel modules: wiki.archlinux.org. Could you try it out, please?

Rgds,

Christian

Hi Christian
Thank you for answers
I did the following:
systemctl status systemd-modules-load in a terminal gave me the Process ID which was 2182
Then sudo journalctl _PID=2182
Here I could see that it was some cups modules that failed.

Then sudo ls -Al /etc/modules-load.d/ who gave me this output.
"-rw-r - r-- 1 root root 125 June 16 11:00 cups filters.conf
lrwxrwxrwx 1 root root 10 May 26 18:37 modules.conf -> ../modules"

Then I opened /etc/modules-load.d/ cups filters.conf in an editor and inserted # in front of the modules that fails.
Then I restarted and the error was gone.
systemctl status systemd-modules-load now says:
systemd-modules-load.service - Load Kernel Modules
Loaded: loaded (/lib/systemd/system/systemd-modules-load.service; static)
Active: active (exited) since Tue 2015-06-16 11:03:54 CEST; 4min 5s ago
Docs: Mon: systemd-modules-load.service (8)
Mon: modules-load.d (5)
Process: 1092 ExecStart = / lib / systemd / systemd-modules-load (code = exited, status = 0 / SUCCESS)
Main PID: 1092 (code = exited, status = 0 / SUCCESS)
CGroup: /system.slice/systemd-modules-load.service

This could indicate that the problem is solved.
The modules not started was, that I could see for printing via par: and ser: devices that I do not use.
Thanks for the help

By the way, which Linux do you use with qemu
AmigaX1000
Follow me on twitter @basjoo_dk
User avatar
musa
 
Posts: 331
Joined: Tue Aug 23, 2011 8:58 pm

Re: Kernel 4.1

Postby xeno74 » Tue Jun 16, 2015 8:39 pm

musa wrote:Hi Christian
Thank you for answers
I did the following:
systemctl status systemd-modules-load in a terminal gave me the Process ID which was 2182
Then sudo journalctl _PID=2182
Here I could see that it was some cups modules that failed.

Then sudo ls -Al /etc/modules-load.d/ who gave me this output.
"-rw-r - r-- 1 root root 125 June 16 11:00 cups filters.conf
lrwxrwxrwx 1 root root 10 May 26 18:37 modules.conf -> ../modules"

Then I opened /etc/modules-load.d/ cups filters.conf in an editor and inserted # in front of the modules that fails.
Then I restarted and the error was gone.
systemctl status systemd-modules-load now says:
systemd-modules-load.service - Load Kernel Modules
Loaded: loaded (/lib/systemd/system/systemd-modules-load.service; static)
Active: active (exited) since Tue 2015-06-16 11:03:54 CEST; 4min 5s ago
Docs: Mon: systemd-modules-load.service (8)
Mon: modules-load.d (5)
Process: 1092 ExecStart = / lib / systemd / systemd-modules-load (code = exited, status = 0 / SUCCESS)
Main PID: 1092 (code = exited, status = 0 / SUCCESS)
CGroup: /system.slice/systemd-modules-load.service

This could indicate that the problem is solved.
The modules not started was, that I could see for printing via par: and ser: devices that I do not use.
Thanks for the help


My pleasure. :-)

musa wrote:By the way, which Linux do you use with qemu


I use my old x86 S.u.S.E Linux 5.0 from 1997:

ubuntu_MATE_15.04_PowerPC_with_kernel_4.00_alpha4_SuSE_5.0_i686_QEMU_A1-X1000.jpg


And I use ubuntu MATE 15.04 PowerPC with QEMU/KVM:

ubuntu_MATE_15.04_PowerPC_with_a_virtual_Power_Macintosh_G3_Beige_QEMU_KVM.jpg
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.
User avatar
xeno74
 
Posts: 4118
Joined: Fri Mar 23, 2012 8:58 am

Re: Kernel 4.1

Postby xeno74 » Sun Jun 21, 2015 10:26 am

The Linux kernel 4.1 final coming soon:

.......

vmlinux-4.1-AMIGA_one_X1000.tar.bz2

Linux kernel 4.1 Articles & Reviews - phoronix

phoronix wrote:If all goes well, the Linux 4.1 kernel will be released before the day is over. Linux 4.1 is yet another exciting update and here's a look at some of the most prominent work found in this new kernel version.


The Big Features Of The Linux 4.1 Kernel - phoronix

Anatomy_Linux_system.jpg
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.
User avatar
xeno74
 
Posts: 4118
Joined: Fri Mar 23, 2012 8:58 am

Re: Kernel 4.1

Postby xeno74 » Mon Jun 22, 2015 4:19 am

Here is a new patch because of the sound source code modifications in the kernel 4.1 final version:

nemo_4.1-3.patch.zip
(8.28 KiB) Downloaded 130 times
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.
User avatar
xeno74
 
Posts: 4118
Joined: Fri Mar 23, 2012 8:58 am

Re: Kernel 4.1

Postby xeno74 » Mon Jun 22, 2015 5:45 am

I compiled the 4.1 final from the git today.

Here you are. :-)

vmlinux-4.1-AMIGA_one_X1000.tar.bz2
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.
User avatar
xeno74
 
Posts: 4118
Joined: Fri Mar 23, 2012 8:58 am

Re: Kernel 4.1

Postby xeno74 » Thu Jun 25, 2015 2:09 pm

xeno74 wrote:I compiled the 4.1 final from the git today.

Here you are. :-)

vmlinux-4.1-AMIGA_one_X1000.tar.bz2


PLEASE test the kernel 4.1 final. This kernel don't boot on zzd10h's X1000. I want to know why. I tested the kernel 4.1 final successfully on my A1-X1000 last Monday.
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.
User avatar
xeno74
 
Posts: 4118
Joined: Fri Mar 23, 2012 8:58 am

Re: Kernel 4.1

Postby zzd10h » Thu Jun 25, 2015 2:21 pm

My failure seems to be

"Please append a correct "root=" boot option"

What do you have as CFE parameters ?

PS : 4.1upd4 boots fine with same CFE boot option
http://apps.amistore.net/zTools
X1000 - AmigaOS 4.1.6 / 4.1 FE
zzd10h
 
Posts: 546
Joined: Sun Sep 16, 2012 6:40 am
Location: France

Re: Kernel 4.1

Postby xeno74 » Thu Jun 25, 2015 2:46 pm

zzd10h wrote:My failure seems to be

"Please append a correct "root=" boot option"

What do you have as CFE parameters ?

PS : 4.1upd4 boots fine with same CFE boot option


I have "root=/dev/sdb9 quiet ro splash rw" because of upstart.
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.
User avatar
xeno74
 
Posts: 4118
Joined: Fri Mar 23, 2012 8:58 am

PreviousNext

Return to Platform: AmigaOne X1000 - Linux Only

Who is online

Users browsing this forum: No registered users and 16 guests