Ubuntu Mate 15.10

AmigaOne X1000 platform specific issues related to Linux only.

Ubuntu Mate 15.10

Postby musa » Mon Jun 15, 2015 7:34 pm

Hi
I tested the installation of ubuntu mate 15.10.
Installation went well.
booted to the login prompt ,then logged in and created an xorg.conf
file.
Then sudo service lightdm start and then joined the graphic's login.
Here login failed with this errror : startup of the session failed.
Tried to install another desktop instead of Mate but got this error
Temporary errors when setting up ports.ubuntu.com.
AmigaX1000
Follow me on twitter @basjoo_dk
User avatar
musa
 
Posts: 323
Joined: Tue Aug 23, 2011 8:58 pm

Re: Ubuntu Mate 15.10

Postby musa » Mon Jun 15, 2015 10:52 pm

It seems that the problem is a question of rights. get an error that says
can not create / sys / module / snd_hda_intel / parameters / power_save: permission denied.
Then the system freezes .
The problem: Temporary errors when setting up ports.ubuntu.com, was an error with the network
AmigaX1000
Follow me on twitter @basjoo_dk
User avatar
musa
 
Posts: 323
Joined: Tue Aug 23, 2011 8:58 pm

Re: Ubuntu Mate 15.10

Postby musa » Wed Jun 17, 2015 1:36 pm

I gave up Mate 15.10 and installed Xubuntu. Then I installed christians Mesa and downgraded xorg.
All work fine but modules are not loaded. I expect it to be resolved. Xubuntu is here booted with RC8.
Skærmbillede_2015-06.png
AmigaX1000
Follow me on twitter @basjoo_dk
User avatar
musa
 
Posts: 323
Joined: Tue Aug 23, 2011 8:58 pm

Re: Ubuntu Mate 15.10

Postby xeno74 » Wed Jun 17, 2015 9:03 pm

musa wrote:I gave up Mate 15.10 and installed Xubuntu. Then I installed christians Mesa and downgraded xorg.
All work fine but modules are not loaded. I expect it to be resolved. Xubuntu is here booted with RC8.
Skærmbillede_2015-06.png


Hi Musa,

Thank you very much for testing! I'll try to update my ubuntu MATE 15.04 to 15.10.

Rgds,

Christian
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.
User avatar
xeno74
 
Posts: 3177
Joined: Fri Mar 23, 2012 8:58 am

Re: Ubuntu Mate 15.10

Postby xeno74 » Fri Jul 24, 2015 1:53 pm

I could update my ubuntu MATE 15.04 to 15.10 successfully today. The new Xorg server shows all colors correct. Unfortunately Compiz doesn't work currently.

ubuntu_MATE_15.10_PowerPC_AMIGA_one_X1000_1.png
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.
User avatar
xeno74
 
Posts: 3177
Joined: Fri Mar 23, 2012 8:58 am

Re: Ubuntu Mate 15.10

Postby xeno74 » Fri Jul 24, 2015 10:03 pm

Fantastic! Compiz works on ubuntu MATE 15.10 again.

Image
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.
User avatar
xeno74
 
Posts: 3177
Joined: Fri Mar 23, 2012 8:58 am

Re: Ubuntu Mate 15.10

Postby musa » Sat Jul 25, 2015 12:13 pm

xeno74 wrote:Fantastic! Compiz works on ubuntu MATE 15.10 again.


Ubuntu Mate 15.10 with vmlinux-4.1.3 and updated
Compiz works
There are still some wrong colour in cairo-dock
Look like it is only in svg icons. not in png
Skærmbillede.png
AmigaX1000
Follow me on twitter @basjoo_dk
User avatar
musa
 
Posts: 323
Joined: Tue Aug 23, 2011 8:58 pm

Re: Ubuntu Mate 15.10

Postby xeno74 » Sat Jul 25, 2015 10:50 pm

musa wrote:
xeno74 wrote:Fantastic! Compiz works on ubuntu MATE 15.10 again.


Ubuntu Mate 15.10 with vmlinux-4.1.3 and updated
Compiz works
There are still some wrong colour in cairo-dock
Look like it is only in svg icons. not in png
Skærmbillede.png


Thank you very much for testing. :-)
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.
User avatar
xeno74
 
Posts: 3177
Joined: Fri Mar 23, 2012 8:58 am

Re: Ubuntu Mate 15.10

Postby xeno74 » Sun Jul 26, 2015 2:06 pm

Hi All,

After a big update today I found two problems in ubuntu MATE 15.10 PowerPC today.

The first is systemd. If I start ubuntu MATE 15.10 with systemd then the gnome-settings daemon doesn't start and MATE Tweak doesn't work (see screenshot). If I use upstart-sysv then MATE Tweak and the gnome-settings-daeomon work without any problems.

Image

Additionally there is a problem with MATE Tweak itself. If I switch to Compiz then it set org.gnome.metacity theme to 'Ambiant-MATE'. Metacity can't display the window decoration with the two apostrophes in the theme name (see screenshot).

Image

I created an own script to switch to Compiz and I set the theme name without apostrophes:

Code: Select all
gsettings set org.gnome.metacity theme Ambiant-MATE
compiz --replace


This works very well.

Rgds,

Christian
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.
User avatar
xeno74
 
Posts: 3177
Joined: Fri Mar 23, 2012 8:58 am

Re: Ubuntu Mate 15.10

Postby xeno74 » Mon Jul 27, 2015 11:55 am

Hi All,

I have released the RC4 of kernel 4.2 recently.

Image

New:

- systemd support (You don't need the boot argument "rw" for ubuntu MATE 15.04 and 15.10 anymore.)

Other changes:

https://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/log/

Linux 4.2-rc4 Released, But 4.2 Isn't Quite Calming Down - phoronix

The Linux 4.2-rc4 release announcement at LKML.org

It also includes:

- KVM_BOOK3S_64_PR
- Mac-on-Linux support
- Network support for AROS hosted
- Support for 4 serial ports
- Bluetooth USB dongle support
- Kernel tracing with ftrace
- ubuntu MATE 15.04 and 15.10 support
- Debian 8 support
- Linux kernel icon for OS4.1 by Tommysammy

Download: vmlinux-4.2-rc4-AMIGA_one_X1000.tar.bz2

Cheers,

Christian
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.
User avatar
xeno74
 
Posts: 3177
Joined: Fri Mar 23, 2012 8:58 am

Next

Return to Platform: AmigaOne X1000 - Linux Only

Who is online

Users browsing this forum: No registered users and 4 guests