(X)(L)ubuntu (MATE) 16.04 LTS

AmigaOne X1000 platform specific issues related to Linux only.

Re: (X)(L)ubuntu (MATE) 16.04 LTS

Postby papaoskar » Thu May 05, 2016 11:17 am

xeno74 wrote:It's also possible to add only the SetUID bit to the file attributes.

Code: Select all
# chmod u+s /bin/su


Code: Select all
# chmod u+s /usr/bin/sudo


Hi Christian,
first I have started ubuntu 12.04 and done the above commands on sdb8....
Then I started Mate_1604 from sdb8.
When I did "ls -l /usr/bin/su " the result now looks with the s bit set. (see picture ).
But still the "chown root:root /bin/su" tells me that I have a read-only filesystem.
Attachments
Foto0338.jpg
papaoskar
 
Posts: 80
Joined: Tue Jul 01, 2014 2:48 pm

Re: (X)(L)ubuntu (MATE) 16.04 LTS

Postby xeno74 » Thu May 05, 2016 2:33 pm

Amigo1 wrote:oh.. I think it was rendering a web page in the background, this looks better:

Code: Select all
amigo1@Amigaone:~$ vblank_mode=0 glxgears
ATTENTION: default value of option vblank_mode overridden by environment.
5177 frames in 5.0 seconds = 1035.321 FPS
5249 frames in 5.0 seconds = 1049.660 FPS
4534 frames in 5.0 seconds = 906.673 FPS
5099 frames in 5.0 seconds = 1019.683 FPS
5362 frames in 5.0 seconds = 1072.320 FPS
4459 frames in 5.0 seconds = 891.770 FPS
5334 frames in 5.0 seconds = 1066.768 FPS
5370 frames in 5.0 seconds = 1073.874 FPS
5360 frames in 5.0 seconds = 1071.894 FPS
^C
amigo1@Amigaone:~$



Hi Amigo1,

Thank you for your reply. These are fantastic glxgears values for a Radeon HD5450. :-) Have you already tested the unofficial Mesa because of your VLC problem?

Cheers,

Christian
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.
User avatar
xeno74
 
Posts: 3013
Joined: Fri Mar 23, 2012 8:58 am

Re: (X)(L)ubuntu (MATE) 16.04 LTS

Postby xeno74 » Thu May 05, 2016 2:46 pm

papaoskar wrote:Hi Christian,
first I have started ubuntu 12.04 and done the above commands on sdb8....
Then I started Mate_1604 from sdb8.
When I did "ls -l /usr/bin/su " the result now looks with the s bit set. (see picture ).
But still the "chown root:root /bin/su" tells me that I have a read-only filesystem.


Hi Papaoskar,

Thank you for your answer. With the following boot arguments, the kernel mounts the root file system with read and write support.

Code: Select all
setenv bootargs "root=/dev/sdb8 rw"


Please try it.

Thanks in advance,

Christian
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.
User avatar
xeno74
 
Posts: 3013
Joined: Fri Mar 23, 2012 8:58 am

Re: (X)(L)ubuntu (MATE) 16.04 LTS

Postby papaoskar » Thu May 05, 2016 4:32 pm

xeno74 wrote:Hi Papaoskar,

Thank you for your answer. With the following boot arguments, the kernel mounts the root file system with read and write support.

Code: Select all
setenv bootargs "root=/dev/sdb8 rw"


Please try it.

Thanks in advance,

Christian


Hi Christian,
the new bootargs argument did the trick! Currently the update and upgrade commands are at work. It takes its time. I tried the rw argument before but to no avail. Probably because I did not switch off long enough. Thanks so far.
papaoskar
 
Posts: 80
Joined: Tue Jul 01, 2014 2:48 pm

Re: (X)(L)ubuntu (MATE) 16.04 LTS

Postby xeno74 » Fri May 06, 2016 5:44 am

papaoskar wrote:Hi Christian,
the new bootargs argument did the trick! Currently the update and upgrade commands are at work. It takes its time. I tried the rw argument before but to no avail. Probably because I did not switch off long enough. Thanks so far.


Hi Papaoskar,

Great news! Did the update work?

Cheers,

Christian
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.
User avatar
xeno74
 
Posts: 3013
Joined: Fri Mar 23, 2012 8:58 am

Re: (X)(L)ubuntu (MATE) 16.04 LTS

Postby papaoskar » Fri May 06, 2016 11:33 am

xeno74 wrote:
Hi Papaoskar,

Great news! Did the update work?

Cheers,

Christian

Hi Christian,
The update was successful ! But now I have another problem. The system now boots into the login screen. It however does not accept the password. It keeps asking for a password again and again. Only as guest I can get a working desktop and use it.
sudo and su are equally not accepted. No way to get root permissions.
Switch to the console tty1 enables a login with root permissions. I tried a lot commands with no success. adduser or addgroup had no successs. Any hint?
Thank you so far!
papaoskar
 
Posts: 80
Joined: Tue Jul 01, 2014 2:48 pm

Re: (X)(L)ubuntu (MATE) 16.04 LTS

Postby xeno74 » Fri May 06, 2016 1:07 pm

papaoskar wrote:Hi Christian,
The update was successful ! But now I have another problem. The system now boots into the login screen. It however does not accept the password. It keeps asking for a password again and again. Only as guest I can get a working desktop and use it.
sudo and su are equally not accepted. No way to get root permissions.
Switch to the console tty1 enables a login with root permissions. I tried a lot commands with no success. adduser or addgroup had no successs. Any hint?
Thank you so far!


Hi Papaoskar,

Please boot your ubuntu MATE in the recovery mode with the following boot arguments:

Code: Select all
setenv bootargs "root=/dev/sdb8 ro single"


After that:

Code: Select all
mount -o remount,rw /


Then you can modify the amigaone password with

Code: Select all
passwd amigaone


Good luck!

Christian
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.
User avatar
xeno74
 
Posts: 3013
Joined: Fri Mar 23, 2012 8:58 am

Re: (X)(L)ubuntu (MATE) 16.04 LTS

Postby xeno74 » Fri May 06, 2016 2:01 pm

You can also delete the encrypted value in the file /etc/shadow after the user name on your ubuntu MATE 16.04 LTS partition (/dev/sdb8) with your booted Ubuntu 12.04.5 LTS. ;-) After that, you don't need a password for the user.
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.
User avatar
xeno74
 
Posts: 3013
Joined: Fri Mar 23, 2012 8:58 am

Re: (X)(L)ubuntu (MATE) 16.04 LTS

Postby papaoskar » Fri May 06, 2016 5:03 pm

xeno74 wrote:
Hi Papaoskar,

Please boot your ubuntu MATE in the recovery mode with the following boot arguments:

Code: Select all
setenv bootargs "root=/dev/sdb8 ro single"


After that:

Code: Select all
mount -o remount,rw /


Then you can modify the amigaone password with

Code: Select all
passwd amigaone


Good luck!

Christian


Hi Christian,
no luck. Could change the password but it still works only on the console. The graphical login screen of Mate does not connect to the user amigaone. Also a startx on the console does nothing.
BTW the command "mount -o remount,rw / " answered with the question of UUID= ... So I decided to use the device /dev/sdb8 instead of / . That was accepted and password changed. But again no success with login!
papaoskar
 
Posts: 80
Joined: Tue Jul 01, 2014 2:48 pm

Re: (X)(L)ubuntu (MATE) 16.04 LTS

Postby papaoskar » Fri May 06, 2016 6:07 pm

xeno74 wrote:You can also delete the encrypted value in the file /etc/shadow after the user name on your ubuntu MATE 16.04 LTS partition (/dev/sdb8) with your booted Ubuntu 12.04.5 LTS. ;-) After that, you don't need a password for the user.


Hi Christian,
that is the exact result: I don't need a password and can not login anymore. The password is not accepted. What now? Start from scratch with dd-ing the image and start all over ?
I think it will be the best.
papaoskar
 
Posts: 80
Joined: Tue Jul 01, 2014 2:48 pm

PreviousNext

Return to Platform: AmigaOne X1000 - Linux Only

Who is online

Users browsing this forum: Bing [Bot] and 4 guests