First time X1000 Linux user

AmigaOne X1000 platform specific issues related to Linux only.

Re: First time X1000 Linux user

Postby ddni » Sun Jan 24, 2016 1:04 am

Yeah. User error and unrestrained installing ... ;)
I have cleaned up now.
User avatar
ddni
 
Posts: 229
Joined: Sat Dec 03, 2011 12:06 am

Re: First time X1000 Linux user

Postby ddni » Mon Jan 25, 2016 9:43 pm

How should multiple kernels be stored on a USB or cf card? Is it best to create a bespoke folder for each kernel and alter the CFE command to point to the desired folder?
User avatar
ddni
 
Posts: 229
Joined: Sat Dec 03, 2011 12:06 am

Re: First time X1000 Linux user

Postby mechanic » Mon Jan 25, 2016 10:11 pm

I usually rename each kernel before copying to usb/cfcard. For example, I may have 2 or 3 4.4.x kernels and I'll just name them linux-4.4rc1, linux-4.4rc2 or if I build my own something like linux4.4LK3, or linux-4.4mint5 or linux-4.4DEB2. Since I run up to 3 distros on the same machine I only have to know which kernel goes to what distro.

One of these days I'll get a single kernel for everything, and then hell will freeze over. :shock:

CFE just reads in the file by name, any linux reference does not really matter to CFE. You could name it BART_SIMPSON if you want. ;)

To change the name it might display in a screensaver you would have to build your own kernel.
A-Eon A1X1000
User avatar
mechanic
 
Posts: 481
Joined: Sat Jun 25, 2011 10:22 pm

Re: First time X1000 Linux user

Postby ddni » Mon Jan 25, 2016 10:32 pm

Thanks all seems to work ok by dropping the whole kernel in it's own folder ie 4.5rc1 and 4.1.16
User avatar
ddni
 
Posts: 229
Joined: Sat Dec 03, 2011 12:06 am

Re: First time X1000 Linux user

Postby xeno74 » Tue Jan 26, 2016 9:18 am

ddni wrote:Thanks all seems to work ok by dropping the whole kernel in it's own folder ie 4.5rc1 and 4.1.16


Excellent work! Well done! :-)
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.
User avatar
xeno74
 
Posts: 3005
Joined: Fri Mar 23, 2012 8:58 am

Re: First time X1000 Linux user

Postby ddni » Wed Jan 27, 2016 11:55 pm

xeno74 wrote:Hi ddni,

Unfortunately I didn't know that you have a R9 270x installed in your A1-X1000. This graphics card doesn't have hardware 3D acceleration on Linux PPC currently. You could try to install an additional graphics card like the cheap HD5450 for hardware 3D acceleration.

Sorry.

A cheap Sapphire Radeon HD5450 for $36.40:

Cheers,

Christian


What is the situation with Linux and HW acceleration on the X5000 boards? Won't they ship with a Southern Islands compatible card for W3D in AmigaOS, a graphics card that is not supported by Linux?
User avatar
ddni
 
Posts: 229
Joined: Sat Dec 03, 2011 12:06 am

Previous

Return to Platform: AmigaOne X1000 - Linux Only

Who is online

Users browsing this forum: No registered users and 4 guests