Kernel 4.6

AmigaOne X1000 platform specific issues related to Linux only.

Re: Kernel 4.6

Postby Srtest » Fri Apr 15, 2016 3:45 pm

RC3 Works well and boots fast on Ubuntu-LXQt here.
User avatar
Srtest
 
Posts: 240
Joined: Wed Jun 11, 2014 6:06 pm

Re: Kernel 4.6

Postby xeno74 » Fri Apr 15, 2016 4:06 pm

Srtest wrote:RC3 Works well and boots fast on Ubuntu-LXQt here.


Thanks for testing! :-)
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.
User avatar
xeno74
 
Posts: 4118
Joined: Fri Mar 23, 2012 8:58 am

Re: Kernel 4.6

Postby xeno74 » Fri Apr 15, 2016 11:36 pm

We have tested the cross compiled RC3 with the following hardware:

Radeon HD6670: (John): works with hardware 3D acceleration
Radeon HD4650 (Nigel): works with hardware 3D acceleration
Radeon R7 250X (John): works without hardware 3D acceleration
Radeon R9-270 (Srtest): works without hardware 3D acceleration

We have tested the following Linux distributions:

Ubuntu 12.04.5 (John): works
ubuntu MATE 16.04 (John and Nigel): works
Lubuntu/LXQt 16.04 (Srtest): works

Please test the P.A. Semi Ethernet with the cross compiled RC3. I don't know if the P.A. Semi Ethernet works with the RC3.
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.
User avatar
xeno74
 
Posts: 4118
Joined: Fri Mar 23, 2012 8:58 am

Re: Kernel 4.6

Postby xeno74 » Mon Apr 18, 2016 5:28 pm

http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.
User avatar
xeno74
 
Posts: 4118
Joined: Fri Mar 23, 2012 8:58 am

Re: Kernel 4.6

Postby xeno74 » Tue Apr 19, 2016 1:10 pm



Hi All,

Could you please test the RC4? I'd like to know if it boots. I cross compiled the RC4 on a Ubuntu server 14.04 x86_64 so I don't know if it works.

Thanks in advance,

Christian
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.
User avatar
xeno74
 
Posts: 4118
Joined: Fri Mar 23, 2012 8:58 am

Re: Kernel 4.6

Postby elginseam » Tue Apr 19, 2016 10:44 pm

RC4 works fine with Ubuntu 16.04 LTS MATE.
glxgears average 6598 frames in 5.0 seconds = 1319.6 FPS
The P.A. Semi Ethernet interface works also.

Nigel
A1000; A1200; A1500; Sam440ep 667MHz OS4.1; AmigaOne X1000
User avatar
elginseam
 
Posts: 12
Joined: Sun Sep 04, 2011 9:54 am
Location: London

Re: Kernel 4.6

Postby xeno74 » Wed Apr 20, 2016 6:16 am

elginseam wrote:RC4 works fine with Ubuntu 16.04 LTS MATE.
glxgears average 6598 frames in 5.0 seconds = 1319.6 FPS
The P.A. Semi Ethernet interface works also.

Nigel


Many thanks for testing!
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.
User avatar
xeno74
 
Posts: 4118
Joined: Fri Mar 23, 2012 8:58 am


Re: Kernel 4.6

Postby jdupuis » Wed Apr 27, 2016 1:39 am

Hi Christian,

Tested 4.6 rc5. X1000, 6670 HD and PA Semi Ethernet. The list of parses at kernel first boot (expected). Ubuntu Mate 16.04 (New Release) boots up fine. GlxGears - 300 frames in 5.0 seconds = 59.907 FPS average (still slow) :| That's okay, used to it with Ubuntu Mate on my system GlxGears are the same with 4.1.20. YouTube video and audio good in Low Definition MP4/SD no Ad playback on opening Youube screen. Can't go fullscreen video with YouTube in Mate on my system with Kernel 4.1.20 or this one (expected). PA Semi Ethernet - Good. File System seems to run well in Ubuntu Mate 16.04 (New Release) with 4.6 rc5.

Now Ubuntu 12.04.05 LTS
4.6 rc5 booted up just as above and Ubuntu 12.04.05 LTS booted right up. :)
GlxGears 5642 frames in 5.0 seconds = 1128.390 average. :) YouTube Video and Audio good in High Definition MP4/HD. Ads played back on opening YouTube screen. Fullscreen video playback smooth with no artifacts. PA Semi Ethernet - Good. Filesystem okay but that's the 12.04 way.

Wish I had time to test the R7 250X but I am not able to due to a temporary work schedule change this week. Have a feeling the R7 250X would boot, though. I would not anticipate seeing much different results than aforementioned.
<edit>
Extra Notes: Just after copying Mate disk image. I created my Admin account, deleted AmigaOne User account/files, established my own DNS Server name in Networks and set up Language. Then deleted the Sam partition. Created an Extended Swap partition 4096 at the end and then expanded the Ext4 partition. Used Software Updater to do the Partial Upgrade. Ubuntu Mate 16.04 runs quite well and stable like this.

Cheers!!

John
C= A500 2 megs RAM with A590 w/40 MB SCSI HD and Workbench 1.3
C= A3000 25 MHz with Workbench 3.1
AmigaOne X1000 4 GB RAM, XFX Radeon HD 6670 1GB GDDR5 GPU and AmigaOS 4.1 FE/Ubuntu 12.04.5 LTS/Ubuntu Mate 16.04 LTS
Sam460ex 2GB DDR2 800 MHz RAM, XFX Radeon HD 5450 2GB GDDR3 GPU, 3114 SATA Raid, ENVY24HT sound card and AmigaOS 4.1 FE
User avatar
jdupuis
 
Posts: 223
Joined: Sat May 09, 2015 8:19 am
Location: Baton Rouge, Louisiana USA

Re: Kernel 4.6

Postby xeno74 » Wed Apr 27, 2016 6:01 am

John,

Many thanks for testing! :-) It's good to know that it works. :-)

Cheers,

Christian
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.
User avatar
xeno74
 
Posts: 4118
Joined: Fri Mar 23, 2012 8:58 am

PreviousNext

Return to Platform: AmigaOne X1000 - Linux Only

Who is online

Users browsing this forum: No registered users and 8 guests