(X)(L)ubuntu (MATE) 16.10 Yakkety Yak

AmigaOne X1000 platform specific issues related to Linux only.

(X)(L)ubuntu (MATE) 16.10 Yakkety Yak

Postby xeno74 » Wed May 11, 2016 10:17 am

Image

I successfully updated my ubuntu MATE 16.04 LTS to 16.10 Yakkety Yak today. :-) I want to start some testing.


Update instructions for (X)(L)ubuntu (MATE):

  1. CTRL+ALT+F1 to change to the console login on (X)(L)ubuntu (MATE) 16.04 LTS.
  2. Login as user
  3. Change your user to the root user with
    Code: Select all
    sudo su
  4. Stop X11 with
    Code: Select all
    service lightdm stop
  5. Update the package index of your old 16.04 LTS system:
    Code: Select all
    apt-get update
  6. Upgrade your packages to the latest packages on your old 16.04 LTS system:
    Code: Select all
    apt-get upgrade
  7. Remove those dependencies that were installed with applications and that are no longer used by anything else on the system:
    Code: Select all
    apt-get autoremove
  8. Remove .deb files for packages that are no longer installed on your system:
    Code: Select all
    apt-get autoclean
  9. Update your repositories to the new 16.10 repositories
    Code: Select all
    sed -i 's/xenial/yakkety/g' /etc/apt/sources.list
  10. Update the package index of the new 16.10 system:
    Code: Select all
    apt-get update
  11. Upgrade your 16.04 LTS system to version 16.10 Yakkety Yak:
    Code: Select all
    apt-get dist-upgrade
  12. Reboot your AmigaONE X1000 with
    Code: Select all
    reboot
  13. Login in your new 16.10 Yakkety Yak system.
  14. Tidy up with the terminal. :D
    Code: Select all
    sudo apt-get autoremove
    Code: Select all
    sudo apt-get autoclean
    Code: Select all
    sudo apt-get clean
  15. Reboot your AmigaONE X1000 and enter the firmware. If you have autoboot set up, press CTRL-C. If you have the latest menu-enabled firmware, press the F key to enter the firmware. In any case, you should end up on the firmware's command prompt which looks like this:
    Code: Select all
    CFE>
  16. Rename the old 16.04 CFE boot entry to the new version 16.10 for example:
    Code: Select all
    CFE> setenv -p MENU_3_LABEL "ubuntu MATE 16.10 Kernel 4.6"
  17. To activate the new Boot Menu type menu and use the arrow keys to select and highlight 3: ubuntu MATE 16.10 Kernel 4.6 before the timer bar runs down.

Issues

I haven't found any issues. It works very well! :-)

Tests

  • Xorg 1.18.3 works
  • Hardware 3D acceleration works without any problems with the official Mesa 11.2.1 (Gallium 0.4 on AMD BARTS DRM 2.42.0)
  • Compiz works
  • YouTube HD videos work with ViewTube in fullscreen!!!!!! (High Definition MP4 VLC HD MP4)
  • Sound works
  • Network works

Screenshot:

Image

PLEASE test the new version 16.10.
Last edited by xeno74 on Tue Dec 27, 2016 10:42 am, edited 1 time in total.
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.
User avatar
xeno74
 
Posts: 3169
Joined: Fri Mar 23, 2012 8:58 am

Re: (X)(L)ubuntu (MATE) 16.10 Yakkety Yak

Postby xeno74 » Wed May 11, 2016 12:29 pm

There was a small update to DRM 2.43.0. (see screenshot)

-- Christian
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.
User avatar
xeno74
 
Posts: 3169
Joined: Fri Mar 23, 2012 8:58 am

Re: (X)(L)ubuntu (MATE) 16.10 Yakkety Yak

Postby elginseam » Sat May 14, 2016 10:41 am

Thanks for the detailed instructions. I have tried the update and all seems good.
The only thing I have noticed is the welcome screen - software boutique does not find any compatible software.
Nigel
A1000; A1200; A1500; Sam440ep 667MHz OS4.1; AmigaOne X1000
User avatar
elginseam
 
Posts: 12
Joined: Sun Sep 04, 2011 9:54 am
Location: London

Re: (X)(L)ubuntu (MATE) 16.10 Yakkety Yak

Postby xeno74 » Sun May 15, 2016 9:29 pm

elginseam wrote:Thanks for the detailed instructions. I have tried the update and all seems good.
The only thing I have noticed is the welcome screen - software boutique does not find any compatible software.
Nigel


Many thanks for testing! I will test the software boutique too.
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.
User avatar
xeno74
 
Posts: 3169
Joined: Fri Mar 23, 2012 8:58 am

Re: (X)(L)ubuntu (MATE) 16.10 Yakkety Yak

Postby xeno74 » Wed Jul 06, 2016 5:41 pm

"Welcome" doesn't work on my ubuntu MATE 16.10 PowerPC. Any hints?

Image
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.
User avatar
xeno74
 
Posts: 3169
Joined: Fri Mar 23, 2012 8:58 am

Re: (X)(L)ubuntu (MATE) 16.10 Yakkety Yak

Postby kilaueabart » Fri Jul 08, 2016 6:35 am

I only dared try because I have two working MATEs. I replaced the one on the SSD, and all seemed to go well, except when I logged on, I got an error message.

I tried launching some things, such as the editor, but it didn't come up. I was able to launch Firefox and get on this page, but then it occurred to me my problem might be that I hadn't done step 14 ("Tidy up ...") yet, so I closed Firefox and tried to get a terminal, without success. Tried to find Firefox again, and not success there, either. I am currently in Midori, but I wonder if I am wasting my time trying to post to this group.

Welcome is one of the things that doesn't come up. I'm thinking I might try Ctrl^Alt^F1 (F2?) and see what apt-get might do for me.
User avatar
kilaueabart
 
Posts: 434
Joined: Mon Mar 05, 2012 3:36 am

Re: (X)(L)ubuntu (MATE) 16.10 Yakkety Yak

Postby kilaueabart » Fri Jul 08, 2016 9:32 am

kilaueabart wrote:Welcome is one of the things that doesn't come up. I'm thinking I might try Ctrl^Alt^F1 (F2?) and see what apt-get might do for me.

And so I did. Started by using that CLI to take care of upgrade step 14. Instead of removing anything, "sudo apt-get autoremove" installed a bunch of stuff! But I followed up with "... autoclean" and "... clean" and rebooted.

This time I was able to open a terminal. I went ahead with "sudo apt-get update / upgrade" again, just in case, and was surprised to see what looked like a repeat of the result of Christian's step 11. It seemed a little faster this time, surely less than an hour, but again finishing with a long download of SuperTuxKart stuff near the end. Some messages, such as "Errors were encountered while processing: /var/cache/apt/archives/hexchat-plugins_2.12.0-2ubuntu2_powerpc.deb."

Rebooted, and was able to launch Firefox from the icon, except that I couldn't go online with it. This time Midori didn't work either. It turned out I didn't have a connection to the internet, and I had no idea how to get one. A bunch of "Crash report (as superuser)." "Sorry, a problem occurred while installing software. Package: man-db 2.7.5-1" and "Package: bamfdaemon 0.5.3-bzr0+16.10.2016705-0ubuntu1" and "Package: fontconfig 2.11.94-0ubuntu1" among them. "Welcome" opened an empty window this time.

I guess I will reformat that partition and copy this working version of 12.04 to it again. This one works OK, but it boots very slowly compared to the one on the SSD that I tried to upgrade to Yakkety-Yak tonight. If I do get 12.04 working on the SSD again, maybe I'll try turning this one into 12.10.
User avatar
kilaueabart
 
Posts: 434
Joined: Mon Mar 05, 2012 3:36 am

Re: (X)(L)ubuntu (MATE) 16.10 Yakkety Yak

Postby kilaueabart » Sun Jul 10, 2016 4:05 am

kilaueabart wrote:I guess I will reformat that partition and copy this working version of 12.04 to it again. This one works OK, but it boots very slowly compared to the one on the SSD that I tried to upgrade to Yakkety-Yak tonight. If I do get 12.04 working on the SSD again, maybe I'll try turning this one into 12.10.
And so I did. Except I meant 16.04, not 12.04, in both cases. Good old Xenial Xerus seems to be working fine on the SSD again, so I tried upgrading my rotating HD's to Yakkety-Yak. Step 11, apt-get dist-upgrade took about 45 minutes downloading, but what seemed all too soon in the following processing stage progress reports were interrupted by many pages of this, repeated over and over:
Code: Select all
dpkg: error processing bamfdaemon (--configure):
  dependency problems - leaving triggers unprocessed
dpkg: dependency problems prevent processing triggers for bamfdaemon:
  bamfdaemon depends on libgdk-pixbuf2.0-0 (>= 2.22-0); however:
     Package  libgdk-pixbuf2.0-0:powerpc is not configured yet.
  bamfdaemon depends on libgtk-3-0 (>= 3.7.10); however:
     Package  libgtk-3-0:powerpc is not configured yet.
  bamfdaemon depends on libgtop-2.0-10 (>= 2.22-3); however:
     Package  libgtop-2.0-10:powerpc is not configured yet.
  bamfdaemon depends on libwnc-3-0 (>= 3.4.7); however:
     Package  libwnc-3-0:powerpc is not configured yet.
  bamfdaemon depends on libx11-6; however:
     Package  libx11-6:powerpc is not configured yet.
Rebooted and launched it anyway. Seemed to come up OK, EXCEPT: No internet icon, screen black. "Program(?) Error" message came up. I went ahead and clicked "Report it."

These results were far WORSE than my first attempt, when I upgraded the SSD install of 16.04. Initially, I was able to get on-line from that one, and even posted to this forum from it, although I soon lost my internet connection. With the new one, all I could do was quit, by clicking the empty upper right corner. Even that didn't work at first; I reportedly had left caja running. I'm not sure what caja is, but suspect I started it with my report-error request.

I got the idea of launching the new install again and seeing what I could do from the console login. The console must have had an internet connection? It informed me that I had 484 updates (0 security updates) available. I checked whether libgtop was in the list. It wasn't, but I "apt-get upgrade"ed anyway. And all that got me was a repeat of those pages of repeated bamfdaemon errors.

Help! Does anyone know how to configure the packages and process bamfdaemon?
User avatar
kilaueabart
 
Posts: 434
Joined: Mon Mar 05, 2012 3:36 am

Re: (X)(L)ubuntu (MATE) 16.10 Yakkety Yak

Postby xeno74 » Mon Jul 11, 2016 2:49 pm

xeno74 wrote:"Welcome" doesn't work on my ubuntu MATE 16.10 PowerPC. Any hints?

Image


Unfortunately, there are currently problems with the WebKit2 library under PowerPC. This problem also affects Ubiquity, the installer slide show, which is also blank.

Bug reports:

http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.
User avatar
xeno74
 
Posts: 3169
Joined: Fri Mar 23, 2012 8:58 am

Re: (X)(L)ubuntu (MATE) 16.10 Yakkety Yak

Postby kilaueabart » Mon Jul 18, 2016 2:37 am

xeno74 wrote:
xeno74 wrote:"Welcome" doesn't work on my ubuntu MATE 16.10 PowerPC. Any hints?
I had reached the point where I ended up with a black screen, a bar across the top with "Applications Places System" on the left, and date and time only, I think, on the right. No power icon, but clicking in the upper right corner where it should be allowed me to reboot. No "Welcome" at all, although my first run after installing had brought up a blank one.

Private email suggested I try (from console) apt-get clean, service lightdm stop, dist-upgrade, then reboot and run apt-get autoclean, apt-get autoremove. So I did, and when I rebooted, I was astonished to get a fully functional "Welcome"!

I noticed a place to click in order to keep "Welcome" up-to-date, so I clicked and all of a sudden things were being downloaded and installed again! Meanwhile there was a notice that "Welcome" would soon restart. When the processing was finally finished, that window and Welcome's closed, then Welcome re-opened, blank!

Ain't compooters fun?

I'm posting this from Yaketty Yak anyway, and will then reboot to the safer 16.04. I expect, from experience, that when I click "Reboot" (the power icon is there now that I have an almost normal screen) it will initially refuse because "caja" is still running.
User avatar
kilaueabart
 
Posts: 434
Joined: Mon Mar 05, 2012 3:36 am

Next

Return to Platform: AmigaOne X1000 - Linux Only

Who is online

Users browsing this forum: No registered users and 4 guests