color problem (pictures added)

AmigaOne X1000 platform specific issues related to Linux only.

color problem (pictures added)

Postby kilaueabart » Thu May 26, 2016 5:47 am

I was in System > Printers to try to set print paper size in MATE 16.04 last night, and gave in to the impulse to print a test page.

Astonishment and delight! It came out the way it should, no smearing or blurring of colors! As I complained just over two years ago, printing anything in color from Ubuntu 12.04 resulted in really messed up colors. Black and white would often come out fine, but even that would sometimes get pink or yellow smearing. Christian gave me a lot of advice how to fix it, but I never succeeded in making it work, so I was really happy to see that apparently MATE had fixed it automatically.

This morning I tried printing a screen save I had made sometime back, with high hopes. Hopes dashed; it came out with colors blurred.

I tried the printer test page again, and again it was perfect!

With 12.04 when I would go to printer configuration, I would be given the option of selecting printer brand and model, and then choosing the closest printer driver available. It was never specifically for my HP Officejet 6700. Now in MATE, my printer is already there, and no simple way to change it. I could delete it, or change the Properties if I had reason to. But now, according to some /etc/cups files as well as annotation on the Printer test page, I seem to have a proper hp-officejet_6700.ppd, Driver Version (hpcups) 3.16.3. So I wonder what is still wrong?

Just in case people can't picture the problem, I will add two pictures.

printertest.jpg
This is the new way "Print Test Page" comes out.
badprint.jpg
And this is how printing that jpeg comes out



This is why it was so important that I could copy to and from a flash drive with MATE (for a while I could not). I need to copy screen saves and documents made with Scribus over to AOS 4.1FE for printing. Drat!
User avatar
kilaueabart
 
Posts: 521
Joined: Mon Mar 05, 2012 3:36 am

Re: color problem (pictures added)

Postby tonyw » Fri May 27, 2016 12:44 am

It looks like your ink is running. Have you tried it with dry paper? ;)
cheers
tony
User avatar
tonyw
AmigaOS Core Developer
AmigaOS Core Developer
 
Posts: 1313
Joined: Wed Mar 09, 2011 2:36 pm
Location: Sydney, Australia

Re: color problem (pictures added)

Postby kilaueabart » Sat May 28, 2016 2:52 am

tonyw wrote:It looks like your ink is running. Have you tried it with dry paper? ;)

Glad you can see the humor in it.

In case you were serious, it's the same paper for the printer test and the jpeg print. The printer test comes out like the top picture every time, while printing any open document or picture by clicking "Print" in a menu comes out like the lower picture. Sometimes even black and white text does.

Never happens on the AOS4.1FE side. And it almost looks like the printer test and the print document/picture functions address different printer configurations, but I can't figure out how that would happen.
User avatar
kilaueabart
 
Posts: 521
Joined: Mon Mar 05, 2012 3:36 am

Re: color problem (pictures added)

Postby tonyw » Sat May 28, 2016 11:25 am

Is that using Postscript or some other protocol?
cheers
tony
User avatar
tonyw
AmigaOS Core Developer
AmigaOS Core Developer
 
Posts: 1313
Joined: Wed Mar 09, 2011 2:36 pm
Location: Sydney, Australia

Re: color problem (pictures added)

Postby kilaueabart » Sat May 28, 2016 11:29 pm

My printer doesn't handle Postscript. I don't know if some other special protocol is involved. Would it be different for Print Test Page versus Ctrl^P on a jpeg, .png, PDF, etc.?

MATE quit working last night, and I had to go back to Ubuntu 12.04. Checked Print Test Page there. The results weren't nearly as bad as my jpeg sample above, but still unsatisfactory.

Interesting differences in test page info. Items before the "/" below are from 12.04, after the slash, 16.04 (MATE).

Job ID: printer-3 / Officejet-6700-17
Driver: hp-officejet_6500_e709n.ppd / hp-officejet_6700.ppd
Driver Version: [blank] / 3.16.3
Printer Location: [this line missing] / Amigaone
Make and Model: HP Officejet 6500 e709n, hpcups 3.12.2 / HP Officejet 6700, hpcups 3.16.3

That "6500" bit is the best that printer configuration offers me from 12.04, for some reason.
User avatar
kilaueabart
 
Posts: 521
Joined: Mon Mar 05, 2012 3:36 am


Return to Platform: AmigaOne X1000 - Linux Only

Who is online

Users browsing this forum: No registered users and 2 guests