ubuntu MATE 16.04.1 Live DVD

AmigaOne X1000 platform specific issues related to Linux only.

Re: ubuntu MATE 16.04.1 Live DVD

Postby AlfredOne » Sat Nov 19, 2016 5:05 pm

xeno74 wrote:
AlfredOne wrote:I tried both cases: with using OS4.1 before and without using OS4.1 before. Same behaviour.

I think it's a problem with my DVD sata drive and Nemo board.
I copied the "powerpc64" directory from live DVD to the CompactFlash and booted successfully from there.
So it seems that Linux and OS4.1 can read from DVD but initrd and vmlinux can not be loaded easily.


Hi AlfredOne,

Good to know. Many thanks for testing!

Have a lot of fun with the live DVD. Would you like to install it?

Cheers,
Christian


Installed with the alternative script on HD.
Booted from HD.
Well done!
Amiga500 Kickstart1.3
AmigaONE XE G4 833MHz - 2GB RAM - Radeon9200 256MB
AmigaONE X1000 - 2GB RAM - Radeon R9-280X 3GB + Radeon HIS4670 1GB DDR3 - AmigaOS4.1
My site: http://project4a.webs.com
User avatar
AlfredOne
Beta Tester
Beta Tester
 
Posts: 112
Joined: Thu Dec 23, 2010 12:45 am
Location: Rome , Italy

Re: ubuntu MATE 16.04.1 Live DVD

Postby xeno74 » Sat Nov 19, 2016 5:31 pm

AlfredOne wrote:Installed with the alternative script on HD.
Booted from HD.
Well done!


Hi AlfredOne,

Fantastic! Well done! :-) Which graphics card is installed in your AmigaOne X1000? Radeon R9-280X 3GB or Radeon HIS4670 or even both?

Thanks,
Christian
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.
User avatar
xeno74
 
Posts: 3005
Joined: Fri Mar 23, 2012 8:58 am

Re: ubuntu MATE 16.04.1 Live DVD

Postby xeno74 » Sat Nov 19, 2016 6:26 pm

Srtest wrote:Had to give up on the installation. It started okay (or so I thought) and then it became extremely slow when it reached the Libreoffice files. It seemed to go on forever so I had to stop it.


Hi Srtest,

Sorry for the late answer. Maybe you typed the incorrect partition device or you typed it in a wrong format in the installer.

The correct format is: /dev/<your partition>

For example: /dev/sdb2

Cheers,
Christian
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.
User avatar
xeno74
 
Posts: 3005
Joined: Fri Mar 23, 2012 8:58 am

Re: ubuntu MATE 16.04.1 Live DVD

Postby Srtest » Sat Nov 19, 2016 11:38 pm

xeno74 wrote:
Srtest wrote:Had to give up on the installation. It started okay (or so I thought) and then it became extremely slow when it reached the Libreoffice files. It seemed to go on forever so I had to stop it.


Hi Srtest,

Sorry for the late answer. Maybe you typed the incorrect partition device or you typed it in a wrong format in the installer.

The correct format is: /dev/<your partition>

For example: /dev/sdb2

Cheers,
Christian


That is what I did. It started okay and then started to have difficulties copying or maybe setting-up files when the installation arrived to the Libreoffice files. After I rebooted I saw it had managed to copy quite a lot before I stopped it, yet installing an os for hours and hours occupying the X1k is unacceptable for me.
User avatar
Srtest
 
Posts: 240
Joined: Wed Jun 11, 2014 6:06 pm

Re: ubuntu MATE 16.04.1 Live DVD

Postby AlfredOne » Thu Nov 24, 2016 1:26 am

xeno74 wrote:
AlfredOne wrote:Installed with the alternative script on HD.
Booted from HD.
Well done!


Hi AlfredOne,

Fantastic! Well done! :-) Which graphics card is installed in your AmigaOne X1000? Radeon R9-280X 3GB or Radeon HIS4670 or even both?

Thanks,
Christian


Both graphics card installed:
1st PCI-e slot: Radeon HIS4670
2nd PCI-e slot: Radeon R9-280X
Boot starts with HIS4670, then switches to R9-280X during Linux start-up.
Amiga500 Kickstart1.3
AmigaONE XE G4 833MHz - 2GB RAM - Radeon9200 256MB
AmigaONE X1000 - 2GB RAM - Radeon R9-280X 3GB + Radeon HIS4670 1GB DDR3 - AmigaOS4.1
My site: http://project4a.webs.com
User avatar
AlfredOne
Beta Tester
Beta Tester
 
Posts: 112
Joined: Thu Dec 23, 2010 12:45 am
Location: Rome , Italy

Re: ubuntu MATE 16.04.1 Live DVD

Postby xeno74 » Thu Nov 24, 2016 11:51 am

AlfredOne wrote:Both graphics card installed:
1st PCI-e slot: Radeon HIS4670
2nd PCI-e slot: Radeon R9-280X
Boot starts with HIS4670, then switches to R9-280X during Linux start-up.


Hi AlfredOne,

Thank you for testing! :-) It's really great that you have a SI and a NI Radeon installed. Maybe you could modify the xorg.conf to get hardware 3D acceleration with
the 4670. If it works then you have hardware 3D acceleration on OS4.1 and on Linux. ;-) What do you think?
Could you please post your xorg.conf?

Thanks,
Christian
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.
User avatar
xeno74
 
Posts: 3005
Joined: Fri Mar 23, 2012 8:58 am

Re: ubuntu MATE 16.04.1 Live DVD

Postby xeno74 » Thu Nov 24, 2016 12:01 pm

Please note: We use the fbdev video driver so it works with SI graphics cards too. If you have a NI graphics card and you want enable hardware 3D acceleration, please replace the fbdev video driver with the radeon driver in the xorg.conf.
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.
User avatar
xeno74
 
Posts: 3005
Joined: Fri Mar 23, 2012 8:58 am

Re: ubuntu MATE 16.04.1 Live DVD

Postby xeno74 » Thu Nov 24, 2016 1:07 pm

xeno74 wrote:
AlfredOne wrote:Both graphics card installed:
1st PCI-e slot: Radeon HIS4670
2nd PCI-e slot: Radeon R9-280X
Boot starts with HIS4670, then switches to R9-280X during Linux start-up.


Hi AlfredOne,

Thank you for testing! :-) It's really great that you have a SI and a NI Radeon installed. Maybe you could modify the xorg.conf to get hardware 3D acceleration with
the 4670. If it works then you have hardware 3D acceleration on OS4.1 and on Linux. ;-) What do you think?
Could you please post your xorg.conf?

Thanks,
Christian


AlfredOne,

You need a xorg.conf for two graphics cards. Please create one with:

  1. Code: Select all
    Ctrl + Alt + F1
  2. Code: Select all
    sudo service lightdm stop
  3. Code: Select all
    sudo Xorg -configure

Please post this xorg.conf.

Thanks,
Christian
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.
User avatar
xeno74
 
Posts: 3005
Joined: Fri Mar 23, 2012 8:58 am

Re: ubuntu MATE 16.04.1 Live DVD

Postby AlfredOne » Sun Dec 04, 2016 12:59 pm

xeno74 wrote:
xeno74 wrote:
AlfredOne wrote:Both graphics card installed:
1st PCI-e slot: Radeon HIS4670
2nd PCI-e slot: Radeon R9-280X
Boot starts with HIS4670, then switches to R9-280X during Linux start-up.


Hi AlfredOne,

Thank you for testing! :-) It's really great that you have a SI and a NI Radeon installed. Maybe you could modify the xorg.conf to get hardware 3D acceleration with
the 4670. If it works then you have hardware 3D acceleration on OS4.1 and on Linux. ;-) What do you think?
Could you please post your xorg.conf?

Thanks,
Christian


AlfredOne,

You need a xorg.conf for two graphics cards. Please create one with:

  1. Code: Select all
    Ctrl + Alt + F1
  2. Code: Select all
    sudo service lightdm stop
  3. Code: Select all
    sudo Xorg -configure

Please post this xorg.conf.

Thanks,
Christian


The command failed and generated the attached log file:
Xorg.0.log.tar.gz
"Xorg -configure" log file
(3.91 KiB) Downloaded 19 times
Amiga500 Kickstart1.3
AmigaONE XE G4 833MHz - 2GB RAM - Radeon9200 256MB
AmigaONE X1000 - 2GB RAM - Radeon R9-280X 3GB + Radeon HIS4670 1GB DDR3 - AmigaOS4.1
My site: http://project4a.webs.com
User avatar
AlfredOne
Beta Tester
Beta Tester
 
Posts: 112
Joined: Thu Dec 23, 2010 12:45 am
Location: Rome , Italy

Re: ubuntu MATE 16.04.1 Live DVD

Postby xeno74 » Sun Dec 04, 2016 3:19 pm

AlfredOne wrote:Both graphics card installed:
1st PCI-e slot: Radeon HIS4670
2nd PCI-e slot: Radeon R9-280X
Boot starts with HIS4670, then switches to R9-280X during Linux start-up.

The command failed and generated the attached log file:
Xorg.0.log.tar.gz


Hi AlfredOne,

Thank you for posting the Xorg.0.log. Could you please post the output of the command lspci -vv?

Thanks,
Christian
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.
User avatar
xeno74
 
Posts: 3005
Joined: Fri Mar 23, 2012 8:58 am

PreviousNext

Return to Platform: AmigaOne X1000 - Linux Only

Who is online

Users browsing this forum: No registered users and 3 guests