Kernel 4.16

AmigaOne X1000 platform specific issues related to Linux only.

Re: Kernel 4.16

Postby xeno74 » Sun Apr 29, 2018 5:42 pm

The stable kernel 4.16.5 is available for the X5000 and X1000.

Download: vmlinux-4.16.5-AmigaOne_X1000_X5000.tar.gz

Image
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.
User avatar
xeno74
 
Posts: 3730
Joined: Fri Mar 23, 2012 8:58 am

Re: Kernel 4.16

Postby xeno74 » Tue May 01, 2018 10:32 pm

Hi All,

I released the stable kernel 4.16.6 for the X5000 and X1000 today.

Download: vmlinux-4.16.6-AmigaOne_X1000_X5000.tar.gz

Image

Cheers,
Christian
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.
User avatar
xeno74
 
Posts: 3730
Joined: Fri Mar 23, 2012 8:58 am

Re: Kernel 4.16

Postby xeno74 » Wed May 02, 2018 6:17 am

Hi All,

I cross compiled the stable kernel 4.16.6 yesterday and I don’t know if it works on your X1000. Could you please test it?

Thanks,
Christian
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.
User avatar
xeno74
 
Posts: 3730
Joined: Fri Mar 23, 2012 8:58 am

Re: Kernel 4.16

Postby tbreeden » Thu May 03, 2018 4:32 am

Re: Kernel 4.16
I cross compiled the stable kernel 4.16.6 yesterday and I don’t know if it works on your X1000. Could you please test it?


4.16.6 works quite well on my X1000.
Screenshot from 2018-05-02 22-17-09.png


Havn't been able to spend much time on my Amiga lately, since I've been
trying to set up an acceptable Win10 on my wife's new PC.

MS has certainly ruined the Win experience with Win10. OS is nothing
but a vehicle for pushing ads and apps down from "Microsoft Store"
and continually nagging one to use Edge. Should have stuck with Win7.

I'm very tempted to install Ubuntu, except that all of her friends
are using Win10. Maybe buy a second disk and/or try setting up
a virtual machine for Linux. Any comments for me on that?

Thanks,

tom
User avatar
tbreeden
 
Posts: 120
Joined: Sat Jun 18, 2011 1:57 am
Location: Charlottesville, VA, USA

Re: Kernel 4.16

Postby xeno74 » Thu May 03, 2018 6:15 am

tbreeden wrote:4.16.6 works quite well on my X1000.


Thanks a lot for testing! It's good to know that it works on the X1000.

tbreeden wrote:Havn't been able to spend much time on my Amiga lately, since I've been
trying to set up an acceptable Win10 on my wife's new PC.

MS has certainly ruined the Win experience with Win10. OS is nothing
but a vehicle for pushing ads and apps down from "Microsoft Store"
and continually nagging one to use Edge. Should have stuck with Win7.

I'm very tempted to install Ubuntu, except that all of her friends
are using Win10. Maybe buy a second disk and/or try setting up
a virtual machine for Linux. Any comments for me on that?

Thanks,

tom


I also have Win10 installed but only for games. I like it not much. I use ubuntu MATE 16.04.4 LTS as my main system.

Cheers,
Christian
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.
User avatar
xeno74
 
Posts: 3730
Joined: Fri Mar 23, 2012 8:58 am

Re: Kernel 4.16

Postby xeno74 » Sun May 06, 2018 11:17 am

Hi All,

I compiled the stable kernel 4.16.7 for the X5000 and X1000 today.

Download: vmlinux-4.16.7-AmigaOne_X1000_X5000.tar.gz

PLEASE test it because it has been cross compiled and I don't know if it works on your AmigaOne.

Thanks,
Christian
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.
User avatar
xeno74
 
Posts: 3730
Joined: Fri Mar 23, 2012 8:58 am

Re: Kernel 4.16

Postby tbreeden » Wed May 09, 2018 3:31 am

I compiled the stable kernel 4.16.7 for the X5000 and X1000 today.
Download: vmlinux-4.16.7-AmigaOne_X1000_X5000.tar.gz
PLEASE test it because it has been cross compiled and I don't know if it works on your AmigaOne.


Hi Christian,

I'm not able to test on my X1000 right now.

It looks like I've got a hardware problem. Linux will not boot into any of the 3 separate
partions - Ubuntu 17.04, Ubuntu 16.04, SuseTumbleweed - using any of the
kernels that worked fine before.

Kernel loads and starts registering drivers, but either hangs or dumps some error info
apparently just after going through the USB hubs and ports.
Last stack trace contains some "snd-..." messages. Sound?

The AmigaOS partition boots about half the time, but a very long pause in it.

I guess I'll open up the case and fiddle around tomorrow. Take out the sound
card.

Tom :cry:
User avatar
tbreeden
 
Posts: 120
Joined: Sat Jun 18, 2011 1:57 am
Location: Charlottesville, VA, USA

Re: Kernel 4.16

Postby xeno74 » Wed May 09, 2018 6:13 am

tbreeden wrote:
Hi Christian,

I'm not able to test on my X1000 right now.

It looks like I've got a hardware problem. Linux will not boot into any of the 3 separate
partions - Ubuntu 17.04, Ubuntu 16.04, SuseTumbleweed - using any of the
kernels that worked fine before.

Kernel loads and starts registering drivers, but either hangs or dumps some error info
apparently just after going through the USB hubs and ports.
Last stack trace contains some "snd-..." messages. Sound?

The AmigaOS partition boots about half the time, but a very long pause in it.

I guess I'll open up the case and fiddle around tomorrow. Take out the sound
card.

Tom :cry:


Hi Tom,

Could you please post some error messages?

Maybe we can find a solution.

Thanks,
Christian
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.
User avatar
xeno74
 
Posts: 3730
Joined: Fri Mar 23, 2012 8:58 am

Re: Kernel 4.16

Postby xeno74 » Thu May 10, 2018 8:14 am

Hi All,

Here is the stable kernel 4.16.8 for the X5000 and X1000.

New:


Download: vmlinux-4.16.8-AmigaOne_X1000_X5000.tar.gz

Image

Cheers,
Christian
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.
User avatar
xeno74
 
Posts: 3730
Joined: Fri Mar 23, 2012 8:58 am

Re: Kernel 4.16

Postby tbreeden » Fri May 11, 2018 4:11 am

tbreeden wrote:
I'm not able to test on my X1000 right now.

It looks like I've got a hardware problem.

Hi Tom,

Could you please post some error messages?


Don't know how to stop the text during boot from scrolling off
the top of the screen.

At any rate, it was the sound card, since I got all my Linux partitions
back booting immediately after removing it.

That card was the one delivered with the X1000 since the built-in
sound driver was not working at the time of delivery. I switched
to the built-in sound when it became available (on AOS4), but never
removed to unused pci card.

:!: Kernel 4.16.8 gives no problems in my Ubuntu-17.04 X1000.
:!: Kernel 4.17-rc4 works just as well also.

Tom

Kernel 16.
User avatar
tbreeden
 
Posts: 120
Joined: Sat Jun 18, 2011 1:57 am
Location: Charlottesville, VA, USA

PreviousNext

Return to Platform: AmigaOne X1000 - Linux Only

Who is online

Users browsing this forum: No registered users and 8 guests