Images in Intuition menus

AmigaOS users can make feature requests in this forum.

Images in Intuition menus

Postby chris » Tue May 14, 2013 12:17 am

I'd like to be able to add custom images in individual Intuition/GadTools menu items.

This should be possible already, but since nobody can tell me how to do it, I'm assuming it's not actually implemented and therefore should be a feature request. (my previous thread with futile attempts to get this to work: viewtopic.php?f=26&t=94)
chris
 
Posts: 552
Joined: Sat Jun 18, 2011 12:05 pm

Re: Images in Intuition menus

Postby salass00 » Tue May 14, 2013 11:17 am

@chris

I just tried your code on my beta system and as you say it crashes on the LayoutMenus() call. I'll look into this and see if it's something that I can fix.

Edit:
Just found the problem. The bug was in CreateMenus() in the code that's supposed to check if the provided image is a BOOPSI image (non-BOOPSI images are copied to an internal buffer in CreateMenus()). Easy to fix once I saw it.
User avatar
salass00
AmigaOS Core Developer
AmigaOS Core Developer
 
Posts: 506
Joined: Sat Jun 18, 2011 4:12 pm
Location: Finland

Re: Images in Intuition menus

Postby chris » Thu May 16, 2013 6:51 pm

salass00 wrote:@chris

I just tried your code on my beta system and as you say it crashes on the LayoutMenus() call. I'll look into this and see if it's something that I can fix.

Edit:
Just found the problem. The bug was in CreateMenus() in the code that's supposed to check if the provided image is a BOOPSI image (non-BOOPSI images are copied to an internal buffer in CreateMenus()). Easy to fix once I saw it.


Thank you! This thread can be closed since it was actually a real bug.
chris
 
Posts: 552
Joined: Sat Jun 18, 2011 12:05 pm


Return to AmigaOS Feature Requests

Who is online

Users browsing this forum: No registered users and 6 guests