Page 1 of 1

Gorky 17 Config issue

PostPosted: Tue Dec 26, 2017 3:02 pm
by ralph.egas
I recently acquired a new Amiga X5000 from Amigakit. It has a Radeon HD 7700 and as far as I know, it has all necessary drivers.

When opening the Config utility, the display option shows only one entry: "Board 0:640x480 RGB16PC". The Descent Freespace config utility shows a whole bunch of modes, including "Board 0:1920x1200 ARGB32". Freespace runs like a charm. Gorky 17 does too, albeit at a mere 640x480 and without (MiniGL) hardware acceleration.

Anyone having had the same issue and got it fixed in the end?

Cheers,
Ralph

Re: Gorky 17 Config issue

PostPosted: Tue Dec 26, 2017 4:11 pm
by salass00
Have you bought and installed the Warp3D SI driver from AmiStore?

Re: Gorky 17 Config issue

PostPosted: Wed Dec 27, 2017 12:01 am
by ralph.egas
No, and nothing suggests I should have. I bought the Enhancer from A-Eon with my OEM X5000 and the fact that Descent freespace runs with hardware acceleration suggests I don't need anything extra. I'm also able to run Warp 3D based SDK samples, so this doesn't immediately hint at the fact I should acquire an extra driver.

So, just as a sanity check: do I really need to buy another driver from AmiStore *although* Freespace already enumerates all displays and accepts "MiniGL" as a valid option (instead of "Software")?

Re: Gorky 17 Config issue

PostPosted: Wed Dec 27, 2017 12:03 am
by ralph.egas
And while we're at it. Besides Warp3D, do I need to buy RadeonHD V1.7 and RadeonHD V2.10 as well? It's all very unclear what is and what isn't needed.

Re: Gorky 17 Config issue

PostPosted: Wed Dec 27, 2017 12:15 am
by ralph.egas
Alright. Update: bought the Warp3D driver like you suggested and that indeed did the trick. Thanks!

If you could shed a light on whether I also need to buy the other RadeonHD drivers I mentioned in previous post (although I know Hyperion ultimately isn't responsible for those, nor their support), that would be great!

Cheers,
Ralph

P.S. way to go on those lighting effects on main menu (now visible with that Warp3D driver; excellent stuff!)

Re: Gorky 17 Config issue

PostPosted: Wed Dec 27, 2017 8:41 am
by salass00
ralph.egas wrote:... do I need to buy RadeonHD V1.7 and RadeonHD V2.10 as well? It's all very unclear what is and what isn't needed.


You certainly don't need to buy both of them.

Since you can have access to higher screen modes like 1920x1080 you probably already have one of them (the Radeon HD driver that is included with AmigaOS itself has a limit on how big resolutions you can use and it doesn't support h/w compositing).

Depending on which release of Enhancer Software you have either the 1.x or 2.x RadeonHD driver (IIRC only the plus version of Enhancer Software has the 2.x driver). To check which version you have installed open a CLI and type in the command "version full RadeonHD.chip".

The only difference between 1.x and 2.x versions of the RadeonHD driver is that the 2.x driver supports compositing YUV graphics which is useful for video players and such (both MPlayer and Emotion can use it to accelerate video playback), whereas the 1.x drivers do not have this feature.