DVD drive disappears

AmigaOne X5000 platform specific issues.

DVD drive disappears

Postby radzikpl » Fri Jan 06, 2017 12:33 pm

I have interesting queston. When X5000 first time boots DVD drive is presen as wel for Media Toobox, AmiDVD.
But after warm reboot there is no more DVD in system... Of course after hard reboot DVD is present.

X5000 is bought as completely system.So far I did not change nothing in computer.
Attachments
dvd_02.png
DVD not working
dvd_01.png
DVD working
radzikpl
 
Posts: 11
Joined: Sun Jan 18, 2015 1:53 pm

Re: DVD drive disappears

Postby tonyw » Fri Jan 06, 2017 12:46 pm

Media Toolbox is trying to tell you what is wrong and asking for permission to fix it. Just click the "Yes" button, then select the disk device that says "Modified" in the right of the window and click "Save".After a warm reboot, all should be well.
cheers
tony
User avatar
tonyw
AmigaOS Core Developer
AmigaOS Core Developer
 
Posts: 1239
Joined: Wed Mar 09, 2011 2:36 pm
Location: Sydney, Australia

Re: DVD drive disappears

Postby thomasrapp » Fri Jan 06, 2017 12:51 pm

tonyw wrote:Media Toolbox is trying to tell you what is wrong and asking for permission to fix it. Just click the "Yes" button, then select the disk device that says "Modified" in the right of the window and click "Save".After a warm reboot, all should be well.


No, it doesn't! This message means that Media Toolbox recognised that the DVD drive has been removed. Letting it save the changes will only tell it to disregard the drive in the future which is exactly the opposite of what we need.
User avatar
thomasrapp
 
Posts: 239
Joined: Sun Jun 19, 2011 12:22 am

Re: DVD drive disappears

Postby ssolie » Fri Jan 06, 2017 9:54 pm

radzikpl wrote:I have interesting queston. When X5000 first time boots DVD drive is presen as wel for Media Toobox, AmiDVD.
But after warm reboot there is no more DVD in system... Of course after hard reboot DVD is present.

The p5020 SATA driver is still not finished in regards to ATAPI devices so I wouldn't worry about it. The current driver is just enough to boot the system and a little bit more but I wouldn't push it too far. Just don't expect everything to work in the ATAPI dept.

I'm working on an updated driver that will be better at ATAPI stuff but it is still in the works.
AmigaOS Development Team Lead
Be authentic. Get AmigaOS.
User avatar
ssolie
AmigaOS Core Developer
AmigaOS Core Developer
 
Posts: 1000
Joined: Mon Dec 20, 2010 9:51 pm
Location: Canada

Re: DVD drive disappears

Postby tonyw » Fri Jan 06, 2017 11:23 pm

thomasrapp wrote:This message means that Media Toolbox recognised that the DVD drive has been removed.


My mistake then. If that is so, then it could be caused by an intermittent SATA cable.
cheers
tony
User avatar
tonyw
AmigaOS Core Developer
AmigaOS Core Developer
 
Posts: 1239
Joined: Wed Mar 09, 2011 2:36 pm
Location: Sydney, Australia

Re: DVD drive disappears

Postby Amigo1 » Wed Feb 01, 2017 10:54 am

I can confirm this,

Happens here too.

But contrary to what it logically should do, even if I save the new configuration to the HD (means the DVD is not in the list of connected devices anymore) it still reads the media when a disk is inserted in the optical drive.
User avatar
Amigo1
 
Posts: 156
Joined: Sun Jan 01, 2012 4:32 pm

Re: DVD drive disappears

Postby Ribdevil » Sun Feb 05, 2017 4:09 pm

ssolie wrote:
radzikpl wrote:I have interesting queston. When X5000 first time boots DVD drive is presen as wel for Media Toobox, AmiDVD.
But after warm reboot there is no more DVD in system... Of course after hard reboot DVD is present.

The p5020 SATA driver is still not finished in regards to ATAPI devices so I wouldn't worry about it. The current driver is just enough to boot the system and a little bit more but I wouldn't push it too far. Just don't expect everything to work in the ATAPI dept.

I'm working on an updated driver that will be better at ATAPI stuff but it is still in the works.



Another strange issue. In every change of Cd, the device unit changes.
So, first cd insert = CD1:
Eject this and insert again: CD2:
Eject this and insert again: now CD3:


This is problem for me, cause I made a script to automatic update of my mp3 music cd database.
But whit this change of device don't works.

Virginio
User avatar
Ribdevil
 
Posts: 28
Joined: Tue Jun 28, 2011 8:11 pm

Re: DVD drive disappears

Postby ssolie » Mon Feb 06, 2017 9:49 pm

Ribdevil wrote:Another strange issue. In every change of Cd, the device unit changes...

That is normal behaviour right now. Like I said, I'm working on a new driver. Don't expect this one to behave with ATAPI devices. It is meant only for booting and installing the OS.
AmigaOS Development Team Lead
Be authentic. Get AmigaOS.
User avatar
ssolie
AmigaOS Core Developer
AmigaOS Core Developer
 
Posts: 1000
Joined: Mon Dec 20, 2010 9:51 pm
Location: Canada


Return to Platform: AmigaOne X5000

Who is online

Users browsing this forum: No registered users and 1 guest