Swapping ALT and AMIGA keys doesn't work

AmigaOne X5000 platform specific issues.

Swapping ALT and AMIGA keys doesn't work

Postby IamSONIC » Mon Apr 24, 2017 12:58 am

Hi,

i recently bought a Ducky Shine mechanical keyboard and everything works fine exept one thing. The swapping of the ALT and AMIGA keys doesn't work. I tried both ways:

a) SYS:Prefs/Input -> checked the option to swap the keys (also tried it without checking the option)
b) Added UBoot variable keymap_swapaltamiga with value "on"

The key mapping of the ALT and AMIGA keys remains.

Any help?
Thanks
IamSONIC
 
Posts: 11
Joined: Wed Aug 31, 2011 9:39 am

Re: Swapping ALT and AMIGA keys doesn't work

Postby nbache » Mon Apr 24, 2017 10:12 pm

Have you tried "keymap_swapaltamiga=off"? The newer machines default to "on", because they for some reason think everybody will buy those AmigaOne keyboards which need the swapping in order to work like a classical Amiga keyboard. So with other keyboards (pc types etc) you need to explicitly turn the swap off.

Best regards,

Niels
User avatar
nbache
Beta Tester
Beta Tester
 
Posts: 1183
Joined: Mon Dec 20, 2010 8:25 pm
Location: Copenhagen, Denmark

Re: Swapping ALT and AMIGA keys doesn't work

Postby IamSONIC » Tue Apr 25, 2017 12:48 am

No, haven't tried setting keymap_swapaltamiga to "off" before. I gave it a try but it doesn't work. Also in combination with the Options in SYS:Prefs/Input (tried on and off) it doesn't work.

Regards
Alex
IamSONIC
 
Posts: 11
Joined: Wed Aug 31, 2011 9:39 am

Re: Swapping ALT and AMIGA keys doesn't work

Postby tonyw » Tue Apr 25, 2017 7:16 am

You DID reboot after changing the NV setting, didn't you?

Type "nvgetvar" in a shell to get a proper list of the settings and check whether they have actually changed.
cheers
tony
User avatar
tonyw
AmigaOS Core Developer
AmigaOS Core Developer
 
Posts: 1186
Joined: Wed Mar 09, 2011 2:36 pm
Location: Sydney, Australia

Re: Swapping ALT and AMIGA keys doesn't work

Postby IamSONIC » Tue Apr 25, 2017 10:39 pm

@tonyw

yes i performed a reboot and even tried it with a cold boot after setting the environment variable. On X5000 (currently?) you can set UBoot vars only within the UBoot Shell. There is no NVSetVar AmigaOS command like on other Amiga Platforms (SAM, ...).

Before i connected the mechanical Keyboard i had a common PC Keyboard connected to the AmigaONE X5000 with that keyboard ALT and AMIGA switching worked fine by enabling swap keys in SYS:Prefs/Input settings.
IamSONIC
 
Posts: 11
Joined: Wed Aug 31, 2011 9:39 am

Re: Swapping ALT and AMIGA keys doesn't work

Postby nbache » Wed Apr 26, 2017 11:25 pm

In that case, it must be the keyboard which is somehow "weird". Maybe the Alt/Win keys are not emitting the keycodes expected by the keymap, or maybe one or both keys are wired to some internal logic in the keyboard which performs "special magic" on Windows machines, but is not recognized correctly under other systems.

I believe you can examine the actual keycodes emitted from each key with the help of Deniil's Allkeys program.

I'm not familiar with the technical details about how the swap is really working, so my assumptions may be totally wrong, of course.

Best regards,

Niels
User avatar
nbache
Beta Tester
Beta Tester
 
Posts: 1183
Joined: Mon Dec 20, 2010 8:25 pm
Location: Copenhagen, Denmark

Re: Swapping ALT and AMIGA keys doesn't work

Postby IamSONIC » Fri Apr 28, 2017 1:28 am

@nbache

Yes you're right. This "Ducky Shine 6" Keyboard must be somehow special... Because i configured now the Allkeys Utility and it still doesn't work :(

allkeys1.jpg
The codes the keyboard reports


allkeys2.jpg
My attempt to swap ˜˜the left AMIGA and ALT keys


Another interesting thing is, above the numeric keypad (so in the upper right corner of the keyboard) there are 4 "Multimedia" Keys, when i hit them Allkeys reports nothing. But this information only as a side note. Any idea about my main problem with the ALT and AMIGA key swapping?

Thank you very much for your help

Kind regards
Alex
IamSONIC
 
Posts: 11
Joined: Wed Aug 31, 2011 9:39 am

Re: Swapping ALT and AMIGA keys doesn't work

Postby broadblues » Fri Apr 28, 2017 9:55 pm

So if you suspect there is something "special" about this particular keyboard, have you tried a more generic one?
User avatar
broadblues
Beta Tester
Beta Tester
 
Posts: 417
Joined: Sat Jun 18, 2011 3:40 am
Location: Portsmouth, UK

Re: Swapping ALT and AMIGA keys doesn't work

Postby TSK » Mon May 01, 2017 2:18 pm

@IamSONIC

I have the same problem on A1-SE and a PS2 keyboard. Key swapping works with old keymap.libary.kmod v53.7 and a UBoot variable but not with the input Prefs setting and keymap.libary.kmod v53.9. (The key swap checkbox is disabled in input prefs with the v53.7 library.) If I remember the UBoot variable support was removed in newer versions of the keymap.libary.kmod so it won't work. Do you have access to the old library v53.7 ? I have made a bug report long time ago. I don't have this problem on X1000 and a Ducky Shine 3 USB keyboard. It's interesting that the problem exists with some keyboards only. I can't remember if I've been using the same Keytronic Wings PS2 keyboard all the time with my SE or if I swapped keyboards around the time AOS and the keymap.library were updated.

Do you have multiple keyboards you could test ?

I have reset broken on the SE and PS2 is not hot swappable and I don't want to power on and off the machine too frequently. It will take time for me to make any tests. I hope you could make some more testing !
Keep the party going !
User avatar
TSK
Beta Tester
Beta Tester
 
Posts: 215
Joined: Mon Dec 20, 2010 2:15 pm
Location: Home land of Santa C., sauna, sisu and salmiakki

Re: Swapping ALT and AMIGA keys doesn't work

Postby IamSONIC » Mon May 01, 2017 7:24 pm

broadblues wrote:So if you suspect there is something "special" about this particular keyboard, have you tried a more generic one?


Yes! As i wrote this problem only exists with the new Keyboard. With my old one i don't experience this kind of problem.
IamSONIC
 
Posts: 11
Joined: Wed Aug 31, 2011 9:39 am

Next

Return to Platform: AmigaOne X5000

Who is online

Users browsing this forum: No registered users and 1 guest