X5000 uBoot AmigaOS

AmigaOne X5000 platform specific issues.

X5000 uBoot AmigaOS

Postby daveyw » Tue May 30, 2017 9:41 am

Uh, I've been playing around with my uBoot settings, fiddling with Linux, and now I can't autoboot AmigaOS - I get <<<<Linux Running>>>> (even though it isn't) and I have to escape and select Boot AmigaOS.

Can someone fill me in on what the required uBoot variables are, or give me a list of their own uBoot settings?

Thanks!

Image
User avatar
daveyw
 
Posts: 144
Joined: Mon Sep 12, 2011 8:44 pm

Re: X5000 uBoot AmigaOS

Postby Amigo1 » Tue May 30, 2017 11:13 am

Hi!

5.Work-X5k:> nvgetvar
amigaboot_quiet=Y
amigabootmenu_default=0
baudrate=115200
bdev=sda3
bootargs=root=/dev/sda2 mem=3500M console=ttyS0,115200 console=tty0
bootargs_live=root=/dev/ramdisk boot=casper mem=3500M ro --
bootargs_live_debug=root=/dev/ramdisk boot=casper mem=3500M ro break debug
bootcmd=setenv bootargs root=/dev/$bdev rw console=$consoledev,$baudrate $othbootargs;tftp $loadaddr $bootfile;tftp $fdtaddr $fdtfile;bootm $loadaddr - $fdtaddr
bootdelay=10
bootdvd=scsi reset ; load scsi 0 2000000 boot_dvd ; bootm 2000000
bootfile=uImage
consoledev=ttyS0
eth1addr=00:1E:C0:F7:D7:6F
ethact=FM1@DTSEC4
ethaddr=00:04:A3:6B:44:7B
ethernetboot=echo Running Ethernet Boot
ethprime=FM1@DTSEC4
fdtaddr=c00000
fman_ucode=7fe71c00
harddiskboot=echo Running Hard Disk Boot
hwconfig=fsl_ddr:ctlr_intlv=cacheline,bank_intlv=cs0_cs1;usb1:dr_mode=host,phy_type=utmi;usb2:dr_mode=host,phy_type=utmi
linuxboot=echo Running Linux
liveusb=usb start ; setenv bootargs_live_debug ; ext2load usb 1:1 2000000 boot_dvd ; bootm 2000000
loadaddr=1000000
loadbmps=mmc read 0x10005000 0x500 0x200; mmc read 0x20000000 0x10000 0x20000
massboot=echo Running Mass Storage Boot
mos=bootmorphos
netdev=eth0
nfsboot=setenv bootargs root=/dev/nfs rw nfsroot=$serverip:$rootpath ip=$ipaddr:$serverip:$gatewayip:$netmask:$hostname:$netdev:off console=$consoledev,$baudrate $othbootargs;tftp $loadaddr $bootfile;tftp $fdtaddr $fdtfile;bootm $loadaddr - $fdtaddr
opticalboot=echo Running Optical Boot
preboot=run loadbmps;bmp d 0x20000000;ami
ramboot=setenv bootargs root=/dev/ram rw console=$consoledev,$baudrate $othbootargs;tftp $ramdiskaddr $ramdiskfile;tftp $loadaddr $bootfile;tftp $fdtaddr $fdtfile;bootm $loadaddr $ramdiskaddr $fdtaddr
ramdiskaddr=2000000
ramdiskfile=ramdisk.uboot
rootpath=/opt/nfsroot
scsidevs=1
stdin=usbkbd,serial
stdout=serial,vga
uboot=u-boot.bin
ubootaddr=0xFFF80000
5.Work-X5k:>
User avatar
Amigo1
 
Posts: 157
Joined: Sun Jan 01, 2012 4:32 pm

Re: X5000 uBoot AmigaOS

Postby smf » Tue May 30, 2017 12:04 pm

Hi.
i would start with setting:

amigabootmenu_default=0
smf
Beta Tester
Beta Tester
 
Posts: 85
Joined: Fri Nov 18, 2011 12:16 am


Return to Platform: AmigaOne X5000

Who is online

Users browsing this forum: No registered users and 2 guests

cron